Results 1 to 8 of 8

Thread: On system startup, current track starts again

  1. #1
    Newbie
    Join Date
    Aug 2005
    Posts
    31

    Question On system startup, current track starts again

    Sorry if this is actually a Winamp problem but I've searched the forums for these symptoms and nothing really came up similar.

    When my CarPC starts up (complete startup - not coming out of hibernate), RR is set to auto-start and when it comes up the track that was playing when the system was last shutdown begins playing.

    The problem is that the first second or two of audio plays the start of that track, then it "jumps" to the actual position within the track it got to at the time of shutdown.

    I've lived with it up until now but it's just a bit rough round the edges. I'm guessing it's the audio buffer/cache that Winamp keeps - can this be set to be flushed when Winamp closes/RR closes?

    aiml27

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    This is rather an "issue" with RR. Used to be RR would Tell Winamp to PLAY, Immediately PAUSE, set the "resume" position and then tell to PLAY again -- this provided PERFECT resume effects. But It was determined that such process did NOT work in many computers, and therefore a "prevention" procedure was put in place. Now RR waits for Winamp to start propperly responding to it's commands and requests before trying to set the position of the song -- that's what you're experiencing. You can easily try a different winamp version OR try the winamp resume plugin (I don't know anything about it, but I know some people use it). As a last note, the problem you're describing ONLY happens on the same machines where the "perfect" resume seems to NOT work propperly.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    Newbie
    Join Date
    Aug 2005
    Posts
    31
    Thanks Guino - I know you've got more crucial problems to tackle with RR, so I appreciate your response!

    I guess I'll live with it for the time being!

    aiml27

  4. #4
    Constant Bitrate
    Join Date
    Sep 2005
    Posts
    140
    This questions should probably be asked in a winamp forum, but I feel more comfortable here

    Like you said, maybe using another version of winamp would work. I was thinking of installing winamp 2.9.x but can older winamps use the same visualizations? I mean does 2.9 have the same visualization engine, because I love the visualizations that come with winamp 5.

    Sorry if that is off topic to this thread. I don't like to start new threads for something this trivial.

    I too experience this lag in resume time. That's why I want to try a different version. More importantly, I'm sick of winamp crashing! I just put a 'start winamp' button in my skin. I assume that this is the real reason that button was implemented, not to resume winamp after 'closing' it, like RRSkinEditor would like me to believe.

  5. #5
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    You can use winamp 5 with classic skin.
    I have no problem with it, but switch back to 2.9x for faster loading. Although, I use hibernate so that is not much different between the 2 versions.
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

  6. #6
    Newbie
    Join Date
    Aug 2005
    Posts
    31
    I'll add to that - I use Winamp 5.x with the classic skin.

    Thrasher - I too find that Winamp crashes - not while I'm using it, but every once in a while I have to uninstall and reinstall because it fails to start - it's nothing to do with RR (RR never fails to start successfully). A reboot doesn't help - it simply corrupts in some way.

    That's why I keep the install .msi for it in a temp folder on my carPC at all times, along with the latest RR version and a few other bits.

    aiml27

  7. #7
    Constant Bitrate
    Join Date
    Sep 2005
    Posts
    140
    I know it's not RR. Winamp has always been unstable on every computer I've used it with. I always used media player, even though the visualizations sucked, just because the music on my desktop or laptop is run in the background. In the car, however, its the main focus of the computer, so I like to run visualizations sometimes.

    I heard 2.9.x is more stable, but if it cant run the visualizations, I'll just put a start winamp button in my skin. But the only way having a computer in your car can be cooler than having a normal head unit, is if the computer is seamlessly integrated with your car's audio. If winamp crashes, cool factor goes immediately out the window.

    Also, slow load times when bringing up the audio_browser.skin don't help. Thats not as bad as the winamp crash, though.

  8. #8
    FLAC arebelspy's Avatar
    Join Date
    Sep 2005
    Location
    San Luis Obispo, CA
    Posts
    1,260
    Another person with this problem.. I'm using winamp 2.95 and would love if anyone posted a successful fix idea (resume plugin or whatever guino was talking about perhaps).

    -arebelspy
    See my trades here! My For Sale/Trade Thread. Email joe at eipse.com

    Quote Originally Posted by xdjxklusivex
    i think every thread is now a whoreing thread

Similar Threads

  1. GPS / Map Point current position
    By skippy76 in forum RR Bug Tracker
    Replies: 1
    Last Post: 10-09-2005, 11:42 PM
  2. Security System thoughts
    By techy101 in forum General MP3Car Discussion
    Replies: 0
    Last Post: 07-28-2005, 03:42 AM
  3. LAUNCH_ no sound hardware Prevents System Shutdown
    By rando in forum FP Bug Reports
    Replies: 12
    Last Post: 01-21-2005, 01:03 AM
  4. A few observations in OS and why I'm now using Windows 2003...
    By Mastiff in forum Software & Software Development
    Replies: 12
    Last Post: 01-21-2004, 09:11 AM
  5. Replies: 22
    Last Post: 08-13-2001, 01:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •