Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: XM works in Timetrax, not RR

  1. #11
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  2. #12
    The Last Good Gremlin GizmoQ's Avatar
    Join Date
    Nov 2004
    Location
    St Louis
    Posts
    2,347
    Quote Originally Posted by hank_kls65 View Post
    GizmoQ,

    On your Xm commander, are you running that with RR and if so, are you having any luck doing so. I am trying to use the same thing but I can only get it to work if I setup to not use xmpcr start/exit rr, then set for xmpcr, start/exit rr, then finally start rr. Strange, but that is the only way my xm works.

    Let me know what you are doing.

    Hank
    Like I just said in this thread (Powering XM Commander), I use the commander almost exclusively in RR. Quick and dirty recap of above thread - power the commander via external plug, setup RR for XMD, works flawlessly every day, everytime..... until XP decides to corrupt the driver which happens to me about every 9 months or so, but thats more a defrag issue.

    Read above thread for a more detailed answer.
    HARDWARE: Fujitsu Stylistic ST5111w/WiFi and dock, internal Hitachi 500G HD, external 1TB HD, Sierra Wireless Aircard 550, DVD-RW, BoomzBox HD radio, XM Commander, Delorme GPS, Saitek X-52 Pro joystick, BluSoleil Bluetooth, TPMS, FB, Elm327

  3. #13
    Newbie
    Join Date
    Dec 2004
    Posts
    51
    Quote Originally Posted by GizmoQ View Post
    All the time! RR doesn't care if its a commander or an XMD, it doesn't see any difference in my boxes. They may have changed something in the newer commanders (I haven't bought on in over a year) but the trick for me was initializing the USB driver. Its been a while but it sometimes would initialize as an HID Device and I had to manually update that so it would come up as a serial port.

    Otherwise, I know RR initializes the port at startup so I believe if you're running a fast PC or cut power to the Commander everytime you shutdown or both, RR is trying to initialize a box thats not ready. Try powering the external power connector, plug it into the commander, and run Timetrax to initialize it outside RR. Then close Timetrax, wait 10-15 seconds and run RR. Everything should work. I think I remember this issue once before, but since all mine are powered off the external connector it doesn't affect me.

    Another benefit of using the external power connector and FM modulator (at least for me) is I get to listen to the last XM station tuned without the PC or Commander headunit just by dialing it in on the headunit.
    My Commander is at least a year old, so I think we're dealing with the same hardware. To get it to work, I do the aforementioned TimeTrax open/close. I found out I can run Pyro's XMTest and it also works (faster to do this at the moment).

    I have the two types of boxes sitting right here and I'm only having problems with the Commander (same problem hank_kls65 is having). Both boxes work in TimeTrax, Pyro XMTest, Frodo, etc, but there is something wrong with RR that it doesn't initialize the Commander properly. I am using a serial connection; maybe since you use USB, your USB driver initializes the box (and not RR). Can you post the USB driver you are using? Maybe I'll make a cable tonight and test out the USB route.

  4. #14
    Newbie
    Join Date
    Dec 2004
    Posts
    51
    Quote Originally Posted by guino View Post
    If you make a log using portmon (www.sysinternals.com) I can try to work it out -- but without the unit to test it, it's not going to be simple. IF you do make the log, make sure it has time stamps and that it is showing the data in Hex
    Guino,

    Attached is the log, is it in the format you expected?

    Thanks for you help,
    Attached Files Attached Files

  5. #15
    The Last Good Gremlin GizmoQ's Avatar
    Join Date
    Nov 2004
    Location
    St Louis
    Posts
    2,347
    Quote Originally Posted by bruha View Post
    My Commander is at least a year old, so I think we're dealing with the same hardware. To get it to work, I do the aforementioned TimeTrax open/close. I found out I can run Pyro's XMTest and it also works (faster to do this at the moment).

    I have the two types of boxes sitting right here and I'm only having problems with the Commander (same problem hank_kls65 is having). Both boxes work in TimeTrax, Pyro XMTest, Frodo, etc, but there is something wrong with RR that it doesn't initialize the Commander properly. I am using a serial connection; maybe since you use USB, your USB driver initializes the box (and not RR). Can you post the USB driver you are using? Maybe I'll make a cable tonight and test out the USB route.
    Believe me serial is the best way to go! You didn't mention whether you tried the external power connector, I would assume the 12V constant in it keeps the initialization stored in memory somewhere allowing for instant on.
    HARDWARE: Fujitsu Stylistic ST5111w/WiFi and dock, internal Hitachi 500G HD, external 1TB HD, Sierra Wireless Aircard 550, DVD-RW, BoomzBox HD radio, XM Commander, Delorme GPS, Saitek X-52 Pro joystick, BluSoleil Bluetooth, TPMS, FB, Elm327

  6. #16
    Newbie
    Join Date
    Dec 2004
    Posts
    51
    Quote Originally Posted by GizmoQ View Post
    Believe me serial is the best way to go! You didn't mention whether you tried the external power connector, I would assume the 12V constant in it keeps the initialization stored in memory somewhere allowing for instant on.
    Yes, I've always used an external power connector for the XM Commander. I thought that may have been the problem, so thats why I tried power over the serial bus instead this weekend.

    Have you gotten an XM Commander to work with RR using the serial connection?

  7. #17
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Looking at the log you made it's basically what RR does to initialize it, the only difference are a few trailing bytes in there..

    Make sure the XMPCR option in RRConfig is NOT checked and try this version:
    http://www.rrdownloads.net/BETA/RoadRunner.exe

    I also would appreciate if somebody else with a standard XMD1000 could test it to verify it still works.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  8. #18
    Newbie
    Join Date
    Dec 2004
    Posts
    51
    Quote Originally Posted by guino View Post
    Looking at the log you made it's basically what RR does to initialize it, the only difference are a few trailing bytes in there..

    Make sure the XMPCR option in RRConfig is NOT checked and try this version:
    http://www.rrdownloads.net/BETA/RoadRunner.exe

    I also would appreciate if somebody else with a standard XMD1000 could test it to verify it still works.
    Guino,

    No luck with the new version. Looking at the Port Monitor, the last two strings RR is sending are different commands that what Pyro's XMTest is sending. Pyro sends:

    5A A5 00 03 74 00 01 ED ED
    5A A5 00 04 74 02 01 01 ED ED
    5A A5 00 03 74 0B 00 ED ED
    5A A5 00 05 00 10 10 10 01 ED ED
    5A A5 00 02 00 ED ED
    5A A5 00 06 10 02 01 00 00 01 ED ED

    Beta RR sends:

    5A A5 00 03 74 00 01 ED ED
    5A A5 00 04 74 02 01 01 ED ED
    5A A5 00 03 74 0B 00 ED ED
    5A A5 00 05 00 10 10 10 01 ED ED
    5A A5 00 06 10 02 01 00 00 01 ED ED (Pyro's last)
    5A A5 00 02 13 01 ED ED (different)

    Attached is a log with what is sent when the new beta RR is opened, closed, and then Pyro XMTest opened and closed.
    Attached Files Attached Files

  9. #19
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    I'm sorry to say but this right here does not make any sense according to any protocol specifications I've seen:

    5A A5 00 02 00 ED ED

    Header
    _____
    5A A5

    Size
    _____
    00 02

    There were supposed to be TWO bytes here.
    _____
    00 ??

    Tail Mark
    _____
    ED ED

    Also, looking at your log file, it shows me that the XM device IS indeed talking to RR (you didn't post any further communication on it though).

    All I can do is force the commands to be the same (by option), but this would be a jerry rig out of hell since I have no documentation or information that backs up that message up there.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  10. #20
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    ok, try the beta version again (I posted a new one). This time add this to RR.INI:

    xmcommander=true

    I still need people with regular XM to try the beta above (without makin any changes to settings).
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. XM Satellite Radio to Unveil XM Advanced Services at 2006 Consumer
    By Will Albers in forum General MP3Car Discussion
    Replies: 2
    Last Post: 03-27-2006, 08:49 PM
  2. RR Interchange - Update RR via a USB Media Stick
    By Gobby in forum Road Runner
    Replies: 60
    Last Post: 10-04-2005, 04:48 PM
  3. XM Problem. Runtime Error 5. Please help
    By BoyNextDoor in forum RR Bug Tracker
    Replies: 4
    Last Post: 09-01-2005, 06:51 PM
  4. IE in RR bug
    By accentsound in forum RR Bug Tracker
    Replies: 2
    Last Post: 07-10-2005, 01:21 PM
  5. XM Direct / PCR / TimeTrax - The saga continues.....
    By kingtut in forum General Hardware Discussion
    Replies: 4
    Last Post: 10-15-2004, 03:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •