Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: XM works in Timetrax, not RR

  1. #21
    Newbie
    Join Date
    Dec 2004
    Posts
    51
    Still no luck.

    One thing I should have mentioned, when I initialize the XM Commander with Pyros XMTest, I have XMPCR mode selected when I open RR. This has to be selected to get it to work on any RR version (10/8, 10/30, 10/31).

    I've attached one last log. It shows the port activity when I open XMTest, close it, open RR (10/31) with xmcommander=1 and xmpcr=1, and then open the XM radio skin. I open the radio skin at line 300.

    I've also tested version 10/30 of the beta version with the XMD1000 box and it still works.

    Thank you so much!
    Attached Files Attached Files

  2. #22
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    did you try it WITHOUT selecting the PCR option as I asked you to ? (the log shows otherwise).

    before I have to ask you this too, please try both WITH and WITHOUT the xmcommander option in RR.INI
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #23
    Newbie
    Join Date
    Dec 2004
    Posts
    51
    Yes I tried with and without the PCR option, the only time I can get it to work is with PCR selected (and I initialize with Pyros XMTest).

    Looking at the code Pyros XMTest sends (as opposed to PortMon logs) the following commands are sent:

    5A A5 00 03 74 00 01 ED ED (init)
    5A A5 00 04 74 02 01 01 ED ED (init)
    5A A5 00 03 74 0B 00 ED ED (init)
    5A A5 00 05 00 10 10 10 01 ED ED (power on)
    5A A5 00 02 13 00 ED ED (unmute)
    5A A5 00 06 10 02 01 00 00 01 ED ED (channel 1 change)

    So the 5A A5 00 02 00 ED command PortMon is showing must be a mistake as you pointed out. Looking at the 10/30 version of RR, which sends the correct lines I listed above, the only real difference is the unmute and channel change lines are reversed, do you think that matters?

    I'll run it without the xmcommander=1 in the INI this evening.

  4. #24
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    The release I'm posting has the lines in the exact same order as you posted, just make sure xmpcr is NOT checked in rrconfig.

    Please let me know what came out of this.

    Quote Originally Posted by bruha View Post
    Yes I tried with and without the PCR option, the only time I can get it to work is with PCR selected (and I initialize with Pyros XMTest).

    Looking at the code Pyros XMTest sends (as opposed to PortMon logs) the following commands are sent:

    5A A5 00 03 74 00 01 ED ED (init)
    5A A5 00 04 74 02 01 01 ED ED (init)
    5A A5 00 03 74 0B 00 ED ED (init)
    5A A5 00 05 00 10 10 10 01 ED ED (power on)
    5A A5 00 02 13 00 ED ED (unmute)
    5A A5 00 06 10 02 01 00 00 01 ED ED (channel 1 change)

    So the 5A A5 00 02 00 ED command PortMon is showing must be a mistake as you pointed out. Looking at the 10/30 version of RR, which sends the correct lines I listed above, the only real difference is the unmute and channel change lines are reversed, do you think that matters?

    I'll run it without the xmcommander=1 in the INI this evening.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  5. #25
    The Last Good Gremlin GizmoQ's Avatar
    Join Date
    Nov 2004
    Location
    St Louis
    Posts
    2,347
    Quote Originally Posted by bruha View Post
    Yes, I've always used an external power connector for the XM Commander. I thought that may have been the problem, so thats why I tried power over the serial bus instead this weekend.

    Have you gotten an XM Commander to work with RR using the serial connection?
    My development machine XMCommander worked fine. I ran a test this weekend while roadtripping in my son's car. Serial worked without problems until the computer went into hibernate. RR lost control of XM every time. (Son's car has serial connection, no external power, RR 10-08-06, 2 serial ports, 4 USBs connected) I'm almostsure the hihbernate problem could be resolved with external power, but I couldn't reproduce the problems you're having.

    Unfortunately, XM is one area on my development machine I haven't been as neat as I should. I have installed so many other XM programs that I can't actually identify why one works over another. I noticed some load drivers for VB6 so the VB runtimes have to be in place. Others require .Net while still others, replace MSvbvm60.dll and Mscomctl.ocx. My system also still has all the centrafuse required drivers like mdac, jet40sp8 and mdxredist.


    Out of curiousity, have you ever tried XtreMe PCR software. I was working with Frodo years ago to create this type functionality in FrodoXM, but I digress. Try it and see if it recognizes your XM port.

    As far as the USB driver, I can't find the download on my machine, but you can go to the TimeTrax website and download it yourself
    HARDWARE: Fujitsu Stylistic ST5111w/WiFi and dock, internal Hitachi 500G HD, external 1TB HD, Sierra Wireless Aircard 550, DVD-RW, BoomzBox HD radio, XM Commander, Delorme GPS, Saitek X-52 Pro joystick, BluSoleil Bluetooth, TPMS, FB, Elm327

  6. #26
    Newbie hank_kls65's Avatar
    Join Date
    Sep 2005
    Location
    Union City, PA
    Posts
    31

    XM Commander

    Quote Originally Posted by guino View Post
    The release I'm posting has the lines in the exact same order as you posted, just make sure xmpcr is NOT checked in rrconfig.

    Please let me know what came out of this.
    guino,

    can you provide a link to the beta with the changes that you were working on for bruha from 10-31-06. I want to test it with my xm commander also.

    Thank you,

    hank
    2005 Titan SE - TiPuter
    Commell LV-677 CoreDuo
    200G HD / 1G RAM
    Lilliput 629GL-70P
    Phoco/XMD1000/WinTv/
    BU-353 GPS/WiFi/Bluetooth
    DSATX

Page 3 of 3 FirstFirst 123

Similar Threads

  1. XM Satellite Radio to Unveil XM Advanced Services at 2006 Consumer
    By Will Albers in forum General MP3Car Discussion
    Replies: 2
    Last Post: 03-27-2006, 08:49 PM
  2. RR Interchange - Update RR via a USB Media Stick
    By Gobby in forum Road Runner
    Replies: 60
    Last Post: 10-04-2005, 04:48 PM
  3. XM Problem. Runtime Error 5. Please help
    By BoyNextDoor in forum RR Bug Tracker
    Replies: 4
    Last Post: 09-01-2005, 06:51 PM
  4. IE in RR bug
    By accentsound in forum RR Bug Tracker
    Replies: 2
    Last Post: 07-10-2005, 01:21 PM
  5. XM Direct / PCR / TimeTrax - The saga continues.....
    By kingtut in forum General Hardware Discussion
    Replies: 4
    Last Post: 10-15-2004, 03:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •