Results 1 to 8 of 8

Thread: Dynamic MUTE Command

  1. #1
    Variable Bitrate Mr.Fabio's Avatar
    Join Date
    Feb 2005
    Location
    Italy
    Posts
    261

    Question Dynamic MUTE Command

    Hi Everybody,

    Trying to add a mic slider in the mixer to keep control of my microphone, and i am using these commands :

    "VOL;Mic" to control the Microphone level & "MUTE:Mic" to Activate/Deactivate the Mic

    I am able to control only the level of the Mic, but i can't activate or deactivate the Mic.... Seems the Mute command is not responding..

    This is my debug.txt :

    18/04/2006 19.38.29: Start -- Version: 06/04/2006
    18/04/2006 19.38.29: Master Vol: Master Volume/4
    18/04/2006 19.38.29: GetLineControl Failed: 401
    18/04/2006 19.38.29: No Treble Support
    18/04/2006 19.38.29: GetLineControl Failed: 401
    18/04/2006 19.38.29: No Bass Support
    18/04/2006 19.38.29: Source: Wave=&H1008/1
    18/04/2006 19.38.29: Source: Sintetizzatore SW=&H1004/2
    18/04/2006 19.38.29: Source: ProfonditÓ 3D=&H100A/3
    18/04/2006 19.38.29: GetLineControl Failed: 401
    18/04/2006 19.38.29: No Mute for Source
    18/04/2006 19.38.29: Source: Mic=&H1003/4
    18/04/2006 19.38.29: Source: Linea in ingresso=&H1002/5
    18/04/2006 19.38.29: Source: CD Player=&H1005/6
    18/04/2006 19.38.29: Source: Video=&H100A/7
    18/04/2006 19.38.29: Source: Aux=&H100A/8
    18/04/2006 19.38.29: Source: Phone=&H1006/9
    18/04/2006 19.38.29: Source: Altoparlante PC=&H100A/10
    18/04/2006 19.38.29: Source: Wave=&H1008/11
    18/04/2006 19.38.29: GetLineControl Failed: 401
    18/04/2006 19.38.29: Can't Open Source
    18/04/2006 19.38.29: GetLineControl Failed: 401
    18/04/2006 19.38.29: No Mute for Source
    18/04/2006 19.38.29: Winamp window not found.
    18/04/2006 19.38.31: Shell: "C:\Programmi\Winamp\winamp.exe"
    18/04/2006 19.38.35: Sim.WMSGs: 1
    Fabio

    _______________________
    Travla C134
    Jetway J7F2WE 1Gb DDR2 - HD SATA 3.5" 80Gb + HD 2.5" 40Gb - Lilliput 7" TS - Holux GR-213 - Bluetooth - Belkin 802.11g WiFi - Silabs Radio - HTC Leo

    RoadRunner - PC Navigator 7.1 - FreeFone

  2. #2
    Maximum Bitrate DiNASTY's Avatar
    Join Date
    Mar 2005
    Location
    Concord, California
    Posts
    598
    Try it with a semi-colon or just a colon... I think there may be a typo in Skin Commands.txt

  3. #3
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    is't supposed to be ; ... nothing in .skin files that relates to codes uses : .. if the txt has a : then it's a typo.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  4. #4
    Variable Bitrate Mr.Fabio's Avatar
    Join Date
    Feb 2005
    Location
    Italy
    Posts
    261

    Unhappy

    Hi guys, thanks for your reply

    I had already tried with "MUTE;Mic" and i can confirm that does not work....
    I have also tested a different line, "MUTE;Wave" but the same...
    Others test at Home Pc with the same results....

    Guino, can you check the MUTE command?

    Thanks in advance for your help
    Fabio

    _______________________
    Travla C134
    Jetway J7F2WE 1Gb DDR2 - HD SATA 3.5" 80Gb + HD 2.5" 40Gb - Lilliput 7" TS - Holux GR-213 - Bluetooth - Belkin 802.11g WiFi - Silabs Radio - HTC Leo

    RoadRunner - PC Navigator 7.1 - FreeFone

  5. #5
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Just tested it here with both the WAVE and the MIC line.. both worked perfectly ... my guess is that your sound card/drivers either don't support it or are being blocked by another application controlling the mixer. I'm assuming you're using the same card on you home pc as well ? do you have any other sound card to try ? also try clicking on the word "WAVE" on the mixer of the BMV2 skin to see if it mutes/unmutes it.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  6. #6
    Variable Bitrate Mr.Fabio's Avatar
    Join Date
    Feb 2005
    Location
    Italy
    Posts
    261
    Quote Originally Posted by guino
    Just tested it here with both the WAVE and the MIC line.. both worked perfectly ... my guess is that your sound card/drivers either don't support it or are being blocked by another application controlling the mixer. I'm assuming you're using the same card on you home pc as well ? do you have any other sound card to try ? also try clicking on the word "WAVE" on the mixer of the BMV2 skin to see if it mutes/unmutes it.

    My sound cards are different.. In the car it's a VIA VT1616 6 channels AC'97 Codec with Vinyl Audio Drivers, and at my home it's a SoundBlaster Live.
    Naturally the debug info from RR are different for each system, and i had considered the names of the lines on both systems....

    With every skin i can activate/deactivate the standard lines, but not the mic....
    I'm going to test with different drivers on both the systems..

    Anyways thanks a lot
    Fabio

    _______________________
    Travla C134
    Jetway J7F2WE 1Gb DDR2 - HD SATA 3.5" 80Gb + HD 2.5" 40Gb - Lilliput 7" TS - Holux GR-213 - Bluetooth - Belkin 802.11g WiFi - Silabs Radio - HTC Leo

    RoadRunner - PC Navigator 7.1 - FreeFone

  7. #7
    Variable Bitrate Mr.Fabio's Avatar
    Join Date
    Feb 2005
    Location
    Italy
    Posts
    261

    Lightbulb Problem Found

    Ok guys,

    Finally i've found the solution...

    B,288,323,59,27,"MUTE;Mic" ----- THIS is working
    I,288,323,59,27,"MUTE;Mic" ----- THIS doesn't work!!!

    Guino, is this regular???
    Fabio

    _______________________
    Travla C134
    Jetway J7F2WE 1Gb DDR2 - HD SATA 3.5" 80Gb + HD 2.5" 40Gb - Lilliput 7" TS - Holux GR-213 - Bluetooth - Belkin 802.11g WiFi - Silabs Radio - HTC Leo

    RoadRunner - PC Navigator 7.1 - FreeFone

  8. #8
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    'I' are indicators -- only a handful are defined to handle the mute/unmute -- and you just specify the line name: "Wave", "Aux" etc..

    'B' are buttons -- the MUTE command only works on BUTTONS (Otherwise you'd see it under the indicator codes section of skin commands.txt).
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

Similar Threads

  1. SpeakEasy Voice Recognition - Beta 1
    By ruairi in forum Road Runner
    Replies: 31
    Last Post: 08-23-2006, 12:12 AM
  2. SpeakEasy Voice Recognition - Release 0.9.1
    By ruairi in forum Software & Software Development
    Replies: 11
    Last Post: 06-03-2005, 06:19 PM
  3. Problem with Audio Mute in MM/Road Runner
    By wizz in forum Map Monkey
    Replies: 5
    Last Post: 04-21-2005, 10:13 PM
  4. command line mute Toslink optical channel
    By rjoek in forum Software & Software Development
    Replies: 0
    Last Post: 01-26-2005, 06:19 PM
  5. Anyone understand Java ? I need help.
    By frodobaggins in forum Software & Software Development
    Replies: 31
    Last Post: 05-24-2004, 11:53 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •