Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Web Browser Keyboard

  1. #1
    Maximum Bitrate kpjuk's Avatar
    Join Date
    Dec 2003
    Location
    West Midlands
    Posts
    474

    Web Browser Keyboard

    I have skinned a brushed aluminium keyboard that works well with my skin, but not when I load Firefox or IE. As soon as I press a key on the keyboard, it sends the key to the browser, then disappears under the app. It works fine however with my External GPS. Am I doing something wrong ?

    I previously used the Microsoft OSK.EXE free with windows but found the keyboard size impractical for car use, and so with searching, found the virtual keyboard by I think Silent Admirer, which does most of what I want. . . . except for the Bl&&$% Web skin !

    Any ideas?

    cheers KPJUK
    M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
    DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    how are you loading the web screen, this is a very picky feature, you HAVE to use the WEB command, or you're on your own.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    Variable Bitrate NeoMatrixJR's Avatar
    Join Date
    Aug 2004
    Location
    Arround Des Moines, IA
    Posts
    258
    I've got an OSK prob too on my web browser. I'm using the MC2.0 skin/WEB command/Portable Firefox and it all seems to embed properly. When I open the osk to type in the address bar, google, etc. it only sends the last character typed. Any thoughts?

  4. #4
    Maximum Bitrate kpjuk's Avatar
    Join Date
    Dec 2003
    Location
    West Midlands
    Posts
    474
    I am using the following button to lauch the skin, but I have tried the longhand LOAD method as well, bith with the same results.

    B30,588,204,192,87,"WEB||RUN;skins\1Black\Keyboard \VirtualKeybd.exe","Firefox"

    would it be better to use the new onskinstart event to fire off the keyboard ?

    KPJUK
    M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
    DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

  5. #5
    FLAC
    Join Date
    May 2005
    Location
    Vienna, VA
    Posts
    1,375
    Wait, so you're using an external OSK and not RR's built-in OSK? You're pretty much on your own, then.

    onskinstart fires when you switch to another skin so it won't work here.
    iGMon - Integration between iGuidance and Road Runner
    CFX - Skin for Road Runner

  6. #6
    Maximum Bitrate kpjuk's Avatar
    Join Date
    Dec 2003
    Location
    West Midlands
    Posts
    474
    This OSK is the keyboard created by SIlentAdmirer, and used in a few skins. It works fine on other embedded apps, e.g. external GPS, but not with the Web browser. If I fire up Firefox or IE and then fire up the virtual keyboard then it works fine, but when either Firefox or IE are embedded, it disappears behind the app as soon as a key is pressed.

    I also have a "built in" OSK skin, but you lose site of the app fields behind the keyboard when you fire it up, which is not ideal.

    Previously I used the Microsoft OSK that comes free with windows, and that worked fine, but the keys on an 8" screen are just too small. The Virtual Keyboard created by one of the forum members is ideal, and can be easily skinned to suit the rest of your theme, it just behaves differently with an embedded browser, and I don't know why.
    KPJUK
    M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
    DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

  7. #7
    Maximum Bitrate kpjuk's Avatar
    Join Date
    Dec 2003
    Location
    West Midlands
    Posts
    474

    Keyboard now working

    Well, I have renamed the skins www.skin instead of wbrowser.skin, then done the longhand LOAD, and the keyboard now works !

    I will try firefox again to see if that and IE work in the renamed skin, and post my results.



    KPJUK
    Attached Images Attached Images  
    M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
    DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

  8. #8
    Maximum Bitrate kpjuk's Avatar
    Join Date
    Dec 2003
    Location
    West Midlands
    Posts
    474

    Sorted !

    The issue appears to have been with the skin name. When I use the name wBrowser.skin, the Virtual Keyboard doesn't work, but changing the skin name to www.skin and the problem goes away. I guess the skin name must have special meaning in RR, and is treated a different way.

    I can thoroughly recommend Virtual Keyboard from SilentAdmirer who I don't think comes here any more.

    I have re-skinned it with a Brushed Aluminium finish, and one of Mauri's skins also uses it if you don't like mine, or there is the original

    Good Luck to anyone else who wants to try it out.

    All three versions are attached :
    VirtualKeybd.zip Original version
    keyboard.zip Mauri's version
    OSK-BVOA.zip KPJUK Version
    Attached Files Attached Files
    M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
    DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

  9. #9
    Variable Bitrate NeoMatrixJR's Avatar
    Join Date
    Aug 2004
    Location
    Arround Des Moines, IA
    Posts
    258
    Well...as to my problem, I'm using the built in osk

  10. #10
    Maximum Bitrate kpjuk's Avatar
    Join Date
    Dec 2003
    Location
    West Midlands
    Posts
    474
    Hi Neo,

    try one of the options below !


    KPJUK
    M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
    DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

Page 1 of 3 123 LastLast

Similar Threads

  1. osk sends keys twice in web browser
    By liquid_smoke in forum RR Bug Tracker
    Replies: 16
    Last Post: 10-03-2006, 01:46 PM
  2. Help with visualizations, volume, and web browser
    By Bboy_jon in forum Road Runner
    Replies: 5
    Last Post: 04-28-2006, 01:19 AM
  3. RR 03-19-05 .. Web Browser ..
    By guino in forum Road Runner
    Replies: 67
    Last Post: 03-23-2005, 03:04 PM
  4. Replies: 2
    Last Post: 02-05-2005, 12:48 PM
  5. What's the ideal web browser over gprs?
    By M^ck^y in forum Wireless Communications
    Replies: 3
    Last Post: 11-20-2004, 03:59 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •