Page 11 of 37 FirstFirst ... 23456789101112131415161718192021 ... LastLast
Results 101 to 110 of 365

Thread: Auto switch to Guidance screen for iG?

  1. #101
    Constant Bitrate
    Join Date
    Sep 2006
    Location
    Sabattus, ME
    Posts
    222
    Quote Originally Posted by RPM_VR4 View Post
    You should be able to avoid #2 by adding a Clip-Reigon to your skin (in the same size/pos as the Vis).
    I have no idea what that means let alone how to do it. could you expand a bit?

  2. #102
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    I knew there had to be a good reason this thread has been on the front page for a while now.
    The first thing i would say is hats off to those who, what seems to be 2 separate solutions, working.
    I havnt tested either out, unsure of what is the most current version of either of the solutions.
    Someone should edit the first post in this thread though, with links and information so you dont have to dig through this thread to get everything going. I wasnt even aware anything was avail to even test cuz the first post is only a question.
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/rr-faq/
    mp3car live search

    i have joost invites, just hit me up for one.

  3. #103
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    Quote Originally Posted by MatrixPC View Post
    Alright guys, so far, I use it over the weekend and all work as expected. However, during development, I found a BIG BUG that I could NOT replicate (as I forgot exactly what I did). The problem is that you STUCK in GPS screen (the one that auto switch to), because RR keep execute "GPS" command. I can not go to any screen. I have to kill RoadRunner and re-start it.
    just want to confirm that i also have this bug right now. I havnt killed the RR process yet. I can give you some steps on what i did.

    Downloaded the modded RR.exe
    Loaded RR, i didnt change or add any settings to my RR.ini as i was in the middle of doing something else and knew i had to look through this thread to get the settings i need to add etc.
    I turned my volume all the way down almost to zero, but it was still a little too loud in my headphones, so i opened the volume mixer and dropped the wave volume down from 80% to about 10%, then i noticed RR switch to GPS screen.
    This is when i remembered i need to set this up.
    Tried to close the GPS screen and RR tries to switch but goes right back.
    Tried changing the volume back up to see if it will go back on its own but no dice.

    Ill try to repo it after i set everything up.
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/forumdisplay.php?f=93
    mp3car live search

    i have joost invites, just hit me up for one.

  4. #104
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    i can repro this everytime.

    Just change your wave volume to something other that what it was set to when RR starts seems to trigger the GPS command loop.

    This may be caused by the fact i dont have any of the settings that are to go into RR.ini not sure, ill test with them in a sec. If so maybe there needs to be some error checking that is none of those settings are present it will disable itself completely. I can see those not using IG as prime candidates for not having those settings present.

    I just loaded it now, with these settings
    lastscreenswitchtime=3
    pauseonvoice=true
    gpsonvoice=true

    and everything seems to be working ok, ill do some more testing later.

    I havnt read through the whole thread yet, but im sure someone's brought it up about having custom commands to execute for switching to GPS and lastscreen.
    If this is avail somewhere just ignore.
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/forumdisplay.php?f=93
    mp3car live search

    i have joost invites, just hit me up for one.

  5. #105
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,701
    Blog Entries
    1
    Quote Originally Posted by Chuck View Post
    ||SENDKEY;{RIGHT}{RIGHT}”

    "GPSIG","LOAD;EXTERNAL_GPS_ig.skin;Navigation;E:\P rogram Files\iNav\iGuidance\iGuidance.exe;iGuidance||SEND KEY;{RIGHT}{RIGHT}”
    That may work in iG 2.x but in 3.x It brings up the Trip meter Using {Space} seems to work ok, as iG doesn't use the space bar for anything. Oh, and thanks for the button code, works great with a label right over the button that either says Auto ON or Off
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  6. #106
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    Quote Originally Posted by liquid_smoke View Post
    i can repro this everytime.

    Just change your wave volume to something other that what it was set to when RR starts seems to trigger the GPS command loop.

    This may be caused by the fact i dont have any of the settings that are to go into RR.ini not sure, ill test with them in a sec. If so maybe there needs to be some error checking that is none of those settings are present it will disable itself completely. I can see those not using IG as prime candidates for not having those settings present.

    I just loaded it now, with these settings
    lastscreenswitchtime=3
    pauseonvoice=true
    gpsonvoice=true

    and everything seems to be working ok, ill do some more testing later.

    I havnt read through the whole thread yet, but im sure someone's brought it up about having custom commands to execute for switching to GPS and lastscreen.
    If this is avail somewhere just ignore.
    Now I can reproduce that bug. Thanks LS.
    Basically, RR reads wave volume on load/start up and when you change the volume in RR's MIXER screen.
    Because RR constantly monitor the volume level on the wave line, once there is a change, it execute GPS command. Now if you change the volume level with the system's mixer, there is a different between the value RR read and existing mixer setting. That throw you in a loops.
    Unlike system's mixer, iG save existing wave volume, set it own volume, play voice instruction, then restore wave volume.

    Okay, I'll try to re-read the system wave setting once coming out of GPS screen to prevent this problem. In the mean time, don't use system mixer to adjust wave volume, use RR Mixer instead.
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

  7. #107
    Maximum Bitrate Civic03's Avatar
    Join Date
    Dec 2005
    Posts
    605
    good stuff... waiting for release!

    PROGRESS 95%[//////////]Complete - Software configurations
    Current Task: Just adding on...
    Needed:wireless keyboard/mouse
    My Carputer Blog
    Car System Site

  8. #108
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    Alright guys,
    - I fixed the BIG bug as notice in couple posts above.
    - Added custom commands per suggestion by Chuck. Modify this command as you wish by define it in ExecTBL.ini file.

    IGAUTOGPS default it will execute GPS on voice direction and detection of Guidance screen. Change it to whatever command you like. One thing is that if you have full GPS skin, it a good candidate for loading that skin.
    IGAUTOGPSEXIT default will execute LASTSCR command. Change it to load any other skin instead of Last screen.
    IGPAUSE default will execute PAUSE command. Change it to suit other player that doesn't pause with PAUSE command.
    IGRESUME default will execute RESUME command. Change it to suit your need.
    - Add 1 more setting in RR.ini in addition to previous setting.
    igautosw=true|false. Default is true. If set to false, RR will NOT auto execute above commands regardless of other setting. This is the master setting wether you want the feature or not. The value can be change during run time by SETVAR;igautosw;true|false or SETVAR;igautosw;1|0

    lastscreenswitchtime is now has more time [5-30] seconds. Anything lower than 5 mean no switch back.

    I haven't send the file to anyone yet. Let me know if you want it so I can send it to you. PM me your addy if I didn't already has it. I try to upload to RR's FTP server but the server doesn't seem to allow me to connect.
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

  9. #109
    FLAC
    Join Date
    Apr 2005
    Location
    Queens, New York
    Posts
    1,386
    Matrix is there anyway to enable/disable this feature...I found that while was trying to do "other things" within the frontend it kept switching the the guidance screen, can we make a button of some sort to disable it?
    2002 Mitsubishi Galant
    Progress: 90% [-▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓- ->

    Carputer Specs:
    Via M10K
    512mb Ram
    60GB HDD
    Souund Blaster Audigy2 NX
    OPUS ITX PC Case


  10. #110
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    Quote Originally Posted by Cheekz185 View Post
    Matrix is there anyway to enable/disable this feature...I found that while was trying to do "other things" within the frontend it kept switching the the guidance screen, can we make a button of some sort to disable it?
    Yes, I encounter the same problem you did and thus this setting igautosw. By default it is set to true. But can be change with SETVAR;igautosw;false by skin button.
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

Similar Threads

  1. Replies: 4
    Last Post: 01-26-2006, 02:35 AM
  2. FS: IBM Thinkpad 1400, National Display Systems Screen
    By emailthis1 in forum Classified Archive
    Replies: 8
    Last Post: 10-02-2005, 02:02 PM
  3. Auto off switch
    By Ill1 in forum General Hardware Discussion
    Replies: 6
    Last Post: 01-17-2005, 02:50 PM
  4. auto start/shutdown with tower switch
    By HybridFox in forum General Hardware Discussion
    Replies: 4
    Last Post: 11-07-2004, 11:10 AM
  5. BMW pre-installed system - TFT ?
    By tsingsu in forum LCD/Display
    Replies: 11
    Last Post: 08-05-2002, 02:16 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •