Page 28 of 37 FirstFirst ... 1819202122232425262728293031323334353637 LastLast
Results 271 to 280 of 365

Thread: Auto switch to Guidance screen for iG?

  1. #271
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,166
    Blog Entries
    52
    Quote Originally Posted by JohnWPB View Post
    That Shouldn't be necessary... There's an option in AutoIt to do the pixel search based from the top left corner of the application, and NOT the screen. Therefore, the pixel location shouldn't change from one GPS screen to another, or even Skin to Skin for that matter.

    This would for instance get a pixel color from the top left of th IG screen, and not the entire screen:
    Code:
    WinActivate ("iGuidance")
    Opt("PixelCoordMode", 0)
    $Guidance = PixelGetColor( 61 , 109,)
    i tried this again and as i thought autoit cant get focus of iguidance when ignative is set to true. I even tried it with Opt("WinSearchChildren", 1)
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  2. #272
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    Sonic, this is the problem I posted in the earlier day of iGnative. If you can read RR's label with your app, you can use IGHWND label. It is a window handler for IG when iG is running regardless native or not. IGHWND is set to 0 when not running.

    I am not use how you use it with autoIt. Normally, that is the long value return back when you use any of windows api to look for an app.
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

  3. #273
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,166
    Blog Entries
    52
    Quote Originally Posted by MatrixPC View Post
    Sonic, this is the problem I posted in the earlier day of iGnative. If you can read RR's label with your app, you can use IGHWND label. It is a window handler for IG when iG is running regardless native or not. IGHWND is set to 0 when not running.

    I am not use how you use it with autoIt. Normally, that is the long value return back when you use any of windows api to look for an app.
    i can read the label but how does that allow me to activate ig's window so i can do a pixel search? Reading the label returns this to autoit:

    Code:
    IGHWND||459826
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  4. #274
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,166
    Blog Entries
    52
    wow... via dumb luck i was able to figure it out. i was also able to figure out how to read the ig screen when it not even visable. Gonna have to use that!
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  5. #275
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    seems to be some issues with the latest beta, everything was working fine before the code merger, now if i dont have IGAUTOGPS set in my ExecTBL.ini nothing will happen, and when i do have it set it switches to GPS on voice but never switches back.

    Ill do some more testing and try to narrow it down.
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/rr-faq/
    mp3car live search

    i have joost invites, just hit me up for one.

  6. #276
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    hm.... I don't have the code after guino merged with his.
    He said that he made a few change regarding to those commands. So far, my test show that it worked like before.
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

  7. #277
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    did he say what he changed or if we need to change anything on our end.

    the pause/resume works fine
    but nothing else seems to work for me now, i havnt changed anything but the update, ill keep playing with it.
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/forumdisplay.php?f=93
    mp3car live search

    i have joost invites, just hit me up for one.

  8. #278
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    I don't know, I just have to look at the actual code. The problem could be the custom command in ExecTBL.ini associate with those IGxx command. The default IGPAUSE=PAUSE should work fine.
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

  9. #279
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    well i got it to switch back by adding
    "IGAUTOGPSEXIT","LASTSCR"
    without it, it wont do anything.

    Just to clarify everything.

    my rr.ini
    igautosw=True
    pauseonvoice=True
    lastscreenswitchtime=5
    gpsonvoice=True

    if i remove any and all commands from ExecTBL.ini that are related to igautosw, the only thing that works still is the pause winamp when ig speaks.

    To get RR to switch to GPS i have to add
    IGAUTOGPS and IGAUTOGPSEXIT commands to ExecTBL.ini, even though its turned on in RR.ini
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/forumdisplay.php?f=93
    mp3car live search

    i have joost invites, just hit me up for one.

  10. #280
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,166
    Blog Entries
    52
    having the same issue and the igind seems to turn off and on on its own at times. if an instruction occurs within like 10 seconds of a previous one the indicator stays on throughout both instructions.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

Similar Threads

  1. Replies: 4
    Last Post: 01-26-2006, 02:35 AM
  2. FS: IBM Thinkpad 1400, National Display Systems Screen
    By emailthis1 in forum Classified Archive
    Replies: 8
    Last Post: 10-02-2005, 02:02 PM
  3. Auto off switch
    By Ill1 in forum General Hardware Discussion
    Replies: 6
    Last Post: 01-17-2005, 02:50 PM
  4. auto start/shutdown with tower switch
    By HybridFox in forum General Hardware Discussion
    Replies: 4
    Last Post: 11-07-2004, 11:10 AM
  5. BMW pre-installed system - TFT ?
    By tsingsu in forum LCD/Display
    Replies: 11
    Last Post: 08-05-2002, 02:16 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •