Page 32 of 37 FirstFirst ... 22232425262728293031323334353637 LastLast
Results 311 to 320 of 365

Thread: Auto switch to Guidance screen for iG?

  1. #311
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,170
    Blog Entries
    52
    the arrows are hard coded into the .swf file. There are currently two versions, one version has enlarged iguidance stock arrows on a charcoal background... the other version has the black arrows on yellow signs like the modified version of iG lsvoid uses. I'll take pics and go into details about it tomorrow.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  2. #312
    Variable Bitrate
    Join Date
    Jun 2006
    Posts
    348
    Sonic - and LS (since you did get this working)....

    I have all pieces in place, but working to skin it out. Do those addtoskin labels need to be in every skin page I want this shown? I am a little stuck but plugging away guys. LS maybe if you could post a single skin page and or hint that would help me, or the skin text and the screen shot.

    Sorry to bother but a great add and want to get it cooking.

    Thanks again ---

    Quote Originally Posted by Sonicxtacy02 View Post
    the arrows are hard coded into the .swf file. There are currently two versions, one version has enlarged iguidance stock arrows on a charcoal background... the other version has the black arrows on yellow signs like the modified version of iG lsvoid uses. I'll take pics and go into details about it tomorrow.

  3. #313
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,170
    Blog Entries
    52
    yes they need to be on every page you want the .swf file on. I'll have ls void working with it in a lil bit. wil post screenies
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  4. #314
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,170
    Blog Entries
    52
    ok here we go....

    my addon pulls the arrow from screen in the first attached image. I'm assuming this is as up to date as lsx is in terms of the iguidance skin. It changes the album art in attachment 2 (the pic of my daughter as i have no album art on this computer) into either the 3rd attachment (white arrow, arrowmode=0) or the 4th attachment (black arrow in yellow sign, arrowmode=1). I hope this gives an idea of how it worked. in terms of the igaddon.ini, i didnt change anything. here's how it looks:

    Code:
    [iGAddon]
    Xoffset=
    Yoffset=
    arrowmode=1
    that pulled the arrows in every skin fine for me. The problem is different computers need different offsets, so i cant tell you for sure what ur offset needs to be. What i'm gonna try to do today is add a box to debug mode that needs to be aligned with the 96x96 iguidance arrow box.

    LS, are you using a video card on the comp that it didnt work? All the computers i used with onboard video worked, but the one that had a video card needed an offset adjustment.
    Attached Images Attached Images     
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  5. #315
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,170
    Blog Entries
    52
    ok i uploaded a new version with a PIXELHUNT mode that will help you find your arrow box. Read the readme for information.

    www.sonicxtacy.com/igaddon.rar

    If this stuff should be posted in its own thread just let me know.. not tryin to intrude
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  6. #316
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    Quote Originally Posted by Sonicxtacy02 View Post
    ok here we go....

    my addon pulls the arrow from screen in the first attached image. I'm assuming this is as up to date as lsx is in terms of the iguidance skin. It changes the album art in attachment 2 (the pic of my daughter as i have no album art on this computer) into either the 3rd attachment (white arrow, arrowmode=0) or the 4th attachment (black arrow in yellow sign, arrowmode=1). I hope this gives an idea of how it worked. in terms of the igaddon.ini, i didnt change anything. here's how it looks:

    Code:
    [iGAddon]
    Xoffset=
    Yoffset=
    arrowmode=1
    that pulled the arrows in every skin fine for me. The problem is different computers need different offsets, so i cant tell you for sure what ur offset needs to be. What i'm gonna try to do today is add a box to debug mode that needs to be aligned with the 96x96 iguidance arrow box.

    LS, are you using a video card on the comp that it didnt work? All the computers i used with onboard video worked, but the one that had a video card needed an offset adjustment.
    yes, all my comps including the car have real video cards, all nvidia.
    I tried the pixel hunt mode and i found my offset (-2) didnt have to move the grey box much at all, maybe a pixel or 2.
    Still no dice on the arrows though. Odd that a video card would cause this, would you mind if i looked at the source?
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/rr-faq/
    mp3car live search

    i have joost invites, just hit me up for one.

  7. #317
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,170
    Blog Entries
    52
    sure i'll send it to you.. keep in mind its messy still lol. did you move the box up or down? I'm gonna test pixelhunt in my car when i leave work today.. it too has an nvidia card.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  8. #318
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,170
    Blog Entries
    52
    there seems to be something wrong with my pixel hunter script. i tried it in the car (nvidia card) and it gave me a -6 offset but the tested wroking offset is 3. If you dont mind do me a favor and open iguidance embedded, then open the autoit info tool and tell me what is the Y coordinate for the bottom of the top green bar that gives the turn street name in window coord mode. On my carputer its 38.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  9. #319
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    114 not embedded with Window cord mode
    61 embedded with Window cord mode
    40 embedded with Screen cord mode

    im getting the numbers from moving my mouse pixel by pixel to the bottom of the top green bar and watching the pixel color till it changes to green.

    other details
    embedded

    Title: iGuidance
    Class: IntellinavWCls
    Size: X: -1 Y: -21 W: 802 H: 389

    not sure why X is -1 and the width is 802 instead of 0, 800 (this is prob from ignative resizing)
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/forumdisplay.php?f=93
    mp3car live search

    i have joost invites, just hit me up for one.

  10. #320
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,170
    Blog Entries
    52
    ok looks like you'll need an x offset too. Try -1 y offset and 1 x offset. I'm gonna have to find a better way to find that damn blue box . As an update though i can now successfully read the distance to turn box . I should have the bottom boxes too later today (ETA n such). I'm avoiding to next turn street label cause coding ALL letters is gonna be a pain! lol

    if ANYONE can think of a better method of finding that box please let me know. The color and size numbers are absolute, the only problem is how to find the x and y positions.

    added a screenie after changing a few things in lsx.. when direction is detected the track name turned into my custom label. hows that for integration

    my only issue now.. well at this point in time is keeping that label up to date with iguidance when iguidance's screen is hidden. i need a formula that will use GPSSPD to update the label until the iguidance screen is visable again.
    Attached Images Attached Images  
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

Similar Threads

  1. Replies: 4
    Last Post: 01-26-2006, 02:35 AM
  2. FS: IBM Thinkpad 1400, National Display Systems Screen
    By emailthis1 in forum Classified Archive
    Replies: 8
    Last Post: 10-02-2005, 02:02 PM
  3. Auto off switch
    By Ill1 in forum General Hardware Discussion
    Replies: 6
    Last Post: 01-17-2005, 02:50 PM
  4. auto start/shutdown with tower switch
    By HybridFox in forum General Hardware Discussion
    Replies: 4
    Last Post: 11-07-2004, 11:10 AM
  5. BMW pre-installed system - TFT ?
    By tsingsu in forum LCD/Display
    Replies: 11
    Last Post: 08-05-2002, 02:16 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •