Page 5 of 13 FirstFirst 12345678910111213 LastLast
Results 41 to 50 of 126

Thread: How do I get the Car2PC adapter to work in RR?

  1. #41
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    Currently, the Supra installation was out of commission. Everything is on the shelf during the process of redoing the install. I can't test which command works nor doesn't work.
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

  2. #42
    Low Bitrate
    Join Date
    Jul 2005
    Posts
    74

    Recompiled Car2PC.exe

    Attached are two programs myhutest.exe will test your car2pc interface, you should see a list of commands, which will change as you press buttons on your headunit.

    There is also a modified version of car2pc.exe the origional kept sending commands to roadrunner which caused problems. Shuffle and Repeat constantly changing.

    It now only sends commands when a button is pressed.

    Here is my exectbl.ini

    "BBAA","SETVAR;MUSICPATH;C:\Users\jgc\Music\||LOAD ;audio_browser2.skin||VISEMBED"
    "TRAFFIC","LOAD;traffic.skin||VISEMBED"
    "WEATHER","LOAD;weather.skin"
    "WMAP1","SETFLASHVAR;MAPVAR;weather\\temp.swf||LOA D;weather_map.skin||VISEMBED"
    "WMAP2","SETFLASHVAR;MAPVAR;weather\\radar.swf||LO AD;weather_map.skin||VISEMBED"
    "WMAP3","SETFLASHVAR;MAPVAR;weather\\sat.swf||LOAD ;weather_map.skin||VISEMBED"
    "TRAFFICDATA","RUNW;$SKINPATH$traffic\traffic data updater.exe"
    "WEATHERDATA","RUN;$SKINPATH$weather\WeatherDownlo ader.exe"
    "VISEMBED","RUN;;$WVIS$"
    "NAVVIS","RUN;$skinpath$skinbedder\ig3.exe;minig|| SETVAR;WVIS;minig"
    "VISNEXT","RUN;$SKINPATH$vis changer\switchvis.exe"
    "VISPREVIOUS","RUN;$SKINPATH$vis changer\switchvisp.exe"
    "ONSONGSTART","RUNQ;$RRPATH$ratings\ratecheck. exe"
    "Rate5","RUNQW;$RRPATH$Ratings\ratecheck.exe||RUNQ ;$RRPATH$Ratings\ratings.exe|5"
    "Rate4","RUNQW;$RRPATH$Ratings\ratecheck.exe||RUNQ ;$RRPATH$Ratings\ratings.exe|4"
    "Rate3","RUNQW;$RRPATH$Ratings\ratecheck.exe||RUNQ ;$RRPATH$Ratings\ratings.exe|3"
    "Rate2","RUNQW;$RRPATH$Ratings\ratecheck.exe||RUNQ ;$RRPATH$Ratings\ratings.exe|2"
    "Rate1","RUNQW;$RRPATH$Ratings\ratecheck.exe||RUNQ ;$RRPATH$Ratings\ratings.exe|1"

    /, Car2PC Interface Support
    "HUSTART","RESUME"
    "HUSTOP","PAUSE"
    "NT ","RRNEXT"
    "PT ","RRPREV"
    "PA ","PLAY"
    "FF 1","RRNEXT"
    "FR 1","RRPREV"
    "DS 001","LOADLIST;C:\playlists\all.m3u;All Music"
    "DS 002","LOADLIST;C:\playlists\dance.m3u;Dance"
    "DS 003","LOADLIST;C:\playlists\favourites.m3u;Favouri tes"
    "DS 004","LOADLIST;C:\playlists\modern.m3u;Modern"
    "DS 005","LOADLIST;C:\playlists\soul.m3u;Soul"
    "DS 006","LOADLIST;C:\playlists\Reggae.m3u;Reggae"
    "MX 0", "SHUFFLE"
    "MX 1", "SHUFFLE"
    "RP 0", "REPEAT"
    "RP 1", "REPEAT"
    Attached Files Attached Files

  3. #43
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    awesome, thanks!
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  4. #44
    Low Bitrate
    Join Date
    Jul 2005
    Posts
    74
    Found a bug in my code heres a version that doesnt crash
    Attached Files Attached Files

  5. #45
    Newbie Headshot12's Avatar
    Join Date
    Oct 2006
    Location
    DFW Texas
    Posts
    8
    Thanks, clarkie - I was attempting to use MS C++ Express and was getting nowhere
    What manner of man are you that can summon up fire without flint or tinder?

  6. #46
    Car Audio Moderator durwood's Avatar
    Join Date
    Sep 2006
    Location
    Chicagoland (St. Charles,IL)
    Posts
    2,028
    Thanks Clarkie. I'll give this a try.

  7. #47
    Car Audio Moderator durwood's Avatar
    Join Date
    Sep 2006
    Location
    Chicagoland (St. Charles,IL)
    Posts
    2,028
    I gave this a test yesterday and it does work finally, however there are way to many issues to list on what is happening. Just a few:

    -Time and track on my factory display jumps all over the place
    -Sometimes the button presses don't work.
    -Button presses are delayed
    -Pressing next track might cause it to advance more then one track (I think this one is an issue with the adapter or driver and not the car2pc.exe since I had this issue with the winamp plugin too.)

    These are all problems that I see when it's actually connected to my HU. Is anyone else having problems? At least it's doing something now with RR. Thanks again Clarkie.

  8. #48
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    humm.. mine is a little lagging and always fails the first command ONLY -- but I'm pretty sure it's because of the PIE adapter I use... is that what you're using too? or are you beta testing one of the units I've been waiting for ?
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  9. #49
    Car Audio Moderator durwood's Avatar
    Join Date
    Sep 2006
    Location
    Chicagoland (St. Charles,IL)
    Posts
    2,028
    I've got the new mazda one you are waiting for. I thought jbors said he sent you one??? That sux you haven't gotten it yet.

  10. #50
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    Finally, I was able to put the carPC back in the Supra.
    So far, before the disassemble, I packup the driver/RR and stuff on a partition HD. But that was lost because of my stupid mistake on a keystroke.
    So no biggy right?
    I went a head and install everything. New driver for the car2PC adapter + latest version of RR (4/11/07). But I am using the older car2PC.exe cuz the newer version doesn't seem to work on first try. May look back later.
    Upon playing with it so far, the following command work.
    "NT", Next Track work fine.
    "PT", Previous Track. Doesn't work, it execute the Play/Pause command instead.
    All other command work.
    What really supprise me is that when I use myhutest.exe to test the command send by the HU. NT, PT send fine whereas DS 003 (Disk 3 button) doesn't work. With RR, DS 003 works. That is really weird.
    Now time for me to dig out that driver disk and try again.
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

Similar Threads

  1. RR and Radio - Don't work the scan indicator
    By slimmegane in forum Road Runner
    Replies: 1
    Last Post: 11-27-2005, 04:13 PM
  2. Repeat Doesn't Work for Winamp / RR
    By mousejunior in forum Road Runner
    Replies: 3
    Last Post: 06-16-2005, 02:51 PM
  3. tv in rr not work
    By manung in forum Road Runner
    Replies: 8
    Last Post: 05-13-2005, 01:10 PM
  4. One more time: Will this car adapter work?
    By S4Per in forum Power Supplies
    Replies: 3
    Last Post: 02-02-2004, 03:31 PM
  5. VGA to RCA adapter... will this work?
    By 700mx6 in forum Newbie
    Replies: 6
    Last Post: 01-10-2004, 09:46 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •