Results 1 to 9 of 9

Thread: How to set RoadRunner startup volume?

  1. #1
    Maximum Bitrate
    Join Date
    Nov 2005
    Posts
    597

    How to set RoadRunner startup volume?

    Hey,

    Ive searched but cant seem to find this anywhere.

    Is there any way to set the RR startup volume?
    Perhaps in the .ini file?

    I dont want it starting at 100% each time and tearing my head off. And I dont want it to start from the previous setting either.

    Cheers
    Ice

  2. #2
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,173
    Blog Entries
    53
    an easy way would be to put the SETVOL command in your STARTCOMMAND in rr.ini. You do it like SETVOL;MASTER;50 (setting the main volume to 50%)

    as far as i know though rr doesnt change the volume from wherever it was prior to rr starting. Sometimes with external sound cards the lines are crossed and it does some funky stuff with the wave, line-in, and master lines.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  3. #3
    Maximum Bitrate
    Join Date
    Nov 2005
    Posts
    597
    Thanks. worked perfectly
    (and when I searched for correct use of STARTCOMMAND I found a thread for setvol .. couldnt find it before ).

    Anyway, for anyone else interested in this, I have RR set to control the MASTER line.. so I added the following line to RR.ini to make it start at volume level of 50:

    STARTCOMMAND=SETVOL;MASTER;50

  4. #4
    Newbie
    Join Date
    Jun 2006
    Posts
    38
    it does alter th evolumne on the new version, i know 2 other people who have had this trouble, and this is the reason why i went back to an old version.

  5. #5
    Maximum Bitrate
    Join Date
    Nov 2005
    Posts
    597
    Well, it sorta works.
    I'm running Freedom 2.0 and I hear the intro noise playing at whatever volume it was on when RR previously exited and after about 2 seconds the volume gets set to 50 (the intro noise is still playing a little). Is there any way to force RR to set the volume at the very beginning?

    I even have the STARTCOMMAND as the first line of my .ini

  6. #6
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,173
    Blog Entries
    53
    startcommands position doesnt really matter and the reason you're having that problem is because freedom isnt playing that intro thru rr its playing it thru flash. I'm not sure flash plays thru the master, it might play thru wave or some other line(pretty sure its wave). Try this

    Code:
    STARTCOMMAND=SETVOL;MASTER;50||SETVOL;WAVE;50
    if that does nothing then turn your wave volume down and start rr. If the sound of the intro goes down you know its the wave line thats the problem.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  7. #7
    Maximum Bitrate
    Join Date
    Nov 2005
    Posts
    597
    Sonic> you are correct. It does come out on the Wave line.

    So is there any way to get RR to control the volume of MASTER the instant it starts up .. rather than as a startup command? (ie: once RR gets running.. its a tiny bit too late).

  8. #8
    Maximum Bitrate Jarrod's Avatar
    Join Date
    Jan 2002
    Location
    Melb, Australia.
    Posts
    475
    Maybe try changing the volume on shutdown instead of startup, not sure how exactly, but it would be a better solution.
    Jarrod - Holden VX S!

  9. #9
    Maximum Bitrate
    Join Date
    Nov 2005
    Posts
    597
    cheer Jarrod.

    I did think of that (but unsure how to). It could possibly lead to problems for other programs using Wave though. If Wave is re-adjusted back to loud by another program, then I get the same problem again when RR starts.

    Ive asked CdR if the music can be mutable in his next release.

Similar Threads

  1. How to set master volume to 3% after hibernation?
    By slimmegane in forum Road Runner
    Replies: 5
    Last Post: 09-01-2006, 10:27 AM
  2. Feature Request: Advanced Volume Control
    By skeeter007 in forum Road Runner
    Replies: 6
    Last Post: 03-20-2006, 06:23 PM
  3. Released: BETA 10
    By skippy76 in forum Road Runner
    Replies: 169
    Last Post: 03-07-2006, 11:53 AM
  4. Winamp volume problems
    By froop in forum Road Runner
    Replies: 9
    Last Post: 09-17-2005, 12:02 PM
  5. Replies: 6
    Last Post: 11-12-2003, 10:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •