Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Problem with OSK, Need a "Delay"

  1. #1
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,689
    Blog Entries
    1

    Problem with OSK, Need a "Delay"

    I created a Playlist skin, that one someone presses a button, it invokes the OSK to enter the playlist name. I then want a pop-up dialog to confirm the playlist was saved. It works fine, to enter the name, and click "Ok". However when I add the command to pop-up the confirmation for 1.5 seconds, the OSK Appears, and immediately dissappears, and is replaced with the confirmation dialog for the 1.5 seconds.

    Is there a way I can get RR to wait till the information is typed in the OSK, before continuing?

    Here is the line of code I am using:
    Code:
    "SAVELIST||SETPATH;$PLAYLISTPATH$||Menu;PlaylistSaved.skin||wait;1.5||EXIT"
    This works perfectly, when someone clicks an existing Playlist to add the songs to. Here is that line, and it works perfectly:
    Code:
    "SETVARBYCODE;LISTTEXT;LISTTEXT||SAVELIST;$PLAYLISTPATH$$LISTTEXT$"||Menu;PlaylistSaved.skin||wait;1.5||EXIT"
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    you have to use OSKTOCMD -- in your case you'll need to throw that into a variable and then execute the commands from the OSKTOCMD parameters, check skin commands.txt.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,689
    Blog Entries
    1

    Saving Playlist from a variable

    I tried the OSKTOCMD, the code is as follows:
    "OSKTOCMD;ListName;SAVELIST;$PLAYLISTPATH$$ListNam e$.m3u"
    and it works fine.

    BUT, when I try to add the command to pop the menu up for 2 seconds, it again skips the keyboard, and goes directly to the confirmation pop-up menu, and then exits in 2 seconds Here is the code:
    "OSKTOCMD;ListName;SAVELIST;$PLAYLISTPATH$$ListNam e$.m3u||Menu;PlaylistSaved.skin||wait;2||EXIT"
    (Ignore the spaces in the above code, thats just the forum doing it magic...)

    It does exactly what the SAVELIST command did by itself, and does not pause and wait for input. I also tried the OSKTOVAR with the same results.... it just is not pausing and waiting for input....





    Also, I am trying to append the songs, in the currently loaded (or on-the-fly playlist) to another file using the new ADDTOFILE command. How do I pull the current playlists songs into a variable?

    I just can't figgure what variable/command the actual song list is in, it's not PLAYLIST, thats the name of the list, its not LIST, tried that....




    .
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  4. #4
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    you cant put || into osktocmd, so if you want multiple commands to execute with it, you'll HAVE to put them in exectbl:

    "OSKTOCMD;ListName;MYSAVE"

    Exectbl:
    "MYSAVE","SAVELIST;$PLAYLISTPATH$$ListName$.m3u||M enu;PlaylistSaved.skin||wait;2||EXIT"
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  5. #5
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,689
    Blog Entries
    1
    Ok Guino, thats twice in 24 hours you have hit me with something that didn't work, (Don't feel bad, Chuck did the same thing to me yesterday). So Far, I'm 3 for 3! I just don't think I am meant to get this to work!

    Don;t get me wrong, I DO appreceite the help, it's just that this is so frustrating. With any other language, C, VB, Perl you name it, there are forums, books, and lots of places to go and learn by example. With RR it is just a few select people in the forums that I can bug, when something goes wrong



    Ok, I stripped the code down, and simplified it for testing

    Here is the Button command I am using:

    "OSKTOCMD;PLFileName;SaveNewList"


    This is what I have in the ExecTBL.ini:

    "SaveNewList","SAVELIST;$PLAYLISTPATH$$PLFileName$ "


    What is happening, is when the button is pressed, the OSK comes up, and I enter in some text, when I press enter, a "$PLFileName$.m3u" file is created. For some reason the PLFilename contents is not getting carried over, once the command in the ExecTBL.ini is called up.

    I tried placing a ; in between the SAVELIST variables, then all I get is a .m3u file in the playlist folder, no name, just the extension.


    Also, I am trying to append the songs, in the currently loaded (or on-the-fly playlist) to another file using the new ADDTOFILE command. How do I pull the current playlists songs into a variable?



    .
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  6. #6
    FLAC Chuck's Avatar
    Join Date
    Sep 2003
    Location
    Ellicott City, MD
    Posts
    1,671
    this worked for me

    How do I pull the current playlists songs into a variable?
    SETVARBYCODE
    2001 S10 ZR2

    Chucks Skin - to old

  7. #7
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,689
    Blog Entries
    1
    Chuck, the code in bold above worked for you??!?! I have been going in circles! You made NO changes or anything to it? Did you verify that the name you typed in the OSK, was actually saved in your Playlist folder?


    Quote Originally Posted by JohnWPB View Post
    I just can't figgure what variable/command the actual song list is in, it's not PLAYLIST, thats the name of the list, its not LIST, tried that....
    .
    I've got that part...

    "SETVARBYCODE;MyPlayListName;XXXXX"

    but I don't know the "code name" (X's above) to use to call it into a variable. It's not Playlist, like one would think, as that is the actual name of the playlist itself EA: "Favorites"




    .
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  8. #8
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    this works for me also.
    I was also having the same problem, but OSKTOCMD didnt work at first either.
    If you put them in the ExecTBL it works though.

    My code is this

    button code:
    Code:
    "OSKTOCMD;FREE50;SAVECUSNAME01"
    ExecTBL.ini
    Code:
    "SAVECUSNAME01","SETVARBYCODE;FREE50;$FREE50$||RELOADRR"
    I stuck the RELOADRR in there so i know for sure that the OSK is waiting, else it will restart RR


    [edit]

    that dosent work either, ill have to play with it a bit.
    it kind of worked in that the OSK waited, but the OSKTOCMD failed to actually set the var at all so the code dosnt work.
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/rr-faq/
    mp3car live search

    i have joost invites, just hit me up for one.

  9. #9
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,689
    Blog Entries
    1
    Quote Originally Posted by liquid_smoke View Post
    that dosent work either, ill have to play with it a bit.
    it kind of worked in that the OSK waited, but the OSKTOCMD failed to actually set the var at all so the code dosnt work.

    Hehehe Been there done that.... I literally spent like 4-5 hours trying to figgure it out, as I have about 3 things I want to do, using that command.

    I PM"d Guino again, and he said he is going to try the code.
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  10. #10
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    sorry, the commands are correct, but there was an issue with the function tha replaces variables in the commands..
    please download the latest beta for a fix:

    http://www.rrdownloads.net/BETA/RoadRunner.exe
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

Page 1 of 2 12 LastLast

Similar Threads

  1. Lilliput TouchKit problem solved!
    By AAVfReaK in forum LCD/Display
    Replies: 4
    Last Post: 11-07-2010, 08:29 AM
  2. OSK Problem.
    By NeoMatrixJR in forum Road Runner
    Replies: 4
    Last Post: 06-02-2006, 10:34 PM
  3. Car Idle - power/amp problem?
    By TheFaze in forum Car Audio
    Replies: 1
    Last Post: 12-15-2005, 11:10 PM
  4. had an all day (9 hr) problem at work....
    By wizardPC in forum Off Topic
    Replies: 13
    Last Post: 10-20-2005, 11:50 AM
  5. OSK Focus Problem
    By warnockm in forum Map Monkey
    Replies: 4
    Last Post: 09-30-2005, 03:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •