Page 2 of 5 FirstFirst 12345 LastLast
Results 11 to 20 of 50

Thread: RR & Iguidance problem

  1. #11
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    If your version of iG haven't been alter (changing class name and caption text), it shouldn't have problem embedded it with option to set ignative=true. If you still have problem, do what guino suggested by setting it to false.
    I don't know how to fix the problem when I can't reproduce the problem.
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

  2. #12
    FLAC Chuck's Avatar
    Join Date
    Sep 2003
    Location
    Ellicott City, MD
    Posts
    1,671
    One way to fix this would be add a command to RR that would activate a command every time RR calls for IG window.

    That way it could be customized for each user

    Ig v 2
    “SHOWIG”,” ACTIVATE;iGuidance||SENDKEY;{RIGHT}{RIGHT}”



    Ig v 3
    “SHOWIG”,” ACTIVATE;iGuidance||SENDKEY;{SPACE}{SPACE}”
    2001 S10 ZR2

    Chucks Skin - to old

  3. #13
    FLAC Chuck's Avatar
    Join Date
    Sep 2003
    Location
    Ellicott City, MD
    Posts
    1,671
    I have tried everything under the sun to fix this.
    ignative=false true and everything in between

    The map is embedded and it is there but you cannot see it till you
    1 Start moving in the car
    2 Send a command to IG
    3 Click the map area and move the map a little

    If you clip the area it will just show the desktop.

    For some reason the map just will not redraw on screen switches but it is there and embedded.

    This is what I am doing now to eliminate the problem on both of my machines so the map will show on start, menu exits, lastscreens and screen switches.

    What a pain in the a$$

    /,63A--------------------GPS Exit from stuff to show map-------------------------------------
    "LASTSCR","TEMPLASTSCR||RETURNMAP"
    "TEMPLASTSCR","LASTSCR"
    "EXIT","TEMPEXIT||RETURNMAP"
    "TEMPEXIT","EXIT"
    "RETURNMAP","SHOWMAP",EXTERNAL_GPS_IG.skin
    "RETURNMAP","SHOWMAP",EXTERNAL_GPS_ig_FS.skin
    "RETURNMAP","SHOWMAP",ATI tv GPS.skin
    "RETURNMAP","SHOWMAP",Audio_GPS.skin
    "RETURNMAP","SHOWMAP",Radio_GPS.skin
    "RETURNMAP","SHOWMAP",SIRIUS GPS.skin
    "RETURNMAP","SHOWMAP",XM GPS.skin
    "SHOWMAP","ACTIVATE;iGuidance||SENDKEY;{RIGHT}{RIG HT}"

    And on all GPS loads I added "SHOWMAP" to the end of the command.
    2001 S10 ZR2

    Chucks Skin - to old

  4. #14
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    Did you guys try other front end such as Freeway? Once way to figure out if it is RR specific or machine setting.
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

  5. #15
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,710
    Blog Entries
    1
    I will venture out on a limb here, but I am 99% sure, to bet that this is RR specific. The front end itself is in charge of showing the screen and how it is handled. Right? We know iGuidance is just another "window" and on it's own, it never disappears when it is used standalone. Logically then, it HAS to be something, somewhere between RR and iG that is causing this.

    I am not saying there is something wrong with RR, as it is the best of the best out there as far as Front Ends are concerned. It is just some sort of small code problem, to do with the way the iG window is either called, brought to the front, focused ect.

    With the addition of the iG code in Road Runner to trim the menu/borders ect, That has been a FANTASTIC improvement. Now, to do that, when iGuidance is detected, it has to "realize" this to trim the borders/menu each time right? If this is the case, is is possible to put some sort of focus command into that area of code? Like Chuck's sollution to send UP,UP / Space Space, so that it done automatically whenever the iG screen is "detected"?

    The idea being, Switch to iG screen, the code is accessed to trim the menu's/borders. THEN send the Up Up or whatever to ensure that it is brought to the front.

    This has been a problem for just about everyone at some point, and I have just learned to deal with it, and make HEAVY use of the "North" button on my screen to make iG show back up again when this happens.

    EDIT:
    Thinking throug this a bit further, if the sollution to stop this from happening, is to:

    If you can't understand what's been posted, just open RR.INI set (or add) ignative=false and call it the day.
    Then that, 100% tells me that is HAS to be something to do with the trimming of the menu's and borders to embed it natively. As, this problem never once occured, on my systems at least, when iG's borders and menu were showing.

    This is not pointing fingers, blaming code, just trying to narrow it down, and see if collectively we can come up with a sollution for a problem that seems to be pretty much all iG 2.x and 3.x users, which is about 60% of the CarPC users in this forum according to that GPS poll a while back.




    .
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  6. #16
    FLAC Chuck's Avatar
    Join Date
    Sep 2003
    Location
    Ellicott City, MD
    Posts
    1,671
    No I never tried any other front end after working with RR and I don’t want to.
    Never had any problem with screen switching before RR with native IG came out.
    And when it did I just loaded IG with the class window name to fool RR in to thinking it was just any application. The problem with that was auto gps will not work that way.

    But I can live with the way I have it setup now.

    Auto GPS screen switching is worth the trouble.

    Thanks MatrixPC
    2001 S10 ZR2

    Chucks Skin - to old

  7. #17
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    Alright guys, I'll try to look at the code that trim the border to see if anything abnormal in there. So far, I don't have any problem like that in my carPCs and dev machine. So it hard for me to fix the problem when it's "not there" for me.

    setting ignative=true|false isn't going to solve the problem if it is in the trimming code, but try changing from true to false or around to see if that change anything.

    I hope that you guy can trace down to where is the problem so I can find a fix for it (if I can). And no, it's not finger pointing. It's all about finding a perfect solution to our carPC adventure .
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

  8. #18
    FLAC Chuck's Avatar
    Join Date
    Sep 2003
    Location
    Ellicott City, MD
    Posts
    1,671
    Here is mine with true setting

    It off sets all my gps screens down I have YPosition=85 setting in the general.ini
    OriginalWidth=1024
    OriginalHeight=683
    ShowWidth=1024
    ShowHeight=683
    XPosition=0
    YPosition=85

    And none of my command buttons will do anything
    Attached Images Attached Images  
    2001 S10 ZR2

    Chucks Skin - to old

  9. #19
    Maximum Bitrate Civic03's Avatar
    Join Date
    Dec 2005
    Posts
    605
    Interesting and I thought I was the only one with this problem. I'm using LSX skin and just starting having this problem once I installed the latest RR. Hope someon finds a solution.

    PROGRESS 95%[//////////]Complete - Software configurations
    Current Task: Just adding on...
    Needed:wireless keyboard/mouse
    My Carputer Blog
    Car System Site

  10. #20
    Car Audio Moderator durwood's Avatar
    Join Date
    Sep 2006
    Location
    Chicagoland (St. Charles,IL)
    Posts
    2,028
    I think I am having the same problem here. IG screen will not come back into focus. I have it embedded in the skin but still having problmes. I am still very new to RR and I will try to explain what I see.

    I set IGnative=true in the RR.ini file
    I am using a Earthmate USB running their serial emulation program set on com port 3.
    I have the Digital Graphite skin
    I am using RR 10/24 version.
    I am using IG 3 NA

    I have two problems at the moment and I have searched and read and still unsure if I have something set wrong.

    1) Anytime I switch to the GPS screen, the taskbar pops up indicating that roadrunner does not have focus?? I then have to click back on the roadrunner GPS window to bring roadrunner back into focus.

    2) To get my GPS receiver to talk to IG I must go into the IG GPS settings and then return back to the map screen. How do I get my GPS reciver to always be active or talking to IG whenever it needs it?

    If any of this has been discussed before please point me in the right direction.

Page 2 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. Replies: 16
    Last Post: 12-17-2009, 04:26 PM
  2. Replies: 570
    Last Post: 11-05-2009, 02:49 PM
  3. Replies: 0
    Last Post: 09-23-2006, 08:38 PM
  4. iGuidance GPS Issue in RR
    By moeman_49 in forum GPS
    Replies: 3
    Last Post: 06-04-2006, 03:17 PM
  5. Iguidance reroute problem?
    By samc in forum GPS
    Replies: 17
    Last Post: 10-02-2004, 10:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •