Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Hibernation and Startup Questions

  1. #1
    Variable Bitrate
    Join Date
    Sep 2006
    Location
    Richmond, Tx: USA
    Posts
    328

    Hibernation and Startup Questions

    I have following two urgent questions (since I'm on a road trip)

    1) Everything was working perfectly till yesterday when I installed Enginius USB Wifi card. Now what happens is the software for it keeps the computer from hibernating. Everytime RR tries to hibernate, it gives a pop-up and stops it from hibernating. How can I close the software (since I'm using RR as shell I don't see the task bar where its at) before hibernation and open up again when RR starts ?

    2) I'm using "startcommand" for running Xport on starup but now I want run Philips Soundcard software on startup too. I tried using "startcommand" but it seems like RR does not like two startcommands. How can I run more than one command at startup ???

    Prompt reply will be appreciated.

  2. #2
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,045
    well for #1, go to system properties, harware device manager. locate your usb section under hubs or root, and then uncheck the box that says something like "dont let computer sleep while this device is active" or something. im in airport now on phone, so i dont know exactly, but pretty sure it is like that.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  3. #3
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    1) you can try running devcon.exe to disable the card before hibernating, then running it again to re-enable it after resuming. You'll have to lookup the syntax and card information then just place the commands in exectbl (ONSUSPEND/ONRESUME events). Making .bat files is a good way to test/set-up.

    2) use || to separate commands (i.e. AUDIO||STOP)
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  4. #4
    Variable Bitrate
    Join Date
    Sep 2006
    Location
    Richmond, Tx: USA
    Posts
    328
    Quote Originally Posted by guino View Post
    1) you can try running devcon.exe to disable the card before hibernating, then running it again to re-enable it after resuming. You'll have to lookup the syntax and card information then just place the commands in exectbl (ONSUSPEND/ONRESUME events). Making .bat files is a good way to test/set-up.

    2) use || to separate commands (i.e. AUDIO||STOP)
    1) what type of information do I need to use devcon ?

    2) so it should be something like

    startcommand=c:\xport.exe||c:\soundcard.exe

    ??

  5. #5
    Newbie
    Join Date
    Nov 2006
    Posts
    37
    go into rr config and find the box thats says force hibernation- even if hardware port it preventing, that should work i think
    PC
    AMD 3500+ 2.2Ghz, MSI K9VGM-V Motherboard,
    Geil 512MB PC4200 DDR2-RAM, 7" Lilliput Touchscreen, 30GB HD
    Audio
    300 watt RMS 2 Channel MTX AMP, 500 watt RMS D-Class MTX AMP, 2 Front - 5 1/4" Sony Xplods,
    2 Back - 6 1/2" Sony Xplods, 12" MTX Sub

  6. #6
    Variable Bitrate
    Join Date
    Sep 2006
    Location
    Richmond, Tx: USA
    Posts
    328
    Quote Originally Posted by Legacy View Post
    go into rr config and find the box thats says force hibernation- even if hardware port it preventing, that should work i think
    That is already checked but that is not working.

  7. #7
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Type 'devcon help' in the command prompt for details. You'll need the device path along with the disable/enable commands from devcon -- you may have to google it, it's not hard but it's highly dependent on your hardware so there's nothing I can do to tell you what to type in. It's basically: 'devcon disable <device>' and 'devcon enable <device>' but the device you'll have to find with 'devcon find *'

    startcommand is for RR commands (as in skin commands.txt), if you want to run applications you should use: "RUN;C:\xport.exe||RUN;c:\soundcard.exe"
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  8. #8
    Variable Bitrate
    Join Date
    Sep 2006
    Location
    Richmond, Tx: USA
    Posts
    328
    Quote Originally Posted by guino View Post
    Type 'devcon help' in the command prompt for details. You'll need the device path along with the disable/enable commands from devcon -- you may have to google it, it's not hard but it's highly dependent on your hardware so there's nothing I can do to tell you what to type in. It's basically: 'devcon disable <device>' and 'devcon enable <device>' but the device you'll have to find with 'devcon find *'

    startcommand is for RR commands (as in skin commands.txt), if you want to run applications you should use: "RUN;C:\xport.exe||RUN;c:\soundcard.exe"
    aren't skin commads for skin only ? I've been sucessfully using startcommand for xport. Now all I want do is run another command with it. Is it not possible to do multiple commands using startcommand ?

  9. #9
    Maximum Bitrate kpjuk's Avatar
    Join Date
    Dec 2003
    Location
    West Midlands
    Posts
    474
    Hi Ajamils,

    You can define a command in ExecTbl.ini like

    "DoThis","RUN;c:\Roadrunner\Xport\Xport.exe||RUN;c :\somethingelse.exe"

    Then set startcommand to
    startcommand=DoThis

    cheers
    KPJUK
    M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
    DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

  10. #10
    Variable Bitrate
    Join Date
    Sep 2006
    Location
    Richmond, Tx: USA
    Posts
    328
    Quote Originally Posted by kpjuk View Post
    Hi Ajamils,

    You can define a command in ExecTbl.ini like

    "DoThis","RUN;c:\Roadrunner\Xport\Xport.exe||RUN;c :\somethingelse.exe"

    Then set startcommand to
    startcommand=DoThis

    cheers
    KPJUK
    Thank you, will try it out.

Page 1 of 2 12 LastLast

Similar Threads

  1. hibernation freezes upon startup
    By NYCdesignkid in forum Software & Software Development
    Replies: 14
    Last Post: 02-28-2009, 08:43 PM
  2. CF & Hibernation Issue
    By mmk999 in forum CF Bug Reports
    Replies: 6
    Last Post: 04-27-2006, 12:16 PM
  3. ME not loading from Hibernation
    By TheMayor in forum Media Engine
    Replies: 8
    Last Post: 11-22-2005, 10:00 AM
  4. Odd Off Topic-ness on Hibernation
    By Vchat20 in forum General MP3Car Discussion
    Replies: 1
    Last Post: 01-31-2005, 05:41 PM
  5. computer freezes at hibernation startup
    By bobthebaker in forum General Hardware Discussion
    Replies: 0
    Last Post: 01-12-2005, 08:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •