Results 1 to 9 of 9

Thread: iGuidance Integration Problems

  1. #1
    Low Bitrate
    Join Date
    Jun 2006
    Location
    Richmond VA
    Posts
    73

    iGuidance Integration Problems

    I am using iGuidance v 3.0, and it works fine in windows. I am also using the latest version of RoadRunner with a scion tc skin.

    In road runner config, I have setup the GPS section for it to have the GPS window in road runner.. but it doesn't work for me.

    In RRConfig, I have the following settings:
    GPS Mode: External
    GPS Path: C:\Program Files\iNav\iGuidance\iGuidanceUMPC.exe" "nowarning
    GPS Window Name: !IntellisnavWCls!IGuidance

    I have also tried removing and switching the window names, i have tried setting the parameters for the GPS path differently, ie:
    GPS Path: "C:\Program Files\iNav\iGuidance\iGuidanceUMPC.exe" nowarning

    ...and everything else I can think of..

    The ONLY way I can get it to work, is if I already have iGuidance running when I startup Road Runner. When I click GPS, it works and comes up fine.. then if I go to close Road Runner, and exit back to windows, I see that the iGuidance window is gone, but the iGuidanceUMPC.exe process is still in the task manager.

    Yes, I've tried searching for similar problems, but can't find much - and by the way this forums search methods are awful!



    Brett

  2. #2
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

  3. #3
    Low Bitrate
    Join Date
    Jun 2006
    Location
    Richmond VA
    Posts
    73
    Quote Originally Posted by MatrixPC View Post
    Thanks for the link.
    I looked through the threads that were in the threads you linked to, but still cannot get this working. Maybe it is a skin problem? I've tried editing the rr.ini with the suggested settings, but it still doesn't properly work. I'm not sure what else to try.

    Brett

  4. #4
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    Post the GPS portion of rr.ini
    what skin are you using?
    What is the code to run GPS? Remember, some skin, the skinner hard code the GPS button to use LOAD command instead of just "GPS".
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

  5. #5
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,691
    Blog Entries
    1
    Not sure if this is the problem or not, but in GPS Window title in RRConfig, I simply have "iGuidance". I am also using iG 3.0. With the window "disappearing" it sounds like a window title problem, and RR is not able to get a "lock" on it.

    This is from my RR.ini:

    Code:
    gpsmode=2
    gpspath=C:\Program Files\iNav\iGuidance\iGuidanceUMPC.exe
    gpsname=iGuidance
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  6. #6
    Low Bitrate
    Join Date
    Jun 2006
    Location
    Richmond VA
    Posts
    73
    Quote Originally Posted by MatrixPC View Post
    Post the GPS portion of rr.ini
    what skin are you using?
    What is the code to run GPS? Remember, some skin, the skinner hard code the GPS button to use LOAD command instead of just "GPS".

    The skin i'm using is from another mp3car memeber's thread..
    Its called "system error (blue)".
    Midnight tc Car pc finally done.


    My complete rr.ini file is here:
    http://qrxx.com/carpc/rr.ini

    The GPS Parts are:

    Code:
    gpsmode=2
    mapmonkeypath=
    gpspath=C:\Program Files\iNav\iGuidance\iGuidanceUMPC.exe|nowarning
    gpsname=Iguidance
    Note that I have tried the gpspath different ways.
    I don't have any setting for ignative, although i have seen that posted, but i was under the impression it was not needed.
    I've also changed around the gpsname using winspector, to IntellinavWCls.. i think that was it, anyway it still doesn't work unless iguidance is already running.


    Thanks,
    Brett

  7. #7
    Low Bitrate
    Join Date
    Jun 2006
    Location
    Richmond VA
    Posts
    73
    Quote Originally Posted by JohnWPB View Post
    Not sure if this is the problem or not, but in GPS Window title in RRConfig, I simply have "iGuidance". I am also using iG 3.0. With the window "disappearing" it sounds like a window title problem, and RR is not able to get a "lock" on it.

    This is from my RR.ini:

    Code:
    gpsmode=2
    gpspath=C:\Program Files\iNav\iGuidance\iGuidanceUMPC.exe
    gpsname=iGuidance
    Still doesn't work.
    But thanks.

  8. #8
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,691
    Blog Entries
    1
    Quote Originally Posted by zzzBrett View Post
    Still doesn't work.
    But thanks.
    Hmmmm not sure what it is then. I can tell you you can remove the |NOWARNING from the end of the line, as RR now takes care of that since around the end of October. I doubt this is the problem, but it can be removed anyways.
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  9. #9
    Low Bitrate
    Join Date
    Jun 2006
    Location
    Richmond VA
    Posts
    73
    Its fixed!

    I downloaded and setup another skin, used it.. and the gps worked.
    Then, I went back to the system error skin, and it worked too!

    Kind of weird, but i'm just glad it works now.


    Thanks for the help,
    Brett

Similar Threads

  1. Problems with IGuidance GPS embeding
    By Fat_Tony in forum Mobile Impact
    Replies: 14
    Last Post: 05-11-2006, 07:30 PM
  2. Hacking Iguidance
    By Peoples in forum GPS
    Replies: 74
    Last Post: 08-28-2005, 06:40 PM
  3. iGuidance 2.x auto-run shortcut
    By ziggyrama in forum GPS
    Replies: 1
    Last Post: 08-13-2005, 06:05 PM
  4. Dell Inspiron 8200 & Lilliput TS problems?
    By bkpsu in forum LCD/Display
    Replies: 1
    Last Post: 08-15-2004, 01:55 PM
  5. Replies: 0
    Last Post: 08-01-2004, 11:33 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •