Results 1 to 8 of 8

Thread: Focus lost when switching to GPS - RR nor iG has focus

  1. #1
    Constant Bitrate cMags's Avatar
    Join Date
    Jun 2005
    Location
    Marietta, GA
    Posts
    215

    Focus lost when switching to GPS - RR nor iG has focus

    Not to cross-post, but it seems as if this would be a better forum for my thread in the RR general forum. I'm not getting much help over there, and this does seem to be a bug. If any mods would be kind enough to just move the other thread here and close this, that would be great too.

    Yet another "focus" issue

    CarPC v2.5 up and running - all hardware installed, skin configured, and iG tweaked like crazy. Now for OBD-II, and voice control, and camera plugin, and... :nutz: - it never ends!

  2. #2
    Newbie
    Join Date
    Dec 2000
    Posts
    11
    Ok, this is a WAG and the second time I've hocked Tweak UI today, but if an application is stealing focus (which seems to be the case, given the need to alt-tab), try using Tweak to prevent applications from stealing focus (general > focus)

  3. #3
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,049
    have you set ignative=false in the rr.ini file?

    Are you using iG 3.0?

    The problem is not with RR, but with iGuidance. And it is not focus. It is how iG draws it data to the screen. A normal application draws the image x times a second. iG draws only when it thinks it needs to. So if your location has not changed, then iG thinks its a waste of its time to redraw the data. So it doesn't. iG doesn't know that it is embedded, so it doesnt realize that the screen has been switched. But it has.

    So set ignative=false, and it wont embed completely, and then you should get it to work better. And then if you switch screens so it doesnt show because it is not redrawn, then drag your finger over the screen to do a manual pan, and then it will redraw. Click the red x to get back to normal. Or if you just move physically, the screen will redraw at 1Hz.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  4. #4
    Constant Bitrate cMags's Avatar
    Join Date
    Jun 2005
    Location
    Marietta, GA
    Posts
    215
    Toaster: I'm using iG 2.1.3. I do have ignative=false, and it embeds just as well as with ignative=true (no title/menu/tool/status bars). However, the issue is not that iG isn't redrawing - it shows up fine, and works just fine for display. The issue is that nothing is responding to keystrokes.

    Here's the primary example: In iG, the UP and DOWN arrow keys zoom in and out. I have a set of push buttons on my dash that interface with Diba's Winamp COM-port control. Using this plugin, I have control over winamp, and a pair of buttons mapped to UP and DOWN keys. So when iG has focus, the buttons on my dash will zoom in and out.

    I got tired of having to click into iG, so I used the keytbl.ini to map my up and down arrow keys to the standard iGuidance_ZoomIn and _ZoomOut functions, which in turn use the SENDKEY function to send the UP and DOWN keys. These also work fine when RR has focus. I click on RR, hit one of my buttons, iG zooms in or out. Great.

    The problem is, that when I FIRST open the GPS window, neither iG NOR RR has focus. I have to click somewhere (anywhere) first, then can start using my keyboard shortcuts (the issue even persists if I use my keyboard's arrow keys instead of my buttons).

    Hope that made sense. Thanks for the input.

    CarPC v2.5 up and running - all hardware installed, skin configured, and iG tweaked like crazy. Now for OBD-II, and voice control, and camera plugin, and... :nutz: - it never ends!

  5. #5
    Constant Bitrate cMags's Avatar
    Join Date
    Jun 2005
    Location
    Marietta, GA
    Posts
    215
    So I just tested going back to my original RR version, 5.2.06, and it seems to be working fine. The only difference I can see is the embedding of iG. It's definitely the embedding process that is causing this issue. I've now come into an interesting situation - After switching back and forth between 5.2.06 and 4.11.07 for screen shots, I got to the point where my 4.11.07 tries to embed iG, but won't. BUT - my keyboard shortcuts work. RR keeps focus. Here's those screen shots:

    5.02.06 - notice that iG doesn't embed fully - menu/tool/status bars still visible - RR keeps focus:


    4.11.07 - iG embeds fully, even with iGnative=false - neither iG nor RR has focus:


    4.11.07 - after switching back and forth a couple times, iG isn't embedding properly any more - not sure why, but RR will keep its focus now:

    CarPC v2.5 up and running - all hardware installed, skin configured, and iG tweaked like crazy. Now for OBD-II, and voice control, and camera plugin, and... :nutz: - it never ends!

  6. #6
    Constant Bitrate cMags's Avatar
    Join Date
    Jun 2005
    Location
    Marietta, GA
    Posts
    215
    OK, so by this point, I'm assuming I've got no other suggestions because nobody else has this issue. Can anyone confirm that they have iG 2.1.3 working fine in RR 4.11.07 and can switch to GPS and immediately hit a keyboard shortcut and have RR respond?

    Maybe I should just do a fresh install of RR/iG (again)?

    CarPC v2.5 up and running - all hardware installed, skin configured, and iG tweaked like crazy. Now for OBD-II, and voice control, and camera plugin, and... :nutz: - it never ends!

  7. #7
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    I think there is some problem with external_gps.skin thinggy in RR.
    Create a copy of external_gps.skin called "ig_gps.skin" or whatever you want.
    use the LOAD command to load that skin to see if it RR or IG gain focus after launch.
    "LOAD;ig_gps.skin;$gpsname$;$gpspath$;$gpsname $"
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

  8. #8
    Constant Bitrate cMags's Avatar
    Join Date
    Jun 2005
    Location
    Marietta, GA
    Posts
    215
    Sweet, I'll give that a shot.

    Also, I noticed that ever since RR has been able to fully embed iG natively (remove the menu/tool/status bars in addition to the title bar), this has been happening. I tested back to the July 06 build - that was the last one that worked for what I'm trying to do. I guess I'm unique in my touchscreen-/mouse-less environment huh?

    CarPC v2.5 up and running - all hardware installed, skin configured, and iG tweaked like crazy. Now for OBD-II, and voice control, and camera plugin, and... :nutz: - it never ends!

Similar Threads

  1. Replies: 65
    Last Post: 10-13-2009, 06:51 PM
  2. Getting Started with GPS
    By grepzen in forum The FAQ Emporium
    Replies: 12
    Last Post: 09-26-2006, 05:54 AM
  3. Replies: 17
    Last Post: 09-04-2006, 12:33 PM
  4. How do I setup my GPS Application ?
    By guino in forum RR FAQ
    Replies: 0
    Last Post: 03-20-2005, 02:17 PM
  5. Best GPS Software to use with RR?
    By edrex in forum Road Runner
    Replies: 3
    Last Post: 03-15-2005, 03:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •