Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Problem w/ SETPATH...

  1. #1
    FLAC Sal R.'s Avatar
    Join Date
    Aug 2006
    Location
    Sun Diego
    Posts
    1,448

    Problem w/ SETPATH...

    RRv4-11-2007

    In a DL list, directory won't change using SETPATH. The function is intermittent.

    Been having this problem now since 4-11-2007 release. Last revision I know of where this feature worked was 2-6-2007.

    Tried on three different machines.

    Home Dev PC
    Windows XP
    V5.1
    Build 2600

    CarPC
    Windows XP
    V5.1
    Build 2600 Service Pack 2

    Work Dev PC
    Windows 2000 NT
    V5.0
    Build 2195 Service Pack 4

    In all three OS, the function is buggy. Sometimes, it'll work. Sometimes, it won't. Most times, it won't work.

    If I set the default rr directory is set to any of the directory I use SETPATH on, RR will find it and browse it. Just can't seem to switch directories.

    Tried the following formats for changing drives:

    I:
    I:\

    I can't even switch over to C:\Shared Music or C:\Shared Music\

    Also, doesn't seem contigent on type of drive (FAT32 ro NTFS).

    I hope you can fix this. I miss being able to access my removeable drive media...
    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

  2. #2
    MGD
    MGD is offline
    FLAC
    Auto Apps:loading...
    MGD's Avatar
    Join Date
    Feb 2005
    Location
    Los Angeles
    Posts
    1,756
    Why don't you try my Media Manager. You can browse wherever you want with it, no need for browse.rll.
    Take a look at it and change the locations in the skin file to your liking.

    Media manager

  3. #3
    FLAC Sal R.'s Avatar
    Join Date
    Aug 2006
    Location
    Sun Diego
    Posts
    1,448
    I'm not quite sure how our media manager switches directories. I can see the indicators for specific drives, but no additional skins are provided that tells me how you switch to those drives.

    If you have a chance, DL my skin and check out the audio library. 3 of 5 drive paths are defineable on-the-fly to accomodate the various media I could be carrying. All of which are defined by SETPATH.

    I also use SETPATH to browser for and define external app paths, as well as, help with opening text files on removeable media. I really need this feature to work properly.
    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

  4. #4
    FLAC Sal R.'s Avatar
    Join Date
    Aug 2006
    Location
    Sun Diego
    Posts
    1,448
    Seems to be tied into the "EXISTS" indicator code as well.

    I,224,529,14,11,"EXISTS;$musicpath$:B"

    If the path is accessible using SETPATH, the indicator...indicates?...that it's available and vice versa.

    Even if the path exists, the indicator code will display "OFF."
    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

  5. #5
    MGD
    MGD is offline
    FLAC
    Auto Apps:loading...
    MGD's Avatar
    Join Date
    Feb 2005
    Location
    Los Angeles
    Posts
    1,756
    Look at the file Sal,
    I have 3 different locations in my file, one for the CD Drive, one for my USB Thumb Drive and the one for my hard drive. With that EXISTS you can read ANY directory like
    "EXISTS;C:\Music\*.MP3" or
    "EXISTS;C:\Documents\My Documents\Textfiles\*.txt"
    Now when on of those criterias are set, the indicator comes on and with a button I open the specific browser for it. I have browser skins for CD,Video,USB and hard drive. Now all you have to do is to set the SD definition to the location you want to browse.

  6. #6
    FLAC Sal R.'s Avatar
    Join Date
    Aug 2006
    Location
    Sun Diego
    Posts
    1,448
    I figured that that was how you were browsing your different media, but hardcoding the SD and having a directory browser for each media just wont work for me.

    Depending on what I have plugged in the drive letters change. SETPATH worked great for changing directory paths on-the-fly. For example, my MP3 player shows up as F:\ & G:\. My wife's MP3 player shows up as J:\ & K:\ and, generally, don't have them both hooked up at the same time. The same 2GB thumb drive i carry with me has shown up as E:\ and H:\. When I plug in my camera who knows what drive it'll pick up.

    When my DVD drive got unplugged, all the drive letters shifted up. Just not efficient to have a button and browser for each of these drives, y'know?
    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

  7. #7
    FLAC Sal R.'s Avatar
    Join Date
    Aug 2006
    Location
    Sun Diego
    Posts
    1,448
    YES! GOT IT TO WORK!

    The bottom line is that the directory you point "SETPATH" to has to have a file in it...any kind of file, not a folder. I used a .txt file.

    Also, the file cannot be hidden.

    I put a txt file in all my drive media and RR switches directories using SETPATH now, no problems.
    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

  8. #8
    MGD
    MGD is offline
    FLAC
    Auto Apps:loading...
    MGD's Avatar
    Join Date
    Feb 2005
    Location
    Los Angeles
    Posts
    1,756
    Well, I figured that you have to have files in there otherwise there is nothing to display in your DL.
    Great it is working for you the way you want it.

  9. #9
    FLAC Sal R.'s Avatar
    Join Date
    Aug 2006
    Location
    Sun Diego
    Posts
    1,448
    Quote Originally Posted by MGD View Post
    Well, I figured that you have to have files in there otherwise there is nothing to display in your DL.
    Great it is working for you the way you want it.
    LOL! Not necessarily.

    My root music folder is structured like this:
    Artist
    - Album
    - - MP3s

    Nothing but folders in the root directory. So, once I move away from it, I couldn't get it back.

    My MP3 player is organized like that as well. So is my thumb drive, where I sort everything by folder at the root directory (Pictures, MP3's, Video, etc.)...no files there either.

    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

  10. #10
    FLAC
    Auto Apps:loading...
    moahdib's Avatar
    Join Date
    Jul 2000
    Posts
    1,017
    Yeah Sal, I been working with browse by cover plugin and experiencing the same issue.
    Setpath is working VERY slow it seems and might even cause high CPU usage. For the most part it does work. but very slowly -_-
    04 Acura TL w/ core2duo 2ghz laptop w/ 1gb RAM on a docking station.

    Fast car, fast PC. ;)

    http://www.arcdesigns.net/carpc/

    My TL CarPC ver2

    FSR Flash Skin w/ moving weather maps

Page 1 of 2 12 LastLast

Similar Threads

  1. Lilliput TouchKit problem solved!
    By AAVfReaK in forum LCD/Display
    Replies: 4
    Last Post: 11-07-2010, 09:29 AM
  2. reconnected puter and now audio problem..
    By NYCdesignkid in forum Car Audio
    Replies: 2
    Last Post: 05-31-2006, 12:09 AM
  3. gps navilock and com problem
    By lele67 in forum GPS
    Replies: 0
    Last Post: 04-01-2006, 08:41 PM
  4. Problem with directshow filter and WMP
    By EricE in forum Software & Software Development
    Replies: 0
    Last Post: 03-01-2006, 11:38 AM
  5. Car Idle - power/amp problem?
    By TheFaze in forum Car Audio
    Replies: 1
    Last Post: 12-16-2005, 12:10 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •