Results 1 to 3 of 3

Thread: OSKTOCMD/OSKTOVAR don't wait until I press ENTER

  1. #1
    Maximum Bitrate
    Join Date
    Aug 2004
    Location
    Germany
    Posts
    520

    OSKTOCMD/OSKTOVAR don't wait until I press ENTER

    I have written my own playlist search tool, which is running fine. I now want to embed the program in my skin, i.e. enter the searchstring with the OSK and launch the search tool after this. I tried this button code:

    Code:
    B12,700,200,080,040,"OSKTOCMD;searchstring||RUN;search.exe|$searchstring$|WHOLE"
    RoadRunner doesn't wait till I press ENTER on the OSK, though. The OSK appears and the program directly launches. To check what the problem is I added an delay after the OSKTOCMD command:

    Code:
    B12,700,200,080,040,"OSKTOCMD;searchstring||WAIT;10||RUN;search.exe|$searchstring$|WHOLE"
    Now when I press the button the OSK appears and RR waits 10 seconds, then the program is RUN.

    I don't see the sense in this function when RR doesn't wait for me to enter something at the OSK. Instead it should wait until I press ENTER at the OSK.

    EDIT: It's the same with OSKTOVAR.

    EDIT2: RR 11-02-2007

  2. #2
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    To my wondering eyes...it looks like you didn't follow the skin cmd txt...(tisk, tisk)

    Proper OSKTOCMD usage...

    "OSDTOCMD;searchstring;RUN;search.exe|$searchstrin g$|WHOLE" <-- this is your line corrected..

    "OSKTOCMD;<NAME OF VARIABLE>;<COMMAND TO EXECUTE>"

    oh, and my I add that you might want to try my media plugin when its released...
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  3. #3
    Maximum Bitrate
    Join Date
    Aug 2004
    Location
    Germany
    Posts
    520
    Quote Originally Posted by Blue ZX3 View Post
    To my wondering eyes...it looks like you didn't follow the skin cmd txt...(tisk, tisk)
    Yeah, you're right. I really thought I read it correctly, sorry about that . Thanks alot . I'll look out for your media plugin.

    If someone is interested: It seems you have to separate the args with spaces here. This line works for me:
    B12,700,200,080,040,"OSKTOCMD;searchstring;RUN;sea rch.exe|$searchstring$ WHOLE"

Similar Threads

  1. Release new phoco integration preview
    By Robby BMW in forum Road Runner
    Replies: 544
    Last Post: 09-12-2009, 06:29 AM
  2. RR 7-8-06.. Pic Viewer & more
    By guino in forum Road Runner
    Replies: 183
    Last Post: 09-11-2006, 01:35 PM
  3. Why you should only buy from the MP3CAR.COM store
    By mykolJay in forum General Hardware Discussion
    Replies: 45
    Last Post: 08-07-2006, 06:24 PM
  4. Voice activated navigation for routis!
    By 0l33l in forum PowerVoice
    Replies: 352
    Last Post: 10-03-2004, 04:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •