Results 1 to 4 of 4

Thread: Issue with sliders in Extension Plugin Interface (with solution)

  1. #1
    Maximum Bitrate Robby BMW's Avatar
    Join Date
    Aug 2005
    Location
    Italy
    Posts
    558

    Exclamation Issue with sliders in Extension Plugin Interface (with solution)

    I've noticed that if you try to load more Extension Plugin in RoadRunner, only the sliders handled by the first Plugin are properly displayed.

    The problem can be easly solved by this simple change in the RRExtension class:




    Public Function ReturnSlider(SLD As String) As Long
    'Default (No Action) <== LINE TO BE ADDED
    ReturnSlider = -1 <== LINE TO BE ADDED
    .
    .
    .
    I think it's important to add this change on every plugin developed with the Extension Plugin Interface in order to allow the simultaneously use in RoadRunner.
    _______________________________________
    Car installation 95% [■■■■■■■■■■■■■■■■■■■]
    Current project: Parking sensor USB interface

  2. #2
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,692
    Blog Entries
    1
    Do you know if something similar to this also pertains to custom indicators? They seem to have the exact problem you describe with the sliders. If I enable one plugin or the other the indicators work with either one. Enable both and the indicators only work with one plugin's indicators. Changing which plugin is loaded first can also effect which plugins indicators work.
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  3. #3
    Maximum Bitrate Robby BMW's Avatar
    Join Date
    Aug 2005
    Location
    Italy
    Posts
    558
    No, the indicators are not plagued by the same problem, because in the function "ReturnIndicator" of the class "RRExtension" is already present the line: ReturnIndicator = "False"
    It seems more a bug in the last official beta release (05/27/08), since the indicators work well on previous releases, also loading multiple plugins.
    _______________________________________
    Car installation 95% [■■■■■■■■■■■■■■■■■■■]
    Current project: Parking sensor USB interface

  4. #4
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    FYI, as of NOW (9/9/08) ReturnIndicator = "" when unprocessed

    return ""
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

Similar Threads

  1. Velleman K8055 USB I/O Board Extension plugin
    By 307SW_NLD in forum RR Released Plugins
    Replies: 224
    Last Post: 02-24-2013, 06:59 AM
  2. Keyboard language indicator extension plugin
    By tolisn in forum RR Plugins
    Replies: 23
    Last Post: 09-13-2006, 03:49 AM
  3. Extension plugin problems
    By festy in forum Road Runner
    Replies: 2
    Last Post: 06-23-2006, 06:20 PM
  4. Replies: 0
    Last Post: 06-11-2006, 05:49 PM
  5. Extension Plugin help ....
    By Gobby in forum Road Runner
    Replies: 1
    Last Post: 06-09-2006, 10:27 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •