Results 1 to 10 of 10

Thread: RideRunner not playing nicely with RRMediaDb

  1. #1
    MGD
    MGD is offline
    FLAC
    Auto Apps:loading...
    MGD's Avatar
    Join Date
    Feb 2005
    Location
    Los Angeles
    Posts
    1,756

    RideRunner not playing nicely with RRMediaDb

    Installed the new RideRunner, added some folders to my music library, rebuild database and what you know, the labels RM_SongDateAdded, RM_LastPlayedDate and RM_PlayedCount are not working anymore. Also the rating part is not working also. When you rate a song. it will show the new rating but when you switch songs, the ratings from the last song will stay.

    Made the test and uninstalled RideRunner, reinstalled the Dec. issue of Road Runner and guess what.....all working fine.
    So, I think ther is something wrong with forwarding the messeges from RideRunner to Road Runner.

  2. #2
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,149
    Blog Entries
    51
    Quote Originally Posted by MGD View Post
    Installed the new RideRunner, added some folders to my music library, rebuild database and what you know, the labels RM_SongDateAdded, RM_LastPlayedDate and RM_PlayedCount are not working anymore. Also the rating part is not working also. When you rate a song. it will show the new rating but when you switch songs, the ratings from the last song will stay.

    Made the test and uninstalled RideRunner, reinstalled the Dec. issue of Road Runner and guess what.....all working fine.
    So, I think ther is something wrong with forwarding the messeges from RideRunner to Road Runner.
    Hmm i'm not noticing this.. but honestly i havent really looked at those labels yesterday. My rating indicators are working fine though. I have noticed that the indicators for the builder screen no longer work but i'm not sure if thats because of the new indicator function compliance.

    [EDIT]

    Just tested.. the labels are working here.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  3. #3
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    Do you have the compatibility Roadrunner.exe in the folder or not ? if you have, try renaming it, if you don't try putting it there.. there shouldn't be a reason why this wouldn't work other than perhaps some configuration setting in the plugin..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  4. #4
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    My plugin's RRMediaDb.exe does need the compatibility Roadrunner.exe to be running as it looks for the process name for when to close/exit.

    One of the updates that I need to get to....
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  5. #5
    MGD
    MGD is offline
    FLAC
    Auto Apps:loading...
    MGD's Avatar
    Join Date
    Feb 2005
    Location
    Los Angeles
    Posts
    1,756
    Just reinstalled the new RideRunner again to test but it is a no go. I do have the Road Runner Compatability.exe in my folder. 12.5kb dated 12/31/08.

  6. #6
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    Except for the label codes you posted and the ratings portion, does the plugin work correctly and displays other labels normally ? or not ?

    Also, did you check the debug log to check if the plugin loaded without errors ?
    Do you have any other plugins loaded with it ? If so, did you try loading RRMediaDB ONLY ?
    Are you installing RideRunner in a "Ride Runner" folder or "Road Runner" folder ? I haven't seen the inner code in the plugin but maybe there's a set path somewhere causing the issues ?
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  7. #7
    Newbie Kadyroff's Avatar
    Join Date
    Sep 2007
    Location
    Moscow, Russia
    Posts
    49
    I think I have the same issue MGD has. About a week ago I installed on a fresh system (XP Pro) latest version of RideRunner + DFX 4.0 to the folder called \Road Runner\. I don't have any other plugins except what was included in DFX pack. Oh, and I changed mp3art.dll with the latest version.

    So, search for recently added/played songs is not working, as well as rating option. I rate a song, change the track, then go back to the rated song - and there is no rate!
    project progress:
    Planning.......[--------X-] 90%
    Parts............[-------X--] 80%
    Fabrication....[------X---] 75%
    Installation...[-------X--] 80%
    Worklog

  8. #8
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    You did also update to RRMedia v1.2.2? Just use the patch version.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  9. #9
    Newbie Kadyroff's Avatar
    Join Date
    Sep 2007
    Location
    Moscow, Russia
    Posts
    49
    Quote Originally Posted by Blue ZX3 View Post
    You did also update to RRMedia v1.2.2? Just use the patch version.
    thanx, will do that! just thought that there was the last vers. of RRMedia in DFX
    project progress:
    Planning.......[--------X-] 90%
    Parts............[-------X--] 80%
    Fabrication....[------X---] 75%
    Installation...[-------X--] 80%
    Worklog

  10. #10
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    No, DFX 4.0 came with the original RRMedia and has had updates since then, with another one some time in the future..
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

Similar Threads

  1. set to keep playing when exit aplication
    By thanatos106 in forum FrodoPlayer
    Replies: 7
    Last Post: 09-20-2005, 08:56 AM
  2. WoW anyone playing?
    By sdashiki in forum Off Topic
    Replies: 0
    Last Post: 04-13-2005, 02:25 PM
  3. Replies: 3
    Last Post: 12-13-2004, 12:50 AM
  4. Replies: 2
    Last Post: 11-25-2003, 10:50 PM
  5. ME playing in background
    By OrangePeel in forum ME Archive
    Replies: 4
    Last Post: 11-18-2003, 12:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •