Results 1 to 5 of 5

Thread: "onsuspend","MAIN"

  1. #1
    FLAC Nomader's Avatar
    Join Date
    Apr 2006
    Location
    Greece
    Posts
    1,290

    "onsuspend","MAIN"

    since ilists sometimes do not resume i have set in the exectbl.ini to :
    "onsuspend","MAIN"
    it works fine if hibernate is trggered by the powersupply or windows..but when hibernate is triggered by RR via "HIBERNATE" (not directly , but from an "exit.skin"), 2 seconds after resuming rr suddenly closes!!. it works ok when "HIBERNATE" is sent directly (via skintool for example)

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    You may want to try a resume delay. This issue is very hard to debug because it's basically DirectX loosing the loaded surfaces for the list -- RR has detection to re-build them after hibernate/standby (but sometimes DirectX will not re-create the surfaces anyway).
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,078
    I think that he understands that, but is saying that there is a different issue when calling the hib cmd from w/i RR.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  4. #4
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    This is weird because the same exact code used on Hibernate through the exit menu, is executed when sending it through skintool.

    However, if through skin tool it works, I would like you to change the "HIBERNATE" command in the exit menu to this:

    "RUNQ;$RRPATH$exec.exe|hibernate"

    Let me know what happens..
    Guino.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  5. #5
    FLAC Nomader's Avatar
    Join Date
    Apr 2006
    Location
    Greece
    Posts
    1,290
    i will just out of curiosity..but i changed to "onsuspend","reloadskin" and it does the same thing, so no issues..i am away for a few days i will try when i get home..thanks guys

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •