Results 1 to 8 of 8

Thread: Winamp not loading when i start RR

  1. #1
    Constant Bitrate
    Join Date
    Oct 2007
    Posts
    164

    Winamp not loading when i start RR

    I'm running RR in VMWare Fusion running XP. Current version of Winamp and RR using Carwings lite skin. I'm running it on here so that I can play with configurations/skins before putting it on the carputer.

    When I start up RR, winamp starts up fine, plays fine, etc. I then exit out for whatever reason.
    When I open RR up again (no restart), WinAmp does not open. No music can be played. Nothin'. I quit out, can't open Winamp by itself. It's like RR locked winamp away in a little closet for being bad and won't let it come out and play anymore. I restart, and all is well in the world again.

    Now, I know this is probably a moot point as I won't have this issue when it's actually on the carputer (skin will be in effect 100% of the time), but I still would like to know why this is happening/resolve it.

    Thanks.

    (apologies if this issue has come up before - I searched and found many winamp issues, but none pertaining to this exact one. If it has, please link me over there)

  2. #2
    Constant Bitrate
    Join Date
    Oct 2007
    Posts
    164
    Insta-update:
    Winamp loaded like 5 minutes later on its own. Weird. Is it a timeout issue? And if so, can I modify that timeout value?

  3. #3
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    1-Which skin you're using ?
    2-Which winamp version ?
    3-Does this happen by opening winamp, closing it and re-opening it (without using RR)?

    Chances are when you're exiting RR there's some winamp process lingering on the memory or something else (RR plugin/winamp plugin) still finishing up some task in that time.

    You can try this:
    -Run RR
    -Exit RR
    -Open task manager and verify if any winamp.exe is still running, if so, KILL IT
    -Re-run RR -- see if it takes 5 mins again

    Or just try another player to see if the same happens...
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  4. #4
    Constant Bitrate
    Join Date
    Oct 2007
    Posts
    164
    Quote Originally Posted by guino View Post
    1-Which skin you're using ? Carwings Lite
    2-Which winamp version ? 5.56
    3-Does this happen by opening winamp, closing it and re-opening it (without using RR)? Nope, it functions as normal when I open/close it multiple times

    Chances are when you're exiting RR there's some winamp process lingering on the memory or something else (RR plugin/winamp plugin) still finishing up some task in that time.

    You can try this:
    -Run RR
    -Exit RR
    -Open task manager and verify if any winamp.exe is still running, if so, KILL IT
    -Re-run RR -- see if it takes 5 mins again

    Or just try another player to see if the same happens...
    Today, the error doesn't seem to be happening. Doing the EXACT same methodology as I had done yesterday to produce the error this time is working perfectly. For now, I guess consider this not an issue, but if it comes up again, I'll update and see if I can reproduce the error.

  5. #5
    Constant Bitrate popi79's Avatar
    Join Date
    Sep 2006
    Posts
    150

    winamp

    winamp has tendency of not closing properly when exiting rr so try looking at the task manager and see if still running, end process and try again rr.

    "Most of the users you'll see in this site are still learning specially me"

  6. #6
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,246
    i find this NOT to be the case...winamp does close when RR exits
    if there is a issue, dont just END Process... report it
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  7. #7
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Quote Originally Posted by popi79 View Post
    winamp has tendency of not closing properly when exiting rr so try looking at the task manager and see if still running, end process and try again rr.

    This is the reason that Dfx had that kill WA thing when exiting RR. Was an observation that he(JohnWPB) made and attempted to "fix" it by Killing its task on RR's Exit.

    Though, I have never seen this ever occur when using WA in standalone, the not closing issue. I have been using WA for my audio playing for ?? years.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  8. #8
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    I have yet to see this happen, but I believe the only possible reason for this is if some winamp plugin is hanging for awhile on exit.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

Similar Threads

  1. Holux GPS Trouble
    By mangus580 in forum StreetDeck
    Replies: 34
    Last Post: 11-26-2007, 08:56 PM
  2. Issue with RR and winamp(?)
    By CubanAffection in forum Road Runner
    Replies: 3
    Last Post: 05-08-2007, 02:51 PM
  3. Replies: 5
    Last Post: 01-19-2007, 11:55 PM
  4. RR hangs on start up
    By fixerofallthing in forum Road Runner
    Replies: 3
    Last Post: 04-16-2006, 10:05 PM
  5. rr & winamp play same time/different videos?
    By turbocad6 in forum Road Runner
    Replies: 3
    Last Post: 01-12-2006, 03:40 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •