Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Video problems

  1. #1
    Maximum Bitrate tolisn's Avatar
    Join Date
    Dec 2003
    Location
    Greece
    Posts
    731

    Video problems

    Well this isanother problem I encountered.

    When I try to play a video that has a name with non english character "Greek"
    The video does not play. If I rename the file and use English characters then it playes OK. This is only for the video player. The music player plays everything and does not depend on the characters used in the name of the file.

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Quote Originally Posted by tolisn
    Well this isanother problem I encountered.

    When I try to play a video that has a name with non english character "Greek"
    The video does not play. If I rename the file and use English characters then it playes OK. This is only for the video player. The music player plays everything and does not depend on the characters used in the name of the file.
    does it even display the file names correctly ?? I have not done any work yet as to support foreign fonts. I do intend to get to it some time..

    Another question though: does media player classic play the files correctly if you open it outside MPC ?

    I do believe I'll have to add some support for that to work..

  3. #3
    Maximum Bitrate tolisn's Avatar
    Join Date
    Dec 2003
    Location
    Greece
    Posts
    731
    1. Yes the files names are shown correctly because I changed the fonts used in the skin.

    2. MP classic plays the files even with the Greek names.

  4. #4
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Quote Originally Posted by tolisn
    1. Yes the files names are shown correctly because I changed the fonts used in the skin.

    2. MP classic plays the files even with the Greek names.
    The video player loads all files/playlist using VB code, and VB has very poor support for foreign fonts.. I'll make sure to look into this wit a little more time... the audio player works because it basically lets winamp handle the file names/titles etc..

  5. #5
    Maximum Bitrate tolisn's Avatar
    Join Date
    Dec 2003
    Location
    Greece
    Posts
    731
    Quote Originally Posted by guino
    The video player loads all files/playlist using VB code, and VB has very poor support for foreign fonts.. I'll make sure to look into this wit a little more time... the audio player works because it basically lets winamp handle the file names/titles etc..

    OK Guino, take your time and keep on coding


    Thanks

  6. #6
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Quote Originally Posted by tolisn
    OK Guino, take your time and keep on coding

    Thanks
    Did you try this yet after I added support for "foreign" fonts ??

    Let me know, I simply used the code I had on my page for my other project (to display greek, chinese etc). Haven't tested myself, that's why I ask...

    Let me know..
    Guino.

  7. #7
    Maximum Bitrate tolisn's Avatar
    Join Date
    Dec 2003
    Location
    Greece
    Posts
    731
    Quote Originally Posted by guino
    Did you try this yet after I added support for "foreign" fonts ??

    Let me know, I simply used the code I had on my page for my other project (to display greek, chinese etc). Haven't tested myself, that's why I ask...

    Let me know..
    Guino.

    I tried the new version but the situation is still the same.
    While the audio player plays all songs, even if the contain names with Greek characters, the video player refuses to play eanything that contains Greek characters in the name. If the same file is renamed using English characters then it plays fine.

  8. #8
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Quote Originally Posted by tolisn
    I tried the new version but the situation is still the same.
    While the audio player plays all songs, even if the contain names with Greek characters, the video player refuses to play eanything that contains Greek characters in the name. If the same file is renamed using English characters then it plays fine.
    I'd like to help you, but you'll have to help me first:

    1-Give me your Windows Reginal Settings (Standards, Location and Language for Non-Unicode settings)
    2-Make me a "list of file names as you have (the way that they don't play) -- Probably a good idea to create zero-sized files with those names and zip them up so I can get them..
    3-Tell me which font (or send me a font) that I can use to view the greek characters with.
    4-Zip up and send me your .skin files...

    I need the above to perform testing and tweaking... I want to solve your problem while allowing many other (potential) users of different countries to use the software propperly This should not be too hard to fix...

    Let me know,
    Guino.

  9. #9
    Maximum Bitrate tolisn's Avatar
    Join Date
    Dec 2003
    Location
    Greece
    Posts
    731
    Ok I will prepare everything and send it to you.

    Thanks for your time.

  10. #10
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Quote Originally Posted by tolisn
    Ok I will prepare everything and send it to you.

    Thanks for your time.
    I went over the stuff you sent me (finally) and applied a patch on Version 2-20-05.. hope it works for you, now, please read the post about using MPC with non-standard characters..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

Page 1 of 2 12 LastLast

Similar Threads

  1. DVD playing causes video problems
    By roleary in forum General Hardware Discussion
    Replies: 4
    Last Post: 12-06-2004, 10:11 AM
  2. Video car problems....
    By joelw23 in forum General Hardware Discussion
    Replies: 6
    Last Post: 11-03-2004, 11:28 AM
  3. Weird problems with video and ME 2.1
    By Rireal in forum Media Engine
    Replies: 4
    Last Post: 02-20-2004, 06:33 PM
  4. FV24 and DC10+ video caputure board problems
    By komarak in forum General Hardware Discussion
    Replies: 1
    Last Post: 01-29-2004, 06:32 PM
  5. sv24 video problems again
    By Holden__V8 in forum General Hardware Discussion
    Replies: 3
    Last Post: 01-06-2003, 09:00 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •