Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: radio problem with WinTV

  1. #11
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    well... the code only sends it with "." (decimal point).. so it should be working.. do the rest of the functions (tune up/down, fine tune up/down, seek up/down) work ?? if so, this should be working just fine..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  2. #12
    Newbie
    Join Date
    Apr 2005
    Posts
    26
    thanks, so i'll try to remove and reinstall wintv applications.

    I've noticed another problem that maybe due to the same system configuration.
    When i go into RR mixer (skin BMV2), there is no change in winamp equalizer when i click on RR presets (rock, rap, pop....) and even no change in RR equalizer.

    On the other way, when i load a preset in winamp, the equalizer in RR mixer is changing correctly to be the same as winamp equalizer.

    Have you got an idea ???

    My version of winamp is a 2.78c
    my OS is windows XP pro SP2.

  3. #13
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  4. #14
    Newbie
    Join Date
    Apr 2005
    Posts
    26
    ok thanks !!!
    So, there is no relationship between that and my radio problem...

  5. #15
    Newbie
    Join Date
    Apr 2005
    Posts
    26
    hi guino, i found the problem. This is not a problem with dot or comma.
    I have to change one parameter in default language and standards format .
    On the language panel (2nd) i clic on the "details" button and i have to choose English as default language.
    Then it works great.
    The problem is that when i'm in English language, i could not enter special french caractere (as or ) with the mapmonkey OSK...

    Would it be hard to make radio work with French default language ???

    Thanks

  6. #16
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    I think the problem may be because of different keyboard handling (on WinTV's app. behalf) while using french ... I'm not exactly sure of what could be done to prevent this..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  7. #17
    Newbie
    Join Date
    Apr 2005
    Posts
    26
    hi guino,

    I've tried something with your keycode.exe, maybe it can be a clue if you are sending keycode to winTV radio.

    With default langage to french if i press :
    - the 1 key it display the "&" char and keycode give 49 code
    - shift+1 key it display the "1" char and keycode 1049
    - 1 key on numeric keypad if display the "1" char and keycode 97

    With default langage to English if i press :
    - the 1 key it display the "1" char and keycode give 49 code
    - shift+1 key it display the "!" char and keycode 1049
    - 1 key on numeric keypad if display the "1" char and keycode 97

    So the only keycode that is similar to french and english keyboard is 97 for "1", 98 for "2", etc....

    What do you think about that ????

    Thank you

  8. #18
    Newbie
    Join Date
    Apr 2005
    Posts
    26
    moreover, i've just looked into your module APIStuff.bas and i found that you're declaring as constant :

    Public Const VK_1 = &H31 ' 1 key

    wich is the code 49 for "1" in english but for "&" in french...

    Do you think everything would be right if you change it to :

    Public Const VK_1 = &H61 ' 1 key

    wich is code 97 for "1" in english and french ???

  9. #19
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    I have actually tried to use VK_xxx codes to send to the WinTV Radio application, but because of the way it handles keyboard input, it only works with the sendkey function which basically sends "raw" text data... I'm assuming the numbers are not so much of an issue as the decimal point may be.. but both could be related.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

Page 2 of 2 FirstFirst 12

Similar Threads

  1. I *think* I have isolated the problem. help?
    By mpfjr in forum General Hardware Discussion
    Replies: 0
    Last Post: 02-24-2005, 04:53 PM
  2. Fm Radio
    By vicky_obee in forum Media Engine
    Replies: 9
    Last Post: 07-01-2004, 10:52 PM
  3. Using radio antenna for radio AND tv
    By pyros in forum General Hardware Discussion
    Replies: 1
    Last Post: 05-19-2004, 01:06 AM
  4. How do i make Radio working in MediaCar?
    By zvi in forum MediaCar
    Replies: 0
    Last Post: 05-16-2004, 02:38 PM
  5. FM radio Question
    By thepogcbr900rr in forum General Hardware Discussion
    Replies: 5
    Last Post: 05-09-2004, 06:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •