Results 1 to 6 of 6

Thread: ExecTBL Commands for Video_Player.Skin

  1. #1
    Low Bitrate Prem's Avatar
    Join Date
    Oct 2004
    Location
    West Sussex UK
    Posts
    85

    ExecTBL Commands for Video_Player.Skin

    Guino

    Think I've found another bug. When creating translation commands in ExecTBL.ini they will work on all .skin files except video_player.skin and video_browser.skin. I have tried this with a number of different commands and a number of different inputs, all with the same result.

    I assume that the video_player and browser skin files are used in both playing DIVX and DVDs?

    Cheers

    Prem
    Re-boxed Dell Optiplex GX110 PIII 733 256Mb RAM
    Modified Sproggy PSU
    Custom made automatic start-up/ shut-down controller
    Dual 2.5" HDDs
    Laptop DVD Reader
    D-Link FM Radio
    5" PSOne LCD
    Installed and working. 75% complete.

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    I'll take a look, but there's no distinction between the skins within the code.. it should work the same way that it does for other screens.

    If you use MPC for DVD playback, it will use the same video_player.skin file as for video.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    Low Bitrate Prem's Avatar
    Join Date
    Oct 2004
    Location
    West Sussex UK
    Posts
    85
    Guino

    Just to show you what I have done, the following is from my ExecTBL.ini file:

    "Button1","!Select||BACK||EXIT",audio_browser. skin
    "Button1","CTRLEXEC",Audio_Player.skin
    "Button1","CTRLEXEC",DESTINATOR_GPS.skin
    "Button1","CTRLEXEC",exit_menu.skin
    "Button1","CTRLEXEC",LIST.skin
    "Button1","CTRLEXEC",menu.skin
    "Button1","CTRLEXEC",mixer.skin
    "Button1","CTRLEXEC",RADIO_MENU_FUNCTION.skin
    "Button1","CTRLEXEC",Radio_Player.skin
    "Button1","CTRLEXEC",video_browser.skin
    "Button1","CTRLEXEC",video_player.skin

    "Play2","Stop||Play",Audio_Player.skin
    "Play2","Stop||Play",DESTINATOR_GPS.skin
    "Play2","Stop||Play",LIST.skin
    "Play2","Stop||Play",menu.skin
    "Play2","Stop||Play",mixer.skin
    "Play2","Stop||Play",RADIO_MENU_FUNCTION.skin
    "Play2","Stop||Play",Radio_Player.skin
    "Play2","Play",video_browser.skin
    "Play2","Play",video_player.skin

    Normal functions called by girder within the videoplayer (e.g. left and right) but when I create something in ExecTBL.ini it doesn't work.

    Hope this helps.

    Cheers

    Prem
    Re-boxed Dell Optiplex GX110 PIII 733 256Mb RAM
    Modified Sproggy PSU
    Custom made automatic start-up/ shut-down controller
    Dual 2.5" HDDs
    Laptop DVD Reader
    D-Link FM Radio
    5" PSOne LCD
    Installed and working. 75% complete.

  4. #4
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    I'll do some tests.. but I don't know what the problem could be (yet)..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  5. #5
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    This is what I placed in ExecTBL.INI (so I wound't have to edit skins):

    "PLAY","VOL-||PLAY2",video_player.skin
    "PLAY","VOL+||PLAY2",audio_player.skin
    "PLAY2","PLAY"


    It worked perfectly, that is.. on the video player, hitting play would decrease the volume and then pause/play. On the audio player, the opposite effect was obtained.

    I'd suggest you post your entire exectbl.ini (probably zipped), so I can look at it. Other than that, if you're using girder to send "PLAY2" make sure it is sending commands to RR.EXE's window and not just any window -- I'd even go as far as duplicating one of the commands that works and then changing it to "play2".
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  6. #6
    Low Bitrate Prem's Avatar
    Join Date
    Oct 2004
    Location
    West Sussex UK
    Posts
    85
    I am such a wally. Forgot to set girder to target RR.exe.

    Sorry for waisting your time man.



    Prem
    Re-boxed Dell Optiplex GX110 PIII 733 256Mb RAM
    Modified Sproggy PSU
    Custom made automatic start-up/ shut-down controller
    Dual 2.5" HDDs
    Laptop DVD Reader
    D-Link FM Radio
    5" PSOne LCD
    Installed and working. 75% complete.

Similar Threads

  1. SpeakEasy Voice Recognition - Beta 1
    By ruairi in forum Road Runner
    Replies: 31
    Last Post: 08-22-2006, 11:12 PM
  2. at+.... commands in phonecontrol for cdma
    By dirtylarry in forum PhoneControl
    Replies: 54
    Last Post: 05-14-2005, 04:27 AM
  3. Replies: 3
    Last Post: 03-08-2005, 02:31 AM
  4. Serial Commands with MediaEngine
    By angeLCD in forum Media Engine
    Replies: 1
    Last Post: 05-10-2004, 09:49 AM
  5. Voice commands
    By droog in forum Software & Software Development
    Replies: 7
    Last Post: 10-17-1999, 03:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •