Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: OSK string insert

  1. #1
    Low Bitrate jollyeskimo's Avatar
    Join Date
    Apr 2005
    Location
    Toronto
    Posts
    90

    OSK string insert

    Everything's been running fine and dandy, but the OSK's been behaving a bit weird ever since I switched from pure iGuidance to iGuidance embedded with skinbedder. Basically all I did was add an APPOSK button to my external GPS page.

    When I try to type something into the street name entry window via OSK, the full string displays on the OSK window... but upon entering it, some of the characters see to be missing from the full string. Something like "mississauga" in the OSK window would end up as "missga" in the iguidance text prompt, I haven't used it enough to tell if there's a pattern to it.

    Any thoughts?

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    does it happen at all when skinbbedder is not used ? that would tell you if the problem is in RR or skinbedder (or it's settings)..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    Low Bitrate jollyeskimo's Avatar
    Join Date
    Apr 2005
    Location
    Toronto
    Posts
    90
    without skinbedder the missing characters seem to stop, but now I notice that there's a new bug with a definite pattern:

    1.
    string entererd in OSK: "testing"
    string showing in iG field: "testing"

    2.
    string entered in OSK: "testig" + LEFT cursor + "n"
    string showing in OSK: "testing"
    string showing in iG field: ""testign"
    string that semantically should be showing in iG field: "testing"


    See what I mean? the cursor actions seem to do nothing.

  4. #4
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    is the above with or without skinbedder ?? If the OSK works fine without the skinbedder than this is not a problem with RR, but with Skinbbeder+IG..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  5. #5
    Low Bitrate jollyeskimo's Avatar
    Join Date
    Apr 2005
    Location
    Toronto
    Posts
    90
    Yeah I guess this isn't an issue with RR anymore, haha

    No matter anyways, finally figured out that iGuidance's blasted OSK only works with 96dpi instead of 120dpi in windows, which makes all of this kind of redundant.

  6. #6
    Low Bitrate
    Join Date
    Aug 2005
    Posts
    103

    Similar OSK problem

    I am using the standard BMV2 skin. When I click on the WEB link, my I.E. browser opens to google. When I use the OSK to type in the google search, all works well. When I click on the address bar and try and type an address, the text in the OSK appears fine, but in the address bar only the last character appears.

    I added an OSK button to my external GPS window, and this is also the case when I try and use OSK on any fields within Delorme. Only the last character appears in the string.

    Any ideas?

    Thanks

  7. #7
    Maximum Bitrate Mad Ad's Avatar
    Join Date
    Oct 2004
    Location
    Hertfordshire UK
    Posts
    533
    seems lots of people are having to add their own osk button to the gps window- shouldnt there be one in the default setup?

  8. #8
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Quote Originally Posted by F350
    I am using the standard BMV2 skin. When I click on the WEB link, my I.E. browser opens to google. When I use the OSK to type in the google search, all works well. When I click on the address bar and try and type an address, the text in the OSK appears fine, but in the address bar only the last character appears.
    I added an OSK button to my external GPS window, and this is also the case when I try and use OSK on any fields within Delorme. Only the last character appears in the string.
    Any ideas?
    Thanks
    This feature is HIGHLY dependent on the application in question... IE will not allow you to type stuff on the address bar because every character you type selects the entire text on the address bar, and that is then replaced with the next character you type -- THATS WHY THERE IS AN OPEN URL BUTTON! My guess is the same is happening with your Delorme software...
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  9. #9
    Low Bitrate
    Join Date
    Aug 2005
    Posts
    103
    Yes, you are correct about the auto complete fields. And I finally noticed the URL button while working on my skin.

    So is there a work around for this? How would I type text into these auto complete fields in my Delorme software (besides an actual keyboard). I'll see if I can turn this feature off.

    Thanks.

  10. #10
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    I'd have to try and do some real funky API work to try and make it work.. for now the only thing that will work is the Windows OSK (which is not that great for touchscreens).. but you could easily launch it using a button in RR's skin.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

Page 1 of 2 12 LastLast

Similar Threads

  1. OSK... need help/ideas..
    By guino in forum Road Runner
    Replies: 27
    Last Post: 06-25-2006, 07:49 PM
  2. OSK and iguidance
    By kuo in forum Road Runner
    Replies: 9
    Last Post: 07-19-2005, 06:31 PM
  3. OSK bug ????
    By tolisn in forum RR Bug Tracker
    Replies: 3
    Last Post: 03-31-2005, 11:25 AM
  4. Dual OSK Possible?
    By grnikolis in forum Map Monkey
    Replies: 0
    Last Post: 03-27-2005, 10:24 AM
  5. OSK clobbers comm port?
    By wi77iam in forum Software & Software Development
    Replies: 7
    Last Post: 03-25-2004, 11:12 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •