Results 1 to 8 of 8

Thread: Auto resume no longer works

  1. #1
    Low Bitrate
    Join Date
    Sep 2005
    Location
    UK
    Posts
    110

    Auto resume no longer works

    Dispite using these forums for the last 4 months this is my first post so be gentle.

    Firstly want to say thanks to all the guys involved in my current carputer setup, you dont know who you are so I will name you: guino (for a great piece of software and constant updates) liquid smoke (for LS3 my new favourite road runner skin) and zorro (for a cool phone application).

    Now down to the point of this post. I have been using Road Runner for the last 3 months or so and all the development is great, however about 3 releases ago the auto resume of music stopped working (well, stopped working consistantly) I have read all the suggestions on the forum I think, I have tried inplugging my USB bluetooth device, I do not use XM radio so that can't be an issue. Interestingly I have tried disabling auto resume and installing an autostart plugin for winamp. This works 100% of the time, the only problem is because I use Phoco the music starts 15 seconds before I can change the volume which is realy anoying at 6am in the morning when I get in the car.

    Only other usefull information I can give is that I do not hibernate my carputer I shut it down.

    Any ideas?

    Cheers

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    if you don't use the PC as a headset for the blue-tooth, you can try disabling the audio device from your blue-tooth adapter.. it seems to "cut off" the sound from the main sound card when resuming from hibernation... you can also try to close/reopen winamp on hibernate/resume.. search for "ONRESUME" and "ONSUSPEND"... this all is of course, assuming you're talking about hibernation..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    Low Bitrate
    Join Date
    Sep 2005
    Location
    UK
    Posts
    110
    I tried disabling the sound device for bluetooth this and I have to say I was most excited when it worked the first time a booted into roard runner but it seem this was blind luck. I am not using hidernation so I dont think any of the other suggestions apply. I have to say one thing I have noticed is when the audio plays for a second before it cuts out it always seems to play from the start of a song. If you go into the audio player and press play it resumes from where it was shut down from. Could this be anything to do with the auto resume code kicking in before the play start command?

    Thanks for your help so far

  4. #4
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    I have never really seen this happen when not using Hibernation... do you have any other AUDIO USB devices installed (besides from the bluetooth device) ?
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  5. #5
    Low Bitrate
    Join Date
    Sep 2005
    Location
    UK
    Posts
    110
    No, no other audio devices installed. As I said in the first post it seems strange that winamp with an autoresume plugin works without issues, yet RR seems to have problems. Is there any way of getting roadrunner to output its commands etc to some sort of a log file or something?

    I am using winamp 2 at teh moment, I may try using winamp 5 as a test. Also I guess it may be a good idea to manually start road runner at boot so if it is another process interfering at start up wee can eliminate the possability.

  6. #6
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    add to RR.INI:

    debugmode=true

    and a debug.txt file will be created with everything RR executes..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  7. #7
    Low Bitrate
    Join Date
    Sep 2005
    Location
    UK
    Posts
    110
    Thanks Guino. I have attached the debug. The first debug block is of the resume cutting out, the second is of the resume working.

    The only difference I can see is during and after the below lines. Obviously the action after these lines are users but I believe the below lines are all Roadrunner, what is Sim.WMSGs: 1 and does the position of play between these have any bearing on the result.

    19/09/2005 19:41:59: Shell: "C:\Program Files\Winamp\winamp.exe"
    19/09/2005 19:42:07: Sim.WMSGs: 1
    19/09/2005 19:42:08: Sim.WMSGs: 1
    19/09/2005 19:42:08: Executing: PLAY

    19/09/2005 22:10:04: Shell: "C:\Program Files\Winamp\winamp.exe"
    19/09/2005 22:10:17: Sim.WMSGs: 1
    19/09/2005 22:10:17: Executing: PLAY
    19/09/2005 22:10:18: Sim.WMSGs: 1

    You veiws are greatly apriciated
    Attached Files Attached Files

  8. #8
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    try the hibernateaware=false in RR.INI along with this patch: http://guino.mpug.co.uk/rr.exe

    SimWMSGs are simultaneous calls to RR's window procedure -- can be potentially dangerous in same cases, but shoudn't affect winamp in general..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

Similar Threads

  1. Replies: 22
    Last Post: 08-06-2006, 03:57 PM
  2. Appsthat don't resume right
    By Cat Monkey in forum General Hardware Discussion
    Replies: 2
    Last Post: 12-01-2004, 05:47 AM
  3. Replies: 2
    Last Post: 11-25-2003, 10:50 PM
  4. Last thing until it works...need auto startup!
    By detz in forum General Hardware Discussion
    Replies: 17
    Last Post: 08-19-2002, 04:42 PM
  5. Resumer Winamp plugin..works with MPC, too
    By Tony S in forum Software & Software Development
    Replies: 7
    Last Post: 03-30-2002, 05:10 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •