Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Still having XMPCR problems

  1. #11
    Constant Bitrate
    Join Date
    Jan 2004
    Location
    Champaign, IL
    Posts
    124
    So do you have plans to fix the XMPCR issues?
    I can't compile your open source code without some effort, it seems (had planned on fixing your XMPCR code myself). Where do you suggest I go from here?
    Are there really only 4 or 5 people affected by this??

  2. #12
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    I'll take the time to do some more testing with the XMPCR as soon as I have time.. I've been travelling for work for the past 2 weeks and I'll travel again this week, so don't expect anything very soon but it is on top of my list of things to do. You can PM me with the issues you have with the source code, but most likely you don't need to meet all the requirements to RUN the source code inside VB and debug the issue you're having.. to COMPILE is that you need all nice an neat.. If you find a solution, you can just send me the changes and I'll put on the main sources and compile it for everyone.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #13
    FLAC IntellaWorks's Avatar
    Join Date
    Jun 2004
    Location
    NH
    Posts
    1,173

    .

    For testing purposes, RJ try doing what guino did for testing his software. Hibernate (or resume), unplug device, resume (come out of hiber) then plug back in. Do you get the same results as the original problem? Or did the problem go away?

    The reason I ask is because if I were writing the software I'd want to work with a known. And the feedback might help him fix the problem faster.

    Guino: I haven't investigated this problem too deeply so forgive me if I'm way off. If the users have XMPCR configuration checked off in RR, you may be able to capture the hibernation or resume request by hooking into the messaging que and holding it for a bit while RR manually disable's the usb device (I.E "remove it saftley")

    Goodluck all!
    Progress [I will seriously never be done!]
    Via EPIA MII
    512MB RAM
    OEM GPS (embedded)
    nLite WinXP pro on
    1GB Extreme III CF card
    Carnetix 1260 startup/ DC-DC regulator
    Software: Still, re-Writing my existing front end in .Net

  4. #14
    Constant Bitrate
    Join Date
    Jan 2004
    Location
    Champaign, IL
    Posts
    124
    Thanks for the comments, both of you. I am happy to test this as Guino has implemented it (standby, unplug device, resume, plug device back in), but ultimately the real issue is whether it can work as it would be used in a real environment (standby, leave device connected OR cut power -- as in from a powered USB hub, then reconnect/power-on, then resume). Now that Guino has an XMPCR it will only take his time for him to fix it.
    And I really appreciate your time, Guino. I understand that you have many other more pressing things to take care of, so I will try to work on it myself. You are simply much, much, much faster than me!
    As for 'testing data', I am happy to send a PM with a recap of everything I have experienced with this issue, so that you can develop a solution a little better.
    Thanks, as always.

  5. #15
    Maximum Bitrate skippy76's Avatar
    Join Date
    Mar 2004
    Location
    Cambridge, MA, USA
    Posts
    507

    XM problems with current relase of RR

    Hi guys,

    I've just upgraded to the latest verison of RR and I'm finding that my XM(PCR) is not working anymore through RR. I have the port correctly set in the config... Anyone else having these problems?

    Thanks

    Andrew
    06 Volvo XC90
    Use to have installed MII 10000/512Mb/40GB, Lilliput 7", OPUS 90W, Wifi-G PCMCIA, Head Unit Aux adapter, Delorme GPS, XM PCR, Audigy NX, RR
    Car PC downloads: http://carpc.harteveldt.com/

  6. #16
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    I'll be doing some more testing with this today or during the weekend.. you should expect something soon.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

Page 2 of 2 FirstFirst 12

Similar Threads

  1. DWW-700M/MTS12000 Motorized In Dash LCD Problems
    By techy101 in forum LCD/Display
    Replies: 17
    Last Post: 06-29-2005, 08:12 PM
  2. Using an XM direct as an XMPCR
    By dacndar in forum General Hardware Discussion
    Replies: 20
    Last Post: 10-17-2004, 02:21 AM
  3. XMPCR has hibernation problems?
    By MikeH in forum FrodoPlayer
    Replies: 29
    Last Post: 09-24-2004, 11:08 PM
  4. Dell Inspiron 8200 & Lilliput TS problems?
    By bkpsu in forum LCD/Display
    Replies: 1
    Last Post: 08-15-2004, 02:55 PM
  5. Problems with GPS mouse and XMPCR
    By DaveDog in forum GPS
    Replies: 0
    Last Post: 06-11-2004, 01:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •