Results 1 to 5 of 5

Thread: Indicator Within button border problem

  1. #1
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,701
    Blog Entries
    1

    Indicator Within button border problem

    First, Road Runner is absolutely amazing!!! I have been reading the forums from top to bottom over the past 2-3 weeks, looking for any kewl tricks, new ideas & so forth. I can't beleive that RR is just over a year old! RR has come so much further that MC ever did in it's entire existance!

    Ok, now to the isssue... Not really sure if it is a bug or not.....

    I am trying to use an indicator within a buttons defined area, and can not get it to work. If I move the border of the button to the side of the indicator it works perfectly.

    In this case, I am finishing an OSK, and have a Caps Lock light that I want to display on the key itself. I am not sure if that can be corrected easily in the code or not, as it seems to be layers fighting to be on top. Same goes for putting an indicator on a mute button. I have check many, many skins, and see that everyone just puts the indicators outside the defined button area.

    This may be something just to have to deal with, as it seems like a layers conflict, and will move the indicator to another location on the screen for now.

    I thought I would ask, as searching the forums turned nothing up, that I could find at least.
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  2. #2
    Maximum Bitrate kpjuk's Avatar
    Join Date
    Dec 2003
    Location
    West Midlands
    Posts
    474
    Hi John,

    I have a blinking MUTE indicator on a button, with the following code lines, Button first, then label then indicator

    B04,113,513,118,90,"MUTE","Mute"

    L11,129,522,83,27,255,255,255,18,"Arial:B","=MUTE" ,"CENTER"

    I03,126,549,87,12,"MUTE:b"

    I keep all button definitions together first, then the Label Definitions, then the indicators. This works fine for me !

    If your skinning an OSK, have a look at the SilentAdmirer skinnable keyboard. For download see note 8 of this thread Web Browser Keyboard

    Cheers
    KPJUK
    M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
    DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

  3. #3
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,701
    Blog Entries
    1
    I checked out the virtual keyboard, is very nice looking! I think it is a bit small for a 7" touch screen for me and my big fingers in the car

    Thanks for the tip, however I ordered & grouped the items as suggested, still a no go.

    Actually there are no lables in a OSK skin, it uses the "K" (Key Tags), and only one button required to clear the text box.


    Here is a condensed version of the skin:

    PHP Code:
    MEDIACAR Skin
    MEDIACAR OSK Skin
    OSK_off
    .jpg,OSK_off.jpg,OSK_on.jpg,OSK_down.jpg 

    /, Txywhfont color R;RGBGBback color R;RGBGBfont size;FONTfont nameCodetooltip
    T01
    ,8,18,550,69,255,255,0,57,57,57,20,"Arial Narrow:B","","Country"

    /, BxywhCommand;COMMANDCODESTooltip
    B52
    ,590,21,79,77,"CLEARTEXT",""

    /, KxywhLineAsciiCodetooltip
    K17
    ,4,349,059,078,002,097,065,"A","A"
     
    < < < < A Thru Z keys all here ect > > > >

    K18,4,429,059,078,002,122,090,"Z","Z"

    /, IxywhCode;INDICATORCODES
    I02
    ,34,544,31,32,"CAPS"

    END 
    The Indicator area light's up when pressed, but goes off as soon as another key is pressed.

    If I move the button's "perimeter" to avoid overlaying the indicator area, the indicator will stay in the on state until the CAPS button is pressed again.

    I am wondering if it is something to do in the RR.exe with the KEY command being treated differently than a BUTTON command. Just as a side note, I did try the SHIFTLOCK command in place of the CAPS command, and the same results occur. I know they are the same command, but was willing to try to see if it was "hooked" into the RR.exe differently.


    While in this discussion, is there a way to send multiple key commands from a single button press /KEY command? Would be very handy to have a "www." button as well as a ".com" one on the OSK

    .
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  4. #4
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,166
    Blog Entries
    52
    i believe the indicator HAS to be set to blink to work correctly. Just add ":b"
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  5. #5
    Maximum Bitrate kpjuk's Avatar
    Join Date
    Dec 2003
    Location
    West Midlands
    Posts
    474
    Hi John,

    Sonicxtasy02 I think is correct, I have only ever used blinking indicators. I had a number of issues getting the built in OSK to work with the web screens, and also kept getting characters echoed twice ! For this reason I searched and found the virtual keyboards which incidentally work outside of RR, as they are exe files.

    You can create a skin with any size keyboard, to suit your screen size, but I get by with this one on an 8" screen, and its way bigger than the Microsoft one that comes with windows.

    My only other suggestion would be to check out the OSK's on other skins to see if they have achieved anything like what you are looking for.

    cheers
    KPJUK
    M1000, 512MB, 512MB CF, 6GB Disk (4200rpm),
    DVD/RW, Dynamix 8" screen, M2-ATX, Custom case,Too many hours building and rebuilding and rebuild.......

Similar Threads

  1. Button request: Minimize
    By DaveB in forum Mobile Impact
    Replies: 17
    Last Post: 01-04-2007, 08:35 PM
  2. BMW iBus problem - Not detecting Button Pressed
    By captain_jim1 in forum Software & Software Development
    Replies: 11
    Last Post: 06-14-2006, 03:10 PM
  3. Replies: 3
    Last Post: 05-18-2006, 03:03 PM
  4. Centrafuse 1.6 Bugs
    By Mbai2 in forum CF Bug Reports
    Replies: 57
    Last Post: 05-10-2006, 10:30 AM
  5. Replies: 2
    Last Post: 04-04-2005, 03:45 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •