Page 4 of 13 FirstFirst 12345678910111213 LastLast
Results 31 to 40 of 124

Thread: OLD Wifi Manager - No longer supported

  1. #31
    Low Bitrate
    Join Date
    Jan 2007
    Posts
    97
    I was able to get it working, but as laposelemer is experienceing, the wifi manager loads up behind RR but doesn't show through, nor does it take the intended shape of the area box. all buttons work fine (except enable/disable - my fault though, screwed up my connection awareness and need to reinstall). My system doesn't hang however.

    EDIT: It appears I'm having a problem with the new wireless.exe program - could be related to an issue I created earlier. The program won't stay open in the background. it launches then closes right away. Once RR is open and I run wireless.exe, the wifi manager resizes the wifi window and loads it in to RR but if I click any buttons in RR, the wifi window hides behind RR and I have to alt-tab to get it back. If I hit the wifi buttons "connect, refresh, etc" it's fine.

  2. #32
    FLAC
    Auto Apps:loading...
    EL CAMINO's Avatar
    Join Date
    Jul 2005
    Location
    upland california us
    Posts
    1,283
    Quote Originally Posted by pwntbypat View Post
    Sweet! thanks for the enable/disable feature. that kicks ***.

    Okay, having issues again. replaced wifi_man and wireless.exe with updated versions, replaced exectbl line with new line and changed the exe location name (that's it). When I load the wireless skin, I get the wifi_man, but none of the buttons work and I don't get any "status" labels to show up.

    I think the issue might be with devcon and the fact that the wireless card I have doesn't have a dev value. Under device id I have:
    USB\VID_13B1&PID_000B\5&1DD5D721&0&1
    the buttons dont work because the skins commands are different now, as you can see in the ExecTBL. ckeck the sample skin to see the difference. i did this because some people were having some issues with the "Wireless Connnection Manager" window(including johnWPB, DFX), so i change the window title to "Wifi Information". the only buttons that aren't included in the sample skin are enable/disable. but they do work. as long you get the dev number. dont know why the dev number is not listed in your card. is there any way you can test this with another card?

  3. #33
    FLAC
    Auto Apps:loading...
    EL CAMINO's Avatar
    Join Date
    Jul 2005
    Location
    upland california us
    Posts
    1,283
    Quote Originally Posted by pwntbypat View Post
    I was able to get it working, but as laposelemer is experienceing, the wifi manager loads up behind RR but doesn't show through, nor does it take the intended shape of the area box. all buttons work fine (except enable/disable - my fault though, screwed up my connection awareness and need to reinstall). My system doesn't hang however.

    EDIT: It appears I'm having a problem with the new wireless.exe program - could be related to an issue I created earlier. The program won't stay open in the background. it launches then closes right away. Once RR is open and I run wireless.exe, the wifi manager resizes the wifi window and loads it in to RR but if I click any buttons in RR, the wifi window hides behind RR and I have to alt-tab to get it back. If I hit the wifi buttons "connect, refresh, etc" it's fine.
    are you sure is embeded?, can you please post your wireless.skin, your ExecTBl lines for this and paths for the exe's.

  4. #34
    Low Bitrate
    Join Date
    Jan 2007
    Posts
    97
    I completely re-made my wireless.skin file and exectbl with the code provided in the new readme. The only thing I think I changed was $skinpath$wireless.exe to $skinpath$scripts\wireless.exe

    all my files (wifi_man.exe, wireless.exe, and devcon.exe as well as wifi_man.ini) are located in:
    C:\Program Files\Road Runner\skins\Shock v5.0\SCRIPTS\

    exectbl
    Code:
    "WIRELESS","LOAD;wireless.skin;WIFI;;Wireless Network Connection||SETTOPMOST;RR;TRUE||RUNQW;$SKINPATH$scripts\wireless.exe||SETTOPMOST;RR;FALSE||ACTIVATE;Wireless Network Connection"
    "NEXT_WIFI","Activate;WiFi Information||SENDKEY;{DOWN}"
    "PREV_WIFI","Activate;WiFi Information||SENDKEY;{UP}"
    "REFRESH_WIFI","Activate;Wifi Information||SENDKEY;{F5}"
    "CONNECT_WIFI","Activate;Wifi Information||SENDKEY;%c"
    "DISCONNECT_WIFI","Activate;Wifi Information||SENDKEY;%d{ENTER}"
    "DISABLE_WIFI","SENDMSG;wifi_man;disable"
    "ENABLE_WIFI","SENDMSG;wifi_man;enable"
    to call wireless skin/app
    Code:
    /DEFINE B10_FUNCTION    "WIRELESS"
    skin.ini
    Code:
    MEDIACAR Skin
    MEDIACAR wireless Skin
    Wifi_menu_off.png,wifi_menu_off.png,wifi_menu_on.png,wifi_menu_off.png
    INC,settings.txt
    /, A, x, y, w, h, color;RGB
    A,228,92,508,225,000,,
    
    L,698,3,100,45,#TOPBAR_RED#,#TOPBAR_GREEN#,#TOPBAR_BLUE#,#TOPBAR_SIZE#,#FONT#,#BUTTON1#,"CENTER"
    L,584,3,106,45,#TOPBAR_RED#,#TOPBAR_GREEN#,#TOPBAR_BLUE#,#TOPBAR_SIZE#,#FONT#,#BUTTON2#,"CENTER"
    L,464,3,110,45,#TOPBAR_RED#,#TOPBAR_GREEN#,#TOPBAR_BLUE#,#TOPBAR_SIZE#,#FONT#,#BUTTON3#,"CENTER"
    L,350,3,108,45,#TOPBAR_RED#,#TOPBAR_GREEN#,#TOPBAR_BLUE#,#TOPBAR_SIZE#,#FONT#,#BUTTON4#,"CENTER"
    L,232,3,107,45,#TOPBAR_RED#,#TOPBAR_GREEN#,#TOPBAR_BLUE#,#TOPBAR_SIZE#,#FONT#,#BUTTON5#,"CENTER"
    L,115,3,104,45,#TOPBAR_RED#,#TOPBAR_GREEN#,#TOPBAR_BLUE#,#TOPBAR_SIZE#,#FONT#,#BUTTON6#,"CENTER"
    L,5,3,101,45,#TOPBAR_RED#,#TOPBAR_GREEN#,#TOPBAR_BLUE#,#TOPBAR_SIZE#,#FONT#,#BUTTON7#,"CENTER"
     
    /, L, x, y, w, h, color R;RGB, G, B, font size;FONT, font name, Code;LABELCODES, Tooltip;LABELALIGNMENT
    L,64,101,151,29,255,255,255,14, #FONT#,"=REFRESH","CENTER"
    L,64,163,151,21,255,255,255,14, #FONT#,"=CONNECT","CENTER"
    L,64,224,151,21,255,255,255,14, #FONT#,"=DISCONNECT","CENTER"
    L,64,282,151,21,255,255,255,14,#FONT#,"=UP","CENTER"
    L,64,341,151,21,255,255,255,14,#FONT#,"=DOWN","CENTER"
    
    L01,240,341,187,28,255,255,255,14,#FONT#,"=Network:","LEFT"
    L01,500,341,187,28,255,255,255,14,#FONT#,"=Signal:","LEFT"
    L01,331,341,187,28,255,255,255,14,#FONT#,"CUSTOM_WIFI_SSID","LEFT"
    L01,569,341,187,28,255,255,255,14,#FONT#,"CUSTOM_WIFI_SIGNAL","LEFT"
     
    /, B, x, y, w, h, Command;COMMANDCODES, Tooltip
    B,54,93,162,51,"REFRESH_WIFI","refresh"
    B,54,152,162,51,"CONNECT_WIFI","connect"
    B,54,211,162,51,"DISCONNECT_WIFI","drop connection"
    B,54,270,162,51,"NEXT_WIFI","next"
    B,54,329,162,51,"PREV_WIFI","previous"
    B,228,329,250,51,"ENABLE_WIFI","enable"
    B,489,329,250,51,"DISABLE_WIFI","disable"
    
    /Indicators
    I,202,469,97,10,"MUTE:b"
     
    /Buttons
    B,703,405,102,78,"exit",
    B,601,404,100,78,"SHUFFLE",
    B,501,404,99,78,"NEXT",
    B,400,404,102,78,"PLAY",
    B,300,404,99,78,"PREV",
    B,199,404,100,78,"MUTE",
    B,96,404,103,78,"VOL-",
    B,0,404,98,77,"VOL+",
    B,695,0,106,72,#B1_FUNCTION#,
    B,579,0,116,71,#B2_FUNCTION#,
    B,462,0,116,71,#B3_FUNCTION#,
    B,347,0,114,72,#B4_FUNCTION#,
    B,228,0,117,73,#B5_FUNCTION#,
    B,110,0,116,74,#B6_FUNCTION#,
    B,0,0,109,72,#B7_FUNCTION#,
    
    END

  5. #35
    Newbie
    Join Date
    Sep 2006
    Location
    Budapest, Hungary
    Posts
    6
    Hi!

    Some improvements!

    1. I found the most useful conbination for me: ver0.4 wireless.exe and wifi_info.exe
    but in the exectbl.ini I use the ver 0.3 exectbl content for run.
    In this case when I call the wireless skin, the wireless.exe run correctly more or less.
    The system hang up about 10-15 sec, after the time the wireless.exe closes itself. And do this only 1 time. If I recall wireless skin it shows the manager correctly.

    With the ver0.4 exectbl contents the the system stays hanging. And do this every time I recall the wireless skin.

    2. I can reach that to fill out the box:
    in exectbl I changed "your" connection name to "my" connection name
    "WIRELESS","LOAD;wireless.skin||SETTOPMOST;RR;TRUE ||RUNQW;$SKINPATH$\wireless.exe;My connection name||GETFOCUS"

    and I did the same with te button codes.

    Still problem:
    when I load wireless skin, the wireless.exe calls the "network connections" instead of "reachable wireless network connections" and not the whole system hangs up, only the cursor ?? (it seems the wireless.exe can't close itself or run correctly,because if I shut it down with task manager everything ok) and I have to open manually the "reachable wireless network connections", after this it fill out the box.
    Still don't give any info about the connection except speed and type.

    I tried this skin on my work laptop, which has builtin wifi and this device has dev.no.
    and I have an USB wifi for my car, it hasn't dev.no. hmm...

    +1: my hungarian language windows can cause problems to your program to handle the network windows correctly? I mean my window names are translated and this can cause problem?

  6. #36
    Low Bitrate
    Join Date
    Jan 2007
    Posts
    97
    I solved my issues (not the dev id but everything else)

    The code for exectbl shipping with the latest version still calls for the old wireless connection window "wireless netowrk connection" while it should be looking for the new window "wifi information".

    This is the working exectbl code
    "WIRELESS","LOAD;wireless.skin;WIFI;;Wifi Information||SETTOPMOST;RR;true||RUNQW;$skinpath$\ wireless.exe||SETTOPMOST;RR;FALSE||ACTIVATE;Wirele ss Network Connection"
    new issue, the connection labels are not working for me. before I didn't have a wifi network to connect to (my bad... heh) but when I connect to a network, I still get "not connected" as status.

  7. #37
    FLAC
    Auto Apps:loading...
    EL CAMINO's Avatar
    Join Date
    Jul 2005
    Location
    upland california us
    Posts
    1,283
    yes, sorry for that ExecTBL line, my bad, about the labels, i got the bug killed now(Many thanks to johnWPB for his help).i uploaded the new wifi_man, with that issue fixed. just replace the Wifi_man.exe.Another thing in the line you fixed, replace the last "Wireless Network Connection", with "Wifi Information" as well.

  8. #38
    FLAC
    Auto Apps:loading...
    EL CAMINO's Avatar
    Join Date
    Jul 2005
    Location
    upland california us
    Posts
    1,283
    Quote Originally Posted by laposelemer View Post
    Hi!

    Some improvements!

    1. I found the most useful conbination for me: ver0.4 wireless.exe and wifi_info.exe
    but in the exectbl.ini I use the ver 0.3 exectbl content for run.
    In this case when I call the wireless skin, the wireless.exe run correctly more or less.
    The system hang up about 10-15 sec, after the time the wireless.exe closes itself. And do this only 1 time. If I recall wireless skin it shows the manager correctly.

    With the ver0.4 exectbl contents the the system stays hanging. And do this every time I recall the wireless skin.

    2. I can reach that to fill out the box:
    in exectbl I changed "your" connection name to "my" connection name
    "WIRELESS","LOAD;wireless.skin||SETTOPMOST;RR;TRUE ||RUNQW;$SKINPATH$\wireless.exe;My connection name||GETFOCUS"

    and I did the same with te button codes.

    Still problem:
    when I load wireless skin, the wireless.exe calls the "network connections" instead of "reachable wireless network connections" and not the whole system hangs up, only the cursor ?? (it seems the wireless.exe can't close itself or run correctly,because if I shut it down with task manager everything ok) and I have to open manually the "reachable wireless network connections", after this it fill out the box.
    Still don't give any info about the connection except speed and type.

    I tried this skin on my work laptop, which has builtin wifi and this device has dev.no.
    and I have an USB wifi for my car, it hasn't dev.no. hmm...

    +1: my hungarian language windows can cause problems to your program to handle the network windows correctly? I mean my window names are translated and this can cause problem?
    if you want to use the enable/disable feature you need the DEV number if not dont worry.

    +1 that might be the case, please post a screencap of the next windows,
    "Network Connections" and "Wireless Network Connection" so i can fix that for you.
    (i need to see the window title of each one)

  9. #39
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,700
    Blog Entries
    1
    Quote Originally Posted by EL CAMINO View Post
    yes, sorry for that ExecTBL line, my bad, about the labels, i got the bug killed now.
    YOU got the labels bug killed?

    For anyone that was having problems with the labels showing up, it should be working perfectly now. Also there is some new code to check your wireless card name automatically, but am not sure if ElCamino included it in the in atest posted version.

    Overall this is a fantastic script, and blends seamlessly into Road Runner!

    Just make sure if you are using it, that you are using windows default wireless connection manager, and not one that many cards come with on the install CD. Personally, I just plugged in my WiFi adapter, and had windows look at the CD for the drivers, and did not install the software on the CD.
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  10. #40
    Low Bitrate
    Join Date
    Jan 2007
    Posts
    97
    everything is working perfectly. two thumbs up
    except enable/disable because of no dev-id

Similar Threads

  1. WiFi FAQ
    By jrtf83 in forum Wireless Communications
    Replies: 75
    Last Post: 12-30-2009, 06:16 PM
  2. Mercury's Polaris JAN/16/08 No Longer Supported.
    By EL CAMINO in forum RR Skins No Longer Supported
    Replies: 70
    Last Post: 08-26-2009, 02:08 PM
  3. Quick question about connecting my DIY wifi antenna
    By nobb in forum Wireless Communications
    Replies: 8
    Last Post: 01-23-2008, 11:23 AM
  4. Ultimate Mobile WiFi Kit ?! my dream !!
    By DJ_MACH7 in forum Wireless Communications
    Replies: 8
    Last Post: 11-02-2007, 05:30 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •