Page 12 of 49 FirstFirst ... 2345678910111213141516171819202122 ... LastLast
Results 111 to 120 of 485
Like Tree2Likes

Thread: OBDMPG - MPG OBDII Plugin for RR 6-12-09

  1. #111
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    I'll look into the trip odo and the zero reset as soon as I get back to my main computer on sunday.

    As for the connection issues i'm not sure if there is much I can do as the code that communicates with the ELM was not written by myself. My only guess is that it has something to do with the files dependent on the vb6 comm control. Perhaps something needs to be registered on your systems?

    I'll see what I can find.

  2. #112
    Newbie colosports's Avatar
    Join Date
    Oct 2008
    Location
    Tampa, FL
    Posts
    14
    Quote Originally Posted by aperali View Post
    I'll post exactaly the same problem as colosports posted. Im having the same problem and using com port #4. Everything works fine on this port with scantool s/w and Im sure my device is elm327 based.
    It shows only 0s on the obdmpg plugin.
    What could be happening?
    Did you try using the Debug.exe yet?
    OBDMPG - MPG OBDII Plugin for RR 6-12-09
    It shows the ELM status. Maybe that may help you solve your problem.

    I gave up on the plugin and am running scantools for now. Here's a few more things that I tried and failed:
    I installed the ELM driver to my laptop (which does not have the ScanTool program installed. It is running the newest version of RR and using the Carwings skin. I also tried changing the ports on the laptop and gave me the same problems of all zeros.

    The .ini file is:
    Code:
    [COMMUNICATION]
    COM=6
    
    [VEHICLE]
    MAF=TRUE
    LITERS=3.3
    VE=80
    TANK=19.1
    
    [AVERAGE]
    NUM=1
    AVG=0
    DST=0
    FUEL=0
    ADJ=1
    
    [OPTIONS]
    ExtraOBD=TRUE
    METRIC=FALSE
    The ELM I got was shipped to me from China. It was manufactured on Aug 08. Hopefully the information will help us determine why my ELM doesn't work and others do.

  3. #113
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,166
    Blog Entries
    52
    i noticed (at least in my versino i downloaded) that nowhere in the documents does it say to add the x,OBDMPG line to menu.skin. Also when i installed i skipped the step where you must put files in system32. Once i did both of those things it worked for me
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  4. #114
    Constant Bitrate aperali's Avatar
    Join Date
    Aug 2007
    Location
    Rio de Janeiro, Brazil
    Posts
    170
    Quote Originally Posted by Sonicxtacy02 View Post
    i noticed (at least in my versino i downloaded) that nowhere in the documents does it say to add the x,OBDMPG line to menu.skin. Also when i installed i skipped the step where you must put files in system32. Once i did both of those things it worked for me
    What file did you put into system32? odbmpg.dll? I didnt put any file there.

  5. #115
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,166
    Blog Entries
    52
    read the instructions it tells you to put a group of files into system32. Thats why its not working for you more than likely
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  6. #116
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    Quote Originally Posted by Sonicxtacy02 View Post
    i noticed (at least in my versino i downloaded) that nowhere in the documents does it say to add the x,OBDMPG line to menu.skin. Also when i installed i skipped the step where you must put files in system32. Once i did both of those things it worked for me
    You are right sonic, documentation is a bit lacking in some areas. My time is usually kind of limited so I focused on the skin_commands first.

    A quick overview for those who aren't sure what to do:
    1. Copy files from "Com Files" Folder into "C:\windows\system32"
    2. Add "x, OBDMPG" to the menu.skin file of the skin that you are using
    3. Copy "obdmpg.dll", "obdmpg.ini", and "RunMe.bat" into RR's main working directory
    4. Double click "RunMe.bat" to register the .dll
    5. Edit Com Port and Vehicle Options in the "obdmpg.ini" to reflect your system and vehicle settings
    6. Then either use my provided skins or make your own, the plugin should be ready to operate!


    The first step is important. Without it the Mscomm control that I use to communicate with the ELM will not work. Also, if you happen to already have VB6 installed on your computer you do not need to do step 1 since the files get added during the vb6 installation.

  7. #117
    Constant Bitrate aperali's Avatar
    Join Date
    Aug 2007
    Location
    Rio de Janeiro, Brazil
    Posts
    170
    Done!

    Thanks. Im a bit lazy lately.

    mezz64, thanks for the great plugin and good work man!

    Got MAP, RPM VSS IAT and MAF answares!!
    How can I get the Absolute Throttle Position; Calculated Load Value; Intake Manifold Temperature; Coolant Temperature and; Distance Since Mill values from others sensors available in my car not present on the sample skin?

    Another question: is it possible to use, for example, the coolant temperature sensor to warn a loud sound if temperature goes over a predefined value??? Is it simple to do?
    I had a Discovery which burnt its heads cause I was travelling and did notice the water was boiling!!!

  8. #118
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    Quote Originally Posted by aperali View Post
    Done!

    Thanks. Im a bit lazy lately.

    mezz64, thanks for the great plugin and good work man!

    Got MAP, RPM VSS IAT and MAF answares!!
    How can I get the Absolute Throttle Position; Calculated Load Value; Intake Manifold Temperature; Coolant Temperature and; Distance Since Mill values from others sensors available in my car not present on the sample skin?

    Another question: is it possible to use, for example, the coolant temperature sensor to warn a loud sound if temperature goes over a predefined value??? Is it simple to do?
    I had a Discovery which burnt its heads cause I was travelling and did notice the water was boiling!!!
    I'm guessing you have ExtraOBD=False in the obdmpg.ini file. Set that to True and it will poll for all the PIDs listed on the sample skin.

    As for the events, I'm not sure if there is an existing RR function for something like that. If not I suppose I could try and figure out how to get something like that working. Making sure the primary functions are working right is my main focus though.

    I'm also thinking of splitting this off into two versions. One for MPG and one for reading PID values. Still haven't decided if that would be a good idea or not though.

  9. #119
    Newbie colosports's Avatar
    Join Date
    Oct 2008
    Location
    Tampa, FL
    Posts
    14
    I guess it's just me that am having problems. When I copied the COM files to windows/system32, I was prompted to overwrite one or 2 files (I forgot how many). I choose overwrite. Was anyone else prompted to overwrite?

  10. #120

Similar Threads

  1. Is there a OBDII BMV2 RR plugin?
    By Dave One in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 13
    Last Post: 10-02-2009, 11:25 AM
  2. OBDII / Elm MPG meter. Almost working but not quite!
    By stevieg in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 105
    Last Post: 08-19-2008, 03:24 AM
  3. pc reboot on sd startup
    By duanes7 in forum StreetDeck
    Replies: 3
    Last Post: 12-14-2007, 08:55 AM
  4. IRMAN plugin
    By knyarko in forum StreetDeck
    Replies: 3
    Last Post: 01-05-2007, 08:26 PM
  5. OBDII plugin (KL/KKL) ?
    By SyNTaXer in forum CF Plugins
    Replies: 6
    Last Post: 07-28-2006, 05:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •