Page 14 of 49 FirstFirst ... 456789101112131415161718192021222324 ... LastLast
Results 131 to 140 of 485
Like Tree2Likes

Thread: OBDMPG - MPG OBDII Plugin for RR 6-12-09

  1. #131
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    New release is posted! All future releases will now be available at: http://rr.johnmihalic.com so I can track the number of downloads.

    A couple things to note:

    • Skin Files are now in a separate zip, as well as the latest source
    • This version has L/100km for the metric switch instead of km/L
    • The com port now operates at 38400 Baud
    • Streamlined fuel efficiency calculations, arrays have been removed in favor of saving a count. I did still run into an overflow error during extended testing. I find it hard to believe that i'm maxing out a double but i've got a couple solutions lined up.


    To the throttle position (TP) problems mentioned earlier, I unfortunately cannot test that PID as my emulator does not provide it. Maybe someone else can chime in on that one, I might have the number wrong somewhere.

    I noticed someone wanted the km/L to remain so I will add that back into the next release. I just wanted to get this one pushed out while I have some time.

  2. #132
    Constant Bitrate tom_rosenback's Avatar
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    170
    I have just received my ELM327 OBD device from eBay. This is the cheap version. What drivers are you using? I seem to have some problems connecting, even with Scantool v1.13. Can you please give me some advice on what drivers/software to test the functionality of the device so that I can get it connected to this awesome plugin.

    EDIT:
    I think I solved the driver issue. Don´t know if it was necessary but I downloaded the newest stable drivers from FDTI and after that run Scantool with baudrate 38400 and then it worked. In other words I would love to have either this plugin with baudrate configurable or fixed to 38400.

    THX

    EDIT 2:
    Confirmed that cable works with Scantool, was able to read RPM etc (COM4, BAUDRATE 38400). But when trying this plugin I get Error: ELM not responding. I looked into the ELM class and saw that the baudrate is already 38400, this confuses me why doesn´t it work?

    This is what I have done:
    1. Unzipped the plugin onto my desktop (v.1.2)
    2. Copied COM-files to system32
    3. Downloaded debug application into same folder on my desktop
    4. Ran the RunMe.bat file
    5. Set the com port to 4 in ini file

    Is this a possible way to test the plugin? The reason why I use my desktop as debug place is that I use my laptop to debug this with and when I get it working I will move it to my carputers roadrunner folder.

  3. #133
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    Quote Originally Posted by tom_rosenback View Post
    EDIT 2:
    Confirmed that cable works with Scantool, was able to read RPM etc (COM4, BAUDRATE 38400). But when trying this plugin I get Error: ELM not responding. I looked into the ELM class and saw that the baudrate is already 38400, this confuses me why doesn´t it work?

    This is what I have done:
    1. Unzipped the plugin onto my desktop (v.1.2)
    2. Copied COM-files to system32
    3. Downloaded debug application into same folder on my desktop
    4. Ran the RunMe.bat file
    5. Set the com port to 4 in ini file

    Is this a possible way to test the plugin? The reason why I use my desktop as debug place is that I use my laptop to debug this with and when I get it working I will move it to my carputers roadrunner folder.
    First off the debug is separate from the plugin. All the debug needs to run is the com files in system32 and the obdmpg.ini in the same folder as the debug.exe. Also the debug.exe code hasn't been updated since a few releases ago so it uses 9600 to communicate.

    With all that being said, I copied the ini and the debug exe into a folder on the desktop of my test machine (WinXP SP3) and it worked fine.

    I think some of you might be having some problems with the registering of the mscomm32.ocx file that you place in system32. I've attached a batch file that will register that file in the c:\windows\system32 location. Give it a run and see if it fixes things. You'll need to remove the .txt extension before you run it.
    Attached Files Attached Files

  4. #134
    Constant Bitrate tom_rosenback's Avatar
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    170
    Ok, I have to try debug with Roadrunner then instead. Regarding my ELM device, it doesn´t seem to work on 9600...

  5. #135
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    Quote Originally Posted by tom_rosenback View Post
    Ok, I have to try debug with Roadrunner then instead. Regarding my ELM device, it doesn´t seem to work on 9600...
    That would explain why you are unable to get the debug application to work then. I've attached a version with 38400 baud to this post, give it a try.
    Attached Files Attached Files

  6. #136
    Constant Bitrate tom_rosenback's Avatar
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    170
    Thanx man! Will have it a go after work today.

    EDIT
    I have now tested the debug application with 38400 as baudrate. IT CONNECTED However it seemed like the information flow stopped pretty fast after connecting, can this be because that the debug app is not really up to date? Will make myself a skin to see if it works better then.

    THX!

  7. #137
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,700
    Blog Entries
    1
    Firstly:

    Mezz64: FANTASTIC work on this plugin! I know the time it takes to write, execute, squash bugs, and add the endless sugested features when something is released. Thanks for all your hard work on this, it is an excellent addition to Road Runner. So many people wanted a way to integrate OBD info in RR fo so long, and you have provided the sollution!

    Ok, like many others in this thread, I purchased a ELM327 off Ebay strictly to take advantage of this plugin It is communicating with no problems that I can see so far. I will have to do some road testing for the odometer, MPG and such for accuracy, and report back if there is anything I think could be useful to you.

    Quote Originally Posted by mezz64 View Post
    What value do you have set for "ADJ" in the ini file? It should be 1 to start out with and will be adjusted as you go when you calibrate with fill-up data.
    Can you elaborate a little more on this? I have no clue how to calibrate this. if you determine you were off by say 30 miles in a tank of gas, do you enter 30 as an adjustment ect? The "1" means nothing to me right now, as I do not know a scale, or what it is linked to



    Quote Originally Posted by aperali View Post
    Perhapsit could send a flash command to RR paly something loud. Or it could be part of the flash file when the values achieves some point then the pictures changes to a 'flame' and starts to play something. Just thinking..
    BlueZX3 wrote a plugin that will monitor a label, and if it goes above a certain value, can execute a command, here is a snipit from his plugin thread:

    Will watch any label and when above/below set limit executes a command. No limit to how many watches
    Lets say your coolant temperature went above 280 degrees, you could easily get a warning of this happens by placing this line in your RR.ini file:

    RRWW_Watch1=obd_ect;280;>;Menu;Temp_Warning.skin

    The above example would pop open a Temp_Warning.skin. You can fire any command that RR can understand, and make it pop open a menu, pause the audio and play a wave file or speak a warning ect ect... Heck hook up a fusion brain, and have it turn the heat on high (known way to drop the coolant temp by a few degrees in an emergency by transfering some of the heat from the coolant as heated air into the cabin)
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  8. #138
    Constant Bitrate aperali's Avatar
    Join Date
    Aug 2007
    Location
    Rio de Janeiro, Brazil
    Posts
    170
    John,

    TYVM for the helpfull info. Then, it is a simple mix of plugins and very easy RR's commands. I'll start trying to make some skins next week.

    Mezz,

    Ive not tryed the new release yet (Im on travelling - eating some sweet foods on my mother's house!). But, Ive noticed on the road that all my availables PIDs were being read fine, but the FEs labels wasnt being calculated, they were showing only "0". I tryed to reset the obdmpg; and filled the tank and adjusted the fuel. What could be causing this behavior?

  9. #139
    Mod - all of it.
    Join Date
    Jul 2007
    Location
    Buena Park, So Cali
    Posts
    524
    Will this only work with the ELM327 Obd connectors. I am thinking of buying the DigiMoto system which uses the mOByDic 2600 chip. This is a great package with connections that seem neat and tidy for a car install. It would be great if this plug in supported this chip as well. It seems in my investigation that it is a faster operating system.

    Thanks.

    "Digimoto 5.0 DigiScan USB Package
    Regular Price: $159.95
    On Sale For: $104.95
    Digimoto 5.0 DigiScan USB Package
    The Digimoto 5.0 DigiScan USB package includes the software and the interface you will need for a fully supported OBD II diagnostic solution. This package includes a DigiScan 3200 USB interface (contains all protocols in a single unit, ISO15765-4 (CAN), ISO14230-4 (KWP2000), ISO9141-2, J1850 VPW, J1850 PWM with enclosure), the Digimoto 5.0 software and an integrated USB 2.0 cable. License information will be printed on the back of the software envelope.

    The new DigiScan 3200 interface is based on the mOByDic 2600 chip. The interface now has an imbedded OBDII cable built within the interface itself. Usually ships next business day."
    Attached Images Attached Images  

  10. #140
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,700
    Blog Entries
    1
    Honestly that seems a bit high $$$, and I have no clue on what ones work with this plugin ect.

    This is the one I just purchased from another seller. I also paid $39.95 and the shipping was free. Came with the drivers disk, as well as a few ODBII programs for scanning codes, testing ect.

    This is the ELM327 and what this plugin was actually written for, and for $40 you sure can't go wrong!
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

Similar Threads

  1. Is there a OBDII BMV2 RR plugin?
    By Dave One in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 13
    Last Post: 10-02-2009, 11:25 AM
  2. OBDII / Elm MPG meter. Almost working but not quite!
    By stevieg in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 105
    Last Post: 08-19-2008, 03:24 AM
  3. pc reboot on sd startup
    By duanes7 in forum StreetDeck
    Replies: 3
    Last Post: 12-14-2007, 08:55 AM
  4. IRMAN plugin
    By knyarko in forum StreetDeck
    Replies: 3
    Last Post: 01-05-2007, 08:26 PM
  5. OBDII plugin (KL/KKL) ?
    By SyNTaXer in forum CF Plugins
    Replies: 6
    Last Post: 07-28-2006, 05:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •