Page 18 of 49 FirstFirst ... 8910111213141516171819202122232425262728 ... LastLast
Results 171 to 180 of 485
Like Tree2Likes

Thread: OBDMPG - MPG OBDII Plugin for RR 6-12-09

  1. #171
    Confusion Master
    Auto Apps:loading...
    Enforcer's Avatar
    Join Date
    Sep 2003
    Location
    If you go down to the woods today, You're sure of
    Posts
    14,629
    Quote Originally Posted by mezz64 View Post
    I need some help from those which are a little more familiar with the RR plugin architecture. I'm trying to do as much as possible to increase speed, in doing this I started to realize that no matter what I do a RR label will only update once a second. I cross checked this by running the code in a separate exe and I was able to see the count increase every 250ms as it should where as in RR it jumps in 4's, or 1000ms at a time.

    So basically is this something I'm doing wrong or just a downside to the RR plugin interface? It's be great if someone familiar with the code could chime in, Guino maybe?

    You can use a combination of comsend and setlabel to update it more often, as I did with the stopwatch plugin, but the more often you update the label the chance you are going to slow RR down is greater.


    eg

    COMSend "RoadRunner", "setlabel;<labelname>;<labelvalue>"

    See the RR Plugin example for the comsend bits.

  2. #172
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,723
    Blog Entries
    1
    There is also a new feature in RR that BlueZX3 added (in the 12/08 release) that allows you to change how often RR updates the screen. From the history.txt:

    + Screenrefresh rate control, 10 steps, (.1s to 1 second) 10 = 1 second and is default

    This HAS to be one of the best things to come along in a LONNnnnnnng time! On my desktop PC (fast PC) I have this in the RR.ini:

    Screenrefresh=1

    This updates the screen every one 10th of a second. Labels are updated in real time, and the song position slider just slides along, instead of just "jumping along" only once every second.

    RR is much MUCH more responsive, its like turbo boost! Button presses and screen changes are INSTANT. (Once the screen is loaded into memory using Preload or going to the same screen for a second time).

    CAUTION: Setting this to a fast refersh on a slow computer, can significantly increase the CPU load. Do some trial and error tests starting at say Screenrefresh=7 and work your way down from there.
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  3. #173
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    Thank you, thank you, thank you! That setting just made a night and day difference in the update speed!

    I was playing with the COMsend like Enforcer suggested last night, and while it worked it didn't work well. But setting screenrefresh=1 in the rr.ini definitely did the trick. I also noticed little to no jump in CPU usage on my testing laptop (1.6Ghz Pentium M, 1gb Ram, XP SP3).

    Now I can run the calculations timer at 100ms and pull the obd variables into a circular buffer. This should make calculations happen faster and more accurately than the current method.

    I'm thinking a new release sometime this weekend most likely.

  4. #174
    Newbie
    Join Date
    Dec 2008
    Posts
    4
    I have one problem. Miles Traveled Overall and Miles Traveled Trip values are 2.5 times more. I drove 16miles and it shows 40miles. How can I adjust it?

  5. #175
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    Quote Originally Posted by sunny868 View Post
    I have one problem. Miles Traveled Overall and Miles Traveled Trip values are 2.5 times more. I drove 16miles and it shows 40miles. How can I adjust it?
    I had an error in the conversion factor from km to miles, I discovered this yesterday. A new release will be out soon with this fixed as well as interpolation on the mpg values. Just need to get some testing done before I release it.

  6. #176
    Constant Bitrate aperali's Avatar
    Join Date
    Aug 2007
    Location
    Rio de Janeiro, Brazil
    Posts
    170
    Quote Originally Posted by aperali View Post
    Yes, Im using metric.
    Today I had to disassembly all my carpc to do some finishing. Tomorrow, I hope get everything in place and will try to install obdmpg again to see what happens. Also Ill install the latest version of RR.
    Will try to unregister the old dll and register the new again.
    well, i finished my rebuild today and tryed again. below you can see obdmpg running ok when metric=false.

    and the respective ini file.

    when I change it to metric=true then, it shows the division by 0 error.

    other question is (in the obdmpg screen) why the instant FE is not being calculated?
    Attached Images Attached Images  
    Attached Files Attached Files

  7. #177
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    Instant FE is not being calculated because your speed is zero. Without movement it's impossible to calculate miles per gallon.

    I've made a number of changes in the new release which I hope to have out before the end of the weekend. I will take extra care in checking the metric functions to ensure there is no problem.

    The error is odd though since most of the calculations are actually performed in metric since that is the default units for most of the pid's and then converted to english units.

  8. #178
    Constant Bitrate aperali's Avatar
    Join Date
    Aug 2007
    Location
    Rio de Janeiro, Brazil
    Posts
    170
    Quote Originally Posted by mezz64 View Post
    Instant FE is not being calculated because your speed is zero. Without movement it's impossible to calculate miles per gallon.

    I've made a number of changes in the new release which I hope to have out before the end of the weekend. I will take extra care in checking the metric functions to ensure there is no problem.

    The error is odd though since most of the calculations are actually performed in metric since that is the default units for most of the pid's and then converted to english units.
    Sorry, i thought it was calculating a kind of equivalent mpg while car is stopped since it is consuming fuel. But, you re right.

  9. #179
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,169
    Blog Entries
    53
    if your not moving of course ur getting 0 miles per gallon
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  10. #180
    The Last Good Gremlin GizmoQ's Avatar
    Join Date
    Nov 2004
    Location
    St Louis
    Posts
    2,348
    Quote Originally Posted by Sonicxtacy02 View Post
    if your not moving of course ur getting 0 miles per gallon
    Yeah, but if I'm sitting still with the motor OFF, the avg FE keeps decreasing until it crashes with a divide by zero.

    And I still need to figure out how to reset the ELM327 from the PC. For some reason the ELM never shuts off even after the motor/key is off or if the PC is shutdown. It seems to be getting power from both the OBDII connector and from the PC. So it never sees a condition/reason to reset. Either way, I currently have to unplug the ELM interface, wait the ECU timeout, then replug in.
    HARDWARE: Fujitsu Stylistic ST5111w/WiFi and dock, internal Hitachi 500G HD, external 1TB HD, Sierra Wireless Aircard 550, DVD-RW, BoomzBox HD radio, XM Commander, Delorme GPS, Saitek X-52 Pro joystick, BluSoleil Bluetooth, TPMS, FB, Elm327

Similar Threads

  1. Is there a OBDII BMV2 RR plugin?
    By Dave One in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 13
    Last Post: 10-02-2009, 12:25 PM
  2. OBDII / Elm MPG meter. Almost working but not quite!
    By stevieg in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 105
    Last Post: 08-19-2008, 04:24 AM
  3. pc reboot on sd startup
    By duanes7 in forum StreetDeck
    Replies: 3
    Last Post: 12-14-2007, 09:55 AM
  4. IRMAN plugin
    By knyarko in forum StreetDeck
    Replies: 3
    Last Post: 01-05-2007, 09:26 PM
  5. OBDII plugin (KL/KKL) ?
    By SyNTaXer in forum CF Plugins
    Replies: 6
    Last Post: 07-28-2006, 06:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •