Page 23 of 49 FirstFirst ... 131415161718192021222324252627282930313233 ... LastLast
Results 221 to 230 of 485
Like Tree2Likes

Thread: OBDMPG - MPG OBDII Plugin for RR 6-12-09

  1. #221
    The Last Good Gremlin GizmoQ's Avatar
    Join Date
    Nov 2004
    Location
    St Louis
    Posts
    2,347
    Quote Originally Posted by xpluis View Post
    tomorrow i reinstall complety my roadrunner and try again.......... any sugestions?
    o.k. Let's start from the beginning. What OBD module do you have? Have you tried the latest RR binary?

    Try this, disconnect the USB from the PC and the OBD module from the car, With the car running - Cold boot the latest RR binary, plug in the USB and wait for it to be recognized, then plug in the OBD and wait 15 seconds, now switch to the OBDMPG screen and see if it works. If this does work you may have a device/interrupt conflict, i.e., two devices trying to use the same interrupt.
    HARDWARE: Fujitsu Stylistic ST5111w/WiFi and dock, internal Hitachi 500G HD, external 1TB HD, Sierra Wireless Aircard 550, DVD-RW, BoomzBox HD radio, XM Commander, Delorme GPS, Saitek X-52 Pro joystick, BluSoleil Bluetooth, TPMS, FB, Elm327

  2. #222
    Constant Bitrate xpluis's Avatar
    Join Date
    Sep 2006
    Location
    Mexico City
    Posts
    138
    What is the file that is the link betwen the odb and roadrunner? remember that the debub file of obdmpg its working, but not link with roadrunner.

    If i know what is the dll, or the file that link obdmpg with RR i can put more atention in this file.

  3. #223
    Constant Bitrate xpluis's Avatar
    Join Date
    Sep 2006
    Location
    Mexico City
    Posts
    138
    obdmpg could be work with Road Runner Plugin Manager ??

  4. #224
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,161
    Blog Entries
    51
    Quote Originally Posted by xpluis View Post
    obdmpg could be work with Road Runner Plugin Manager ??
    at the rate he's putting out version updates i'd say wait til there's something more solid else he'd be wasting time sending me plugin data on an almost daily basis.

    i still havent tried the 9600 rate files .. i'll do that today and post results.

    EDIT.. that solved it.. 1.3.1 works fine now
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  5. #225
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,161
    Blog Entries
    51
    Question? do you have any functions handling hibernation/resume? now that i finally got the 9600 .dll working i'm having an intermittent issue with RR crashing at hibernation. It resumes back to the standard windows box saying the program has been closed yada yada. I wasnt having this problem with OBDMPG disabled.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  6. #226
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    Quote Originally Posted by Sonicxtacy02 View Post
    Question? do you have any functions handling hibernation/resume? now that i finally got the 9600 .dll working i'm having an intermittent issue with RR crashing at hibernation. It resumes back to the standard windows box saying the program has been closed yada yada. I wasnt having this problem with OBDMPG disabled.
    I do have hibernation/resume routines to save the current data to the ini and close and reopen the connection to the elm. These have not changed for some time now though.

    To be more specific the preparation for hibernation routine write the values to the ini via an ini_write function, closes the elm connection, and sets the boolean connected variable to false.

    Then on resume from hibernation the form is unloaded and then loaded again to reinitialize the connection. The unloading and loading of the form might be causing your problem but it has been this way since day one as it was the only way I could get the plugin to start back up correctly after hibernation.

  7. #227
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    Quote Originally Posted by xpluis View Post
    What is the file that is the link betwen the odb and roadrunner? remember that the debub file of obdmpg its working, but not link with roadrunner.

    If i know what is the dll, or the file that link obdmpg with RR i can put more atention in this file.
    The debug exe is just an old build of the dll converted into an executable. The dll is what is communicating with RR and the elm.

    I'm holding off on any future fixes releases until I can get my latest build working on my carputer. It works fine with an emulator but I'm starting to think that is not good enough. With the holidays and everything else going on I've been pretty busy and haven't had much time to tinker.

  8. #228
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,161
    Blog Entries
    51
    Quote Originally Posted by mezz64 View Post
    I do have hibernation/resume routines to save the current data to the ini and close and reopen the connection to the elm. These have not changed for some time now though.

    To be more specific the preparation for hibernation routine write the values to the ini via an ini_write function, closes the elm connection, and sets the boolean connected variable to false.

    Then on resume from hibernation the form is unloaded and then loaded again to reinitialize the connection. The unloading and loading of the form might be causing your problem but it has been this way since day one as it was the only way I could get the plugin to start back up correctly after hibernation.
    i'll do some more testing in the next coming days.. but its gotta be during hibernation that the problem happens because it resumes with the windows error reporting message box.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  9. #229
    Newbie
    Join Date
    Mar 2008
    Posts
    26

    need instructions

    I use Digital fx 4.0 can somebody do a step by Step on how to implement this into it that would be very helpful to me thank you for any help anybody will give me

  10. #230
    Newbie
    Join Date
    Dec 2008
    Posts
    24
    Quote Originally Posted by aperali View Post
    well, i finished my rebuild today and tryed again. below you can see obdmpg running ok when metric=false.
    when I change it to metric=true then, it shows the division by 0 error.
    I have the same issue -- meeting 'division by zero' error while set metric=true. Is there any way to solve this?

Similar Threads

  1. Is there a OBDII BMV2 RR plugin?
    By Dave One in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 13
    Last Post: 10-02-2009, 11:25 AM
  2. OBDII / Elm MPG meter. Almost working but not quite!
    By stevieg in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 105
    Last Post: 08-19-2008, 03:24 AM
  3. pc reboot on sd startup
    By duanes7 in forum StreetDeck
    Replies: 3
    Last Post: 12-14-2007, 08:55 AM
  4. IRMAN plugin
    By knyarko in forum StreetDeck
    Replies: 3
    Last Post: 01-05-2007, 08:26 PM
  5. OBDII plugin (KL/KKL) ?
    By SyNTaXer in forum CF Plugins
    Replies: 6
    Last Post: 07-28-2006, 05:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •