Page 7 of 49 FirstFirst 1234567891011121314151617 ... LastLast
Results 61 to 70 of 485
Like Tree2Likes

Thread: OBDMPG - MPG OBDII Plugin for RR 6-12-09

  1. #61
    Constant Bitrate
    Join Date
    Nov 2005
    Location
    Missouri
    Posts
    200
    Quote Originally Posted by mezz64 View Post
    It shouldn't be doing this. What is your start/shutdown behavior? I have it working with hibernate on my carpc.
    The PC is not shutting down at all when this happens.
    With the PC on and RR running shut down the vehicle...My PC stays on for 15 minutes...The connection is dropped. Restart the car, connection is not reestablished.
    I did not check what happens if the PC goes into hibernate and then restarts, this might restart the connection, I'll do some more testing

    This afternoon I moved from release .7 to .8. I now only get values for speed, rps, and coolant temp, everything else is blank including the mpg calculated fields (I am displaying most of the values on my skin).

    Also 5 decimal places is too much, it makes it too hard to read at a glance, 1 decimal is enough (and none would be fine for speed)

    Coolant temp seems to be displaying in degrees C even though Metric=False.

    Thanks...Paul

  2. #62
    Constant Bitrate
    Join Date
    Nov 2005
    Location
    Missouri
    Posts
    200
    Re the connection issue, If I go out of the main menu and then back in it restarts the connection, so that is fine.

    I reinstalled release .7 and it looks good, however I did notice the intake air temp is being reported at close to 300, and that is not right.
    ...Paul

  3. #63
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    The connection issue with the vehicle being turned off and not the PC is a known one, i'm working on a way to automatically reset the connection, just haven't gotten it to work yet.

    I'll look over the changes in 0.8 to see whats messing up the other PID values and check with the coolant and intake air temp values.

  4. #64
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    Just looked over the code, Intake Air Temp is actually in Kelvin at the moment, hence the high numbers. I'll make sure it operates under the metric switch so it can be displayed as C or F.

    EDIT:
    The more I mess with the code the more I realize the additions have made it kind of clunky in certain areas. I'm going to rewrite most of the MPG stuff as functions more so than they currently are to make things more modular. It should help me track down problems easier as well. Look for a new release sometime tonight, probably in the early AM.

  5. #65
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    A plugin update is not ready yet, however the debug exe now reports data for all the RR variables. If those who are using the plugin can test to make sure the data being outputted is correct it would be greatly appreciated.

    I've just begun using an ELM emulator to do some more testing before I release new builds to cut down on confusion, but I want to try and gain some outside feedback to make sure the calculations are working correctly.



    Debug Link: http://www.johnmihalic.com/obdmpg/obdmpg.exe

  6. #66
    Constant Bitrate
    Join Date
    Nov 2005
    Location
    Missouri
    Posts
    200
    .exe downloaded and installed, I'll run the test tomorrow and let you know what I find.
    ...Paul

  7. #67
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    Quote Originally Posted by pshadwick View Post
    .exe downloaded and installed, I'll run the test tomorrow and let you know what I find.
    ...Paul
    Thanks, my main concern is MAF values at the moment. I tweaked the original code to work well without a MAF sensor and I think the formulas for a MAF sensor need some adjustment to get realistic values.

  8. #68
    Constant Bitrate
    Join Date
    Nov 2005
    Location
    Missouri
    Posts
    200
    OK here are some numbers from a short trip:

    The first lot were taken travelling at a steady speed.

    Car MPG reading Instant MPG from OBDMPG.exe MAF
    9 790 31
    18 1966 33
    27 2800 13.49


    The next readings were taken parked with the engine running after a short trip:

    OBDMPG Digimoto
    CELV blank
    ECT blank
    STFT1 blank 0
    LTFT1 blank -5
    STFT2 blank 3
    LTFT2 blank -5
    FP blank
    MAP 34 (is this Manifold Intake Pressure?) 4.65
    RPM 652 648
    VSS 0 0
    IAT 57.2 59
    MAF 6.53 6
    TP blank
    FRP blank
    RTP blank



    Trip MPG 2143.0
    Ovr MPG 2108
    Miles travelled 2.10377
    miles remaining 31205.0
    miles traveled trip 2.10377
    Gal user ovr 1.154
    Gal used trip 1.05


    It appears my vehicle does not return some of these PID's

    There is about 60 seconds between the vales for OBDMPG.exe and my OBD software (Digimoto) as I have to shut one down to start the other.

    Please let me know what other test you would like me to run.

    ...Paul

  9. #69
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    Thanks for the value comparisons. It looks like i've got some orders of magnitude wrong on the MAF calculations. I'll try and get that sorted out.

    Am I correct in reading the data in that digimoto displayed you're fuel trims and OBDMPG did not? Thats an odd one as those PIDs are displayed pretty much directly with only the conversion factors applied.

  10. #70
    Constant Bitrate
    Join Date
    Nov 2005
    Location
    Missouri
    Posts
    200
    Quote Originally Posted by mezz64 View Post
    Thanks for the value comparisons. It looks like i've got some orders of magnitude wrong on the MAF calculations. I'll try and get that sorted out.

    Am I correct in reading the data in that digimoto displayed you're fuel trims and OBDMPG did not? Thats an odd one as those PIDs are displayed pretty much directly with only the conversion factors applied.
    That is correct I get the fuel trims in Digimoto but no values in OBDMPG. I'm guessing that the others with no value are not supported by my vehicle.
    ...Paul

Similar Threads

  1. Is there a OBDII BMV2 RR plugin?
    By Dave One in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 13
    Last Post: 10-02-2009, 11:25 AM
  2. OBDII / Elm MPG meter. Almost working but not quite!
    By stevieg in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 105
    Last Post: 08-19-2008, 03:24 AM
  3. pc reboot on sd startup
    By duanes7 in forum StreetDeck
    Replies: 3
    Last Post: 12-14-2007, 08:55 AM
  4. IRMAN plugin
    By knyarko in forum StreetDeck
    Replies: 3
    Last Post: 01-05-2007, 08:26 PM
  5. OBDII plugin (KL/KKL) ?
    By SyNTaXer in forum CF Plugins
    Replies: 6
    Last Post: 07-28-2006, 05:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •