Page 2 of 11 FirstFirst 1234567891011 LastLast
Results 11 to 20 of 105

Thread: have RR??? Want Traffic cams??? Check here

  1. #11
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,146
    Blog Entries
    51
    ok i need someone to test this out for me. Its working on my end. Download the .rar. Put the livetraffic folder in C:\program files\road runner\. Open the .ini in the folder and change the skinpath to whatever skin your using (change mc2.5 to the name of your skin folder). After that run the exe. It SHOULD put cam images in your skin folder. Once i've confirmed this works, i'll come up with a solution to allow users to select there own cameras.
    Attached Files Attached Files
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  2. #12
    FLAC W3bMa5t3r's Avatar
    Join Date
    Apr 2006
    Location
    Washington, DC
    Posts
    1,268
    Quote Originally Posted by Sonicxtacy02 View Post
    ok i need someone to test this out for me. Its working on my end. Download the .rar. Put the livetraffic folder in C:\program files\road runner\. Open the .ini in the folder and change the skinpath to whatever skin your using (change mc2.5 to the name of your skin folder). After that run the exe. It SHOULD put cam images in your skin folder. Once i've confirmed this works, i'll come up with a solution to allow users to select there own cameras.
    I'll test for ya. I'm off for the next 3 days too (not that that has any bearing this... lol)

  3. #13
    FLAC W3bMa5t3r's Avatar
    Join Date
    Apr 2006
    Location
    Washington, DC
    Posts
    1,268
    ok, well I had to rename the folder from livetrafficTEST to livetraffic, so the the exe would run, but it only ran for a second, creating only a trafficland.txt file in my livetraffic folder. No pics in my skin folder. Did I miss something?

    edit... the text file is in XML format if that helps...

  4. #14
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,146
    Blog Entries
    51
    there's a folder inside of the livetrafficTest folder called livetraffic. That folder goes in your rr folder. Then go into that folder and open the ini. should read like this:

    [livetraffic]
    filepath=C:\Program Files\Road Runner\livetraffic
    skinpath=C:\Program Files\Road Runner\skins\MC2.5

    if filepath is something different, change it as it says above. Then change skin path to name of your skin folder. Do not put the "\" after the name.

    The text file should just be a text file, not an .xml. Please confirm its .xml, if it is there's a problem
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  5. #15
    FLAC W3bMa5t3r's Avatar
    Join Date
    Apr 2006
    Location
    Washington, DC
    Posts
    1,268
    Quote Originally Posted by Sonicxtacy02 View Post
    there's a folder inside of the livetrafficTest folder called livetraffic. That folder goes in your rr folder. Then go into that folder and open the ini. should read like this:

    [livetraffic]
    filepath=C:\Program Files\Road Runner\livetraffic
    skinpath=C:\Program Files\Road Runner\skins\MC2.5

    if filepath is something different, change it as it says above. Then change skin path to name of your skin folder. Do not put the "\" after the name.

    The text file should just be a text file, not an .xml. Please confirm its .xml, if it is there's a problem
    got the ini.. that's edited as should.
    Code:
    [livetraffic]
    filepath=C:\Program Files\Road Runner\livetraffic
    skinpath=C:\Program Files\Road Runner\skins\CobraSkin_07
    the text file is trafficland.txt, but if you open the file, the file structure is xml. Attaching first few lines:
    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <!-- City: DC - Baltimore-Washington Area (430 cameras) -->
    <!--  Schema: v100.0.  Report data errors to [email protected] . -->
    <Region>
            <RegionID>20000</RegionID>
            <Subregions>
    		<Subregion>
    			<SubregionName>DC - Washington (City)</SubregionName>
    			<Cameras>
    				<Camera>
    					<CameraID>200111</CameraID>
    					<CameraName>12th St  NW and Constitution Ave  NW</CameraName>
    					<CameraURL>http://pub.camera.trafficland.com/trafficimage.php?system=pub&amp;webid=200111&amp;pubtoken=5fe8245d2447dca9690ecf6a5f467b29</CameraURL>
    				</Camera>
    And like I said, the program only runs for a second, just long enough to create the text/xml file, then it closes without warning.

  6. #16
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,146
    Blog Entries
    51
    ok the text file is as it should be.. i just converted the xml downloaded to a .txt so autoit can read it. Now why its not pulling the images is beyond me. Try this .exe (just copy it over your existing one). And make sure you have the latest autoit (they released a new one over the weekend).
    Attached Files Attached Files
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  7. #17
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,146
    Blog Entries
    51
    while ur at it tell me what size your .txt file is. Should be 116kb
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  8. #18
    FLAC W3bMa5t3r's Avatar
    Join Date
    Apr 2006
    Location
    Washington, DC
    Posts
    1,268
    Quote Originally Posted by Sonicxtacy02 View Post
    ok the text file is as it should be.. i just converted the xml downloaded to a .txt so autoit can read it. Now why its not pulling the images is beyond me. Try this .exe (just copy it over your existing one). And make sure you have the latest autoit (they released a new one over the weekend).
    Sweet a new version of AutoIT and an update to SCITE. lol anyways... sorry dude, same result. runs for a sec, creates the txt file, then closes out.

  9. #19
    FLAC W3bMa5t3r's Avatar
    Join Date
    Apr 2006
    Location
    Washington, DC
    Posts
    1,268
    Quote Originally Posted by Sonicxtacy02 View Post
    while ur at it tell me what size your .txt file is. Should be 116kb
    yep, 116kb

  10. #20
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,146
    Blog Entries
    51
    well damn! Ok check to make sure you only have one livetraffic folder. Make sure its C:\program files\road runner\livetraffic and not C:\program files\road runner\livetraffic\livetraffic. If this is the case then please try this customized version of the .exe. Its my first version without the variables for file and skin path. It will put the .txt file in C:\program files\road runner\livetraffic\livetraffic and read it from there. Then it'll pull the images and place them in your CobraSkin_07 folder. Both versions are working on all of my computers.
    Attached Files Attached Files
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

Similar Threads

  1. RR "-4.3" video freeze!
    By RaVEWHQ in forum RR Bug Tracker
    Replies: 3
    Last Post: 04-24-2006, 11:26 PM
  2. General question about the RR program logic
    By DaveB in forum Road Runner
    Replies: 1
    Last Post: 03-19-2006, 11:26 PM
  3. RR vs Frodo
    By tbird2340 in forum Road Runner
    Replies: 58
    Last Post: 03-07-2006, 05:25 AM
  4. Traffic info for Maryland/Wash. DC for RR
    By Civic03 in forum Road Runner
    Replies: 22
    Last Post: 02-03-2006, 11:48 AM
  5. Dialup in RR without Phoco?
    By kbreeden in forum Road Runner
    Replies: 6
    Last Post: 12-12-2005, 08:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •