Page 2 of 9 FirstFirst 123456789 LastLast
Results 11 to 20 of 84

Thread: SerialSwitch Version 5

  1. #11
    Constant Bitrate mpfjr's Avatar
    Join Date
    Jun 2004
    Location
    Corona, CA
    Posts
    215
    No idea what I did wrong but the first time I installed it and it didn't make a directory in my road runner directory. Then I looked and realized that by default my roadrunner installed to RoadRunner (no space) and your app installed to Road Runner. So I tried to uninstall it. There wasn't an uninstall but when I hit exit/cancel the install it said "removing install files". Then I re-installed it using the custom directory path and pointed it to RoadRunner and it created a folder in the RoadRunner folder but it only had a .log file. So I copied/pasted all the files from the old directory to the new one. Whew.

    Ok, so running the app works. I added the lines to the execTBL.ini file as per the readme.txt but when I load up roadrunner nothing happens. Nothing meaning it doesn't seem to load the program, doesn't turn on the serial. Only if I run the app manually. I am using DigitalFX3.0 skin if that matters.

    What I'd like to do, since I might want to use sound outside of RR is just do what others asked and drop the app into startup. Or make a shortcut and put the shortcut into startup folder.

    I was using amp control but as previously stated it only uses com1. My serial is on com2.

    Very cool program you have here. I very much like it.

  2. #12
    Newbie
    Join Date
    Sep 2007
    Location
    Sussex, England
    Posts
    23
    Jesus this is good, Jebus! - Looks like a cool little app.
    I'm currently still bulding my carPC, but the PSU I'm using has a line for the amp remote, so I have no need for that function.

    What I finally intend to do, is to have my car keyfob boot up my PC, set the car ignition to ON and then have a USB fingerprint reader start my engine and launch RR/windows in true 007 style.

    What I would need to use this app for, would be to trigger a relay via COM2 (onboard) for the third point of ignition (turning your key to start the engine) and ideally to monitor the ECU tachometer signal to determine wether the car is started or not, to avoid constantly turning over the engine once already running.

    Does the input signal measure the voltage ? or how does this work ?
    Does version 2 include the labels update that Guino suggested ?
    Do you think that any of this will be possible based on software restrictions ?

    Many thanks, and good work,
    Phil

  3. #13
    Variable Bitrate Jebus's Avatar
    Join Date
    Dec 2007
    Location
    Washington, USA
    Posts
    312
    Does the input signal measure the voltage ? or how does this work ?
    The input signal goes high or positive voltage to generate the event in MSCOMM control. Keep in mind you can't apply just any old voltage to the pins. You should use the serial ports own voltage to drive the pin high. Like one of the two output pins.
    Does version 2 include the labels update that Guino suggested ?
    Version 2 adds the input pins and custom labels.
    Version 3 adds custom indicators and a configurable timer control to update SerialSwitch status into RR.
    Do you think that any of this will be possible based on software restrictions ?
    No, I would get a remote start kit and work it into my setup from that angle.
    ...JJG

  4. #14
    Newbie
    Join Date
    Sep 2007
    Location
    Sussex, England
    Posts
    23
    Quote Originally Posted by Jebus View Post
    The input signal goes high or positive voltage to generate the event in MSCOMM control. Keep in mind you can't apply just any old voltage to the pins. You should use the serial ports own voltage to drive the pin high. Like one of the two output pins.

    Version 2 adds the input pins and custom labels.
    Version 3 adds custom indicators and a configurable timer control to update SerialSwitch status into RR.

    No, I would get a remote start kit and work it into my setup from that angle.
    ...JJG
    I think I will likely get a fusion brain and try and work it through that, it's just space is a constraint in my setup and I also want to know it's possible before I take the plunge, so a little more researching required.

    Thanks very much for your quick response, and keep up the good work!
    Phil

  5. #15
    Constant Bitrate mpfjr's Avatar
    Join Date
    Jun 2004
    Location
    Corona, CA
    Posts
    215
    On install when I select for it to install to c:\program files\RoadRunner it still installs to \Road Runner (with the space). My RoadRunner has no space.

    Also no matter what I try I can not get roadrunner to load it up. Here is my ExecTBL.ini

    "QUIT","SendMsg;RRCDRip;showplugin||bye"
    "BYE","QUIT"

    /, Set Bellow the Path to the CDRip plugin (if used)
    "CDRIP","PLUGIN;RRCDRip;D:\VBStuff\Road Runner\CDRip\CDRip.exe"

    /, You can add commands to execute before suspend
    /, and after resume, using the codes bellow:

    "ONSUSPEND",""
    "ONRESUME",""
    "ONFILECLICK",""
    "ONDIRCLICK",""
    "ONPLCLICK",""
    "ONDLCLICK",""
    "ONPBCLICK",""


    /,ADDED BY CONFIG
    "IGPAUSE","!PRESET;IG3;WINAMP||SETVOL;WINAMP;1 00"
    "IGRESUME","PRESET;IG3;WINAMP"

    "ExtraPrograms","RELAYS"
    "RELAYS","RUN;$RRPATH$SerialSwitch\SerialSwitch.exe||SHOW WINDOW;SerialSwitch;FALSE"


    I just can't get it to load up. I need it to load with RR instead of startup folder because I want it to be hidden.

    I have tried to uninstall and re-install a few times but I think it still has something in the registry that makes it see it in a different folder or .. I don't know.

    Can someone help?

    Update: There is no space in the .exe as it is displayed in the post. I don't know why it puts that there.

    Update2: I did some testing and still can not get it to load up. I changed the line to

    "ExtraPrograms","RELAYS"
    "RELAYS","RUN;C:\Program Files\RoadRunner\SerialSwitch\SerialSwitch.exe||SH OWWINDOW;SerialSwitch;TRUE"
    to see if it would load it and maybe there was an error but since the window was hidden I didn't know.

    Reloaded RR and still nothing. So I went into the serialswitch folder and manually ran it. It loaded no problem.

  6. #16
    Variable Bitrate Jebus's Avatar
    Join Date
    Dec 2007
    Location
    Washington, USA
    Posts
    312
    Well from what I can infer from your post, You already have a line at the top of your ExecTBL.ini that is similar to this:

    "ExtraPrograms","CDLaunch||NetCheck||Counter"

    and you have added the same with:

    "ExtraPrograms","RELAYS"

    You need to add the command "RELAYS" to the top like the rest.

    ...JJG

    SideNote: I have a newer version almost ready to go that sits in the system tray. It does not require RR to hide it. I will post it this weekend.
    ...JJG

  7. #17
    Constant Bitrate mpfjr's Avatar
    Join Date
    Jun 2004
    Location
    Corona, CA
    Posts
    215
    Quote Originally Posted by Jebus View Post
    Well from what I can infer from your post, You already have a line at the top of your ExecTBL.ini that is similar to this:

    "ExtraPrograms","CDLaunch||NetCheck||Counter"

    and you have added the same with:

    "ExtraPrograms","RELAYS"

    You need to add the command "RELAYS" to the top like the rest.

    ...JJG

    SideNote: I have a newer version almost ready to go that sits in the system tray. It does not require RR to hide it. I will post it this weekend.
    ...JJG
    Oooo I can't wait. That would work perfectly!

  8. #18
    FLAC Griff1's Avatar
    Join Date
    Nov 2005
    Location
    Midlands
    Posts
    1,052
    Quote Originally Posted by mpfjr View Post

    I was using amp control but as previously stated it only uses com1. My serial is on com2
    I'm a bit late to this but i just wanted to say that ampctrl will work on any port,you just have to tell it which 1 before you install it by changing port in the AmpCtrl.exe.config,opened with notepad you'll see....

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
    <appSettings>
    <add key="port" value="1" />
    </appSettings>
    </configuration>

    The important bit being = <add key="port" value="1" />.
    P4 2.8 HT, 512Mb Ram, 60Gb 2.5 HD, M4-ATX, SB Audigy2, BU353, Lilliput TS,Soundgraph Imon VFD,SONY Optiarc dvd Burner,RideRunner, iGo8, Custom Freedom 2.1

  9. #19
    FLAC
    Join Date
    May 2006
    Location
    Calgary, Alberta
    Posts
    1,718
    Can someone point out some examples of what someone might want to do with this either in their car or even at home?
    Ampie Case
    2.5" Hard Drive 80GB Samsung 5400RPM
    256 MB DDR2 PC5400
    Xenarc 700TSV - VGA Monitor
    Intel D945GCLF Motherboard
    M2-ATX-HV

    2005 Honda Civic

  10. #20
    Constant Bitrate utd09bry's Avatar
    Join Date
    Sep 2007
    Location
    Dallas,TX
    Posts
    216
    i use it in my car... when RR starts up I have it make DTR high which turns on a transistor/relay combination to turn on my amp

    this is to avoid speaker pop when the sound card initializes during windows booting (I have a USB sound card)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •