Page 8 of 10 FirstFirst 12345678910 LastLast
Results 71 to 80 of 93

Thread: RR application indicator

  1. #71
    The Last Good Gremlin GizmoQ's Avatar
    Join Date
    Nov 2004
    Location
    St Louis
    Posts
    2,347
    Quote Originally Posted by Lucifer View Post
    Gizmo, which fm radio/rds hardware do you use?
    I have the Silabs USB using Spidermunz plugin. Got RDS, TA, AF, TI, TP, EON, NEWS, Wave Audio in stereo or quadraphonic sound and a whole bunch of other labels and indicators I don't understand. Works well.

    I'm no programmer, but I really think this needs to be part of the RR Source. There's so many other uses it could have. As new and different audio sources are added/supported this could follow suite. Just look at the 7 different radios now supported in RR natively besides XM and Sirius, not to mention internet radio.
    HARDWARE: Fujitsu Stylistic ST5111w/WiFi and dock, internal Hitachi 500G HD, external 1TB HD, Sierra Wireless Aircard 550, DVD-RW, BoomzBox HD radio, XM Commander, Delorme GPS, Saitek X-52 Pro joystick, BluSoleil Bluetooth, TPMS, FB, Elm327

  2. #72
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Part of RR source...yes/no.

    No, b/c when the source becomes hard to come by, the ext plugin could be easly updated to include whatever, and would work with possibly older RR's too..

    Yes...Um...Um...Um..I'll get back to ya on this one....
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  3. #73
    Maximum Bitrate Dave One's Avatar
    Join Date
    Mar 2005
    Location
    Norfolk UK
    Posts
    542
    Quote Originally Posted by Lucifer View Post
    Register Dll:
    -------------
    Open cmd, goto RoadRunner install folder
    C:\> cd "C:\Program Files\Road Runner"
    C:\Program Files\Road Runner>regasm ProcessIndicators.dll /tbl
    Fell at the first hurdle

    Tried to register the .dll but didn't have any luck. My Road Runner folder is in E:\Car PC directory. Try as I might I can't register the dll using Run and Run>cmd.

    Any pointers please?

    Thanks,
    Dave
    Vauxhall Astra SXi Car PC installed.

  4. #74
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Here... Just drop into your rr folder or where ever you have your ProcessIndicator.dll file at and run the RegProcInd.cmd.

    [ EDIT ]

    This is for Lucifer's plugin above, to make registering it easier for you, the users.

    Sorry, typo. see below for new zip
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  5. #75
    Maximum Bitrate Dave One's Avatar
    Join Date
    Mar 2005
    Location
    Norfolk UK
    Posts
    542
    Thanks Blue,

    I've done as you and Lucifier have suggested but still no indicator. I just put the .dll and .xml (and Blues registering file) in the Raod Runner folder. Does this mean the .dll hasn't registered or is my xml code wrong?

    <?xml version="1.0" encoding="utf-8" ?>
    - <processes refreshrate="1000">
    <process name="dashcommand" indicator="OBDIND" />
    </processes>

    Many thanks ,
    Dave
    Vauxhall Astra SXi Car PC installed.

  6. #76
    Maximum Bitrate Dave One's Avatar
    Join Date
    Mar 2005
    Location
    Norfolk UK
    Posts
    542
    Actually Blue,

    I just got a screen capture that says about HDRadio when I run the RegProInd.cmd. It must be the registering problem.

    Dave
    Vauxhall Astra SXi Car PC installed.

  7. #77
    Maximum Bitrate Dave One's Avatar
    Join Date
    Mar 2005
    Location
    Norfolk UK
    Posts
    542
    Sorry guys, I've now got it running ok. Twas my DOS ability that caused the problem - it wouldn't go to E: simply because I tried E:\. Doh! I also had to drop /tbl off the regasm line.

    Many Thanks fellow forum users,
    Dave
    Vauxhall Astra SXi Car PC installed.

  8. #78
    Raw Wave pierrotm777's Avatar
    Join Date
    May 2008
    Location
    Bordeaux, France
    Posts
    2,840
    Quote Originally Posted by Davefocus View Post
    Thanks Blue,

    I've done as you and Lucifier have suggested but still no indicator. I just put the .dll and .xml (and Blues registering file) in the Raod Runner folder. Does this mean the .dll hasn't registered or is my xml code wrong?

    <?xml version="1.0" encoding="utf-8" ?>
    - <processes refreshrate="1000">
    <process name="dashcommand" indicator="OBDIND" />
    </processes>

    Many thanks ,
    Dave
    Hi Dave,

    I think than the ligne must to be:

    Delete "-" before <processes refreshrate="1000">
    <process name="dashcommand" indicator="OBDIND"></process>



    Me I had tried this ligne for Garmin Mobile Pc

    <?xml version="1.0" encoding="utf-8" ?>
    <processes refreshrate="1000">
    <process name="que" indicator="GARMINSTATUS"></process>
    </processes>


    And I see nothing

    On my skin I have that
    I,437,2,30,30,"GARMINSTATUS"

  9. #79
    Maximum Bitrate Dave One's Avatar
    Join Date
    Mar 2005
    Location
    Norfolk UK
    Posts
    542
    Quote Originally Posted by pierrotm777 View Post
    Me I had tried this ligne for Garmin Mobile Pc

    <?xml version="1.0" encoding="utf-8" ?>
    <processes refreshrate="1000">
    <process name="que" indicator="GARMINSTATUS"></process>
    </processes>


    And I see nothing

    On my skin I have that
    I,437,2,30,30,"GARMINSTATUS"
    Cheers Pierrotm777,

    Mines working ok now.

    Have you got an image as part of the skin that your indicator line can be used with?

    Personally, I'm using the Elite lite skin (highly recommended) that has the screen image with a screen of indicator images as another layer included to that screen image (using INC command), if you get my meaning. I have an online, repeat, shuffle volume, mute and OBD indicator on the layered screen.

    I'm happy to discuss further if I haven't been clear.

    Thanks,
    Dave
    Vauxhall Astra SXi Car PC installed.

  10. #80
    Raw Wave pierrotm777's Avatar
    Join Date
    May 2008
    Location
    Bordeaux, France
    Posts
    2,840
    Quote Originally Posted by Davefocus View Post
    Cheers Pierrotm777,

    Mines working ok now.

    Have you got an image as part of the skin that your indicator line can be used with?

    Personally, I'm using the Elite lite skin (highly recommended) that has the screen image with a screen of indicator images as another layer included to that screen image (using INC command), if you get my meaning. I have an online, repeat, shuffle volume, mute and OBD indicator on the layered screen.

    I'm happy to discuss further if I haven't been clear.

    Thanks,
    Dave
    If I had help you I am happy .

    For my problem I ask me if my xml file is ok .

    My process name is Que.exe (Garmin Mobile Pc) , so
    I had config these lignes :

    <?xml version="1.0" encoding="utf-8" ?>
    <processes refreshrate="1000">
    <process name="que" indicator="GARMINSTATUS"></process>
    </processes>

    I have not put the necessary files on RR folder but on the skin Plugins folder like:

    C:\Programme Files\Ride Runner\Skins\DigitalFx 4.0\Plugins\ProcessIndicator\

    I had too added X,ProcessIndicator in the Plugins.txt file than is allready include in the menu.txt with an INC command

    On my skin I had added this indicator ligne:
    I,437,2,30,30,"GARMINSTATUS"

    AND I regitered the dll .

    Where is my error ?

Similar Threads

  1. Replies: 70
    Last Post: 10-15-2007, 05:21 PM
  2. How do I use the Base plugin sources ?
    By guino in forum RR FAQ
    Replies: 1
    Last Post: 04-24-2006, 03:43 PM
  3. Notifying child application of Hibernation wakeup
    By mullaly in forum Road Runner
    Replies: 2
    Last Post: 04-24-2006, 03:44 AM
  4. status update....
    By 0l33l in forum PowerVoice
    Replies: 17
    Last Post: 05-05-2005, 12:22 PM
  5. Bruno Speech Recognition with RR?
    By ruairi in forum Road Runner
    Replies: 12
    Last Post: 05-03-2005, 12:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •