Page 9 of 10 FirstFirst 12345678910 LastLast
Results 81 to 90 of 93

Thread: RR application indicator

  1. #81
    Maximum Bitrate Dave One's Avatar
    Join Date
    Mar 2005
    Location
    Norfolk UK
    Posts
    542
    Quote Originally Posted by pierrotm777 View Post
    I have not put the necessary files on RR folder but on the skin Plugins folder like:

    C:\Programme Files\Ride Runner\Skins\DigitalFx 4.0\Plugins\ProcessIndicator\
    I put my ProcessIndicator.dll and xml into C:\Programme Files\Ride Runner\ but I beleive it can be in any subfolder.

    Quote Originally Posted by pierrotm777 View Post
    I had too added X,ProcessIndicator in the Plugins.txt file than is allready include in the menu.txt with an INC command

    Where is my error ?
    I used the INC command because the image layering used in Elite lite, the 'on' image layered on the 'menu' image, not as a prefix to X,ProcessIndicator (this should be a line by itself in menu.skin).

    I beleive that the indicator area, when used for the menu, shows the menu_off image for that particular area if the indicator is set to off and the menu_on image if set to on. Therefore you'll need to amend the .jpgs for the indicator you wish to see.

    My apologies if I've misunderstood what you have done and you're already at this point.

    Incidently, I checked the XML file and couldn't see the "-" so it must have been a cut and paste error.

    Dave
    Vauxhall Astra SXi Car PC installed.

  2. #82
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Quote Originally Posted by Davefocus View Post
    I put my ProcessIndicator.dll and xml into C:\Programme Files\Ride Runner\ but I beleive it can be in any subfolder.
    Correct, but if you want to follow the current std, then plugins that would be used for all installed skins should go in the "C:\Programme Files\Ride Runner\Plugins\plugin name\plugin files"
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  3. #83
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Quote Originally Posted by pierrotm777 View Post
    If I had help you I am happy .

    For my problem I ask me if my xml file is ok .

    My process name is Que.exe (Garmin Mobile Pc) , so
    I had config these lignes :

    <?xml version="1.0" encoding="utf-8" ?>
    <processes refreshrate="1000">
    <process name="que" indicator="GARMINSTATUS"></process>
    </processes>

    I have not put the necessary files on RR folder but on the skin Plugins folder like:

    C:\Programme Files\Ride Runner\Skins\DigitalFx 4.0\Plugins\ProcessIndicator\

    I had too added X,ProcessIndicator in the Plugins.txt file than is allready include in the menu.txt with an INC command

    On my skin I had added this indicator ligne:
    I,437,2,30,30,"GARMINSTATUS"

    AND I regitered the dll .

    Where is my error ?
    My guess would be the same as what Davefocus was taking about. look at the xx_On.png file in the screen that you defined your "I,xxx,x.." line above and check to see if you have something in that area that rr will use to show for the indicator.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  4. #84
    Raw Wave pierrotm777's Avatar
    Join Date
    May 2008
    Location
    Bordeaux, France
    Posts
    2,840
    I Dave and BlueZx3,

    What I must write on Plugins.txt:

    X,ProcessIndicator or X,ProcessIndicators

    I had added the plugin on Plugins RR folder and I have the same issue .

    Xml file is :
    <?xml version="1.0" encoding="utf-8" ?>
    <processes refreshrate="1000">
    <process name="Que" indicator="GARMINSTATUS"></process>
    </processes>

    I had modified the skin give with RR ,Carwings Dynamic:
    Attached Images Attached Images  

  5. #85
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    The correct line "X,ProcessIndicators"

    And What RR ver you running? Turn on debug and look at the debug.txt to make sure that it is in fact being loaded properly and there are no issues.

    And looks like it can't be the image issue as your using something that does have the on/off layers.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  6. #86
    Raw Wave pierrotm777's Avatar
    Join Date
    May 2008
    Location
    Bordeaux, France
    Posts
    2,840
    Quote Originally Posted by Blue ZX3 View Post
    The correct line "X,ProcessIndicators"

    And What RR ver you running? Turn on debug and look at the debug.txt to make sure that it is in fact being loaded properly and there are no issues.

    And looks like it can't be the image issue as your using something that does have the on/off layers.
    I use the First RideRunner version on Vista .
    I had updloaded my debug.txt file .

    I had tried too X,ProcessIndicators in the menu.skin file .
    Attached Files Attached Files

  7. #87
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    This line:
    PHP Code:
    05/02/2009 19:42:59Plugin ManagerError loading (menu.skin): ProcessIndicators (Le composant ActiveX ne peut créer l'objet, check spelling of plugin, or its is COM registration missing.) 
    Is the reason that you are having problems. Its trying to load the plugin but can't. I don't know if somehow its not being registered correctly/completely, but I willing to bet that is where your problem lies.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  8. #88
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    #1 Delete that X,line ( no longer needed for the newer RR's ) and any others
    #2 put the entire zip contents into either RideRunner\Plugins\ProcessIndicators or RideRunner\skins\cartwings_dynamic\plugins\Process Indicators folder
    #3 Put the xml file form your other attempt into that same folder
    #4 Right Click "Run as admin" on the RegProcInd.cmd to reg it
    #5 Give a try..

    There was a typo in my reg zip above, so now i have just combined everthing into one zip.
    Attached Files Attached Files
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  9. #89
    Raw Wave pierrotm777's Avatar
    Join Date
    May 2008
    Location
    Bordeaux, France
    Posts
    2,840
    Quote Originally Posted by Blue ZX3 View Post
    #1 Delete that X,line ( no longer needed for the newer RR's ) and any others
    #2 put the entire zip contents into either RideRunner\Plugins\ProcessIndicators or RideRunner\skins\cartwings_dynamic\plugins\Process Indicators folder
    #3 Put the xml file form your other attempt into that same folder
    #4 Right Click "Run as admin" on the RegProcInd.cmd to reg it
    #5 Give a try..

    There was a typo in my reg zip above, so now i have just combined everthing into one zip.
    I DON'T UNDERSTANDDDDD ...

    Well,

    I had stay X,ProcessIndicators in the Plugins.txt file ,
    I have that in the menu.skin file ,
    RoadRunner Skin
    RRScreen MENU
    MENU_1_OFF.PNG,MENU_1_OFF.PNG,MENU_1_ON.PNG,MENU_1 _DOWN.PNG
    INC,BOTTOMTEXT.TXT
    INC,Plugins.txt

    I,740,60,62,63,"NOTEPADSTATUS"

    I had run RegProInd.cmd ad Administrator,
    and I had renamed your ProcessIndicators(sample).xml as ProcessIndicators.xml.



    I had unzipped here in the Plugins Ride Runner folder :
    Attached Images Attached Images  

  10. #90
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Right click on the regprocind.cmd and edit, change the "exit" to "pause".
    save, then re-run it and post a screen caputure of that window...

    This will have it say open so that we can see if there are any issues of it not registering the dll file.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

Similar Threads

  1. Replies: 70
    Last Post: 10-15-2007, 05:21 PM
  2. How do I use the Base plugin sources ?
    By guino in forum RR FAQ
    Replies: 1
    Last Post: 04-24-2006, 03:43 PM
  3. Notifying child application of Hibernation wakeup
    By mullaly in forum Road Runner
    Replies: 2
    Last Post: 04-24-2006, 03:44 AM
  4. status update....
    By 0l33l in forum PowerVoice
    Replies: 17
    Last Post: 05-05-2005, 12:22 PM
  5. Bruno Speech Recognition with RR?
    By ruairi in forum Road Runner
    Replies: 12
    Last Post: 05-03-2005, 12:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •