Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: New to VB.net and C# need help to interface with SDK

  1. #11
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Quote Originally Posted by ws6vert View Post
    Bump... I still have this problem only for C# in VS2008. Any suggestions are welcomed.
    Sounds weird, I'd try installing it on another machine to see if it happens as well.. if so maybe related to the install, if not, then it's probably machine (OS) related. That's what I'd try to do other than looking at VS2008 settings.. I'd be of more help if I had VS2008 installed (but .NET just doesn't get along well with my slow machine)..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  2. #12
    Maximum Bitrate ws6vert's Avatar
    Join Date
    Sep 2008
    Location
    Baton Rouge
    Posts
    351
    Yeh I dont know... It was working fine, and then all of a sudden it just starts all this crazyness. Its only doing it for C#, and none of the other languages. Weird. Makes me think it was related to some sort of update or something.

  3. #13
    Maximum Bitrate ws6vert's Avatar
    Join Date
    Sep 2008
    Location
    Baton Rouge
    Posts
    351
    Ok, revisiting this issue. I got VS2008 reinstalled and working right again. Updated to newest RR version. First thing I did was open the C# solution extension example, changed the GUIDs (all 3), built the solution, and placed the dll in the plugins folder. The problem is, the plugin mgr on the carwings lite skin does not find the myextension.dll. So what I do wrong, what am i missing to get RR to recognize the plugin?

  4. #14
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Quote Originally Posted by ws6vert View Post
    Ok, revisiting this issue. I got VS2008 reinstalled and working right again. Updated to newest RR version. First thing I did was open the C# solution extension example, changed the GUIDs (all 3), built the solution, and placed the dll in the plugins folder. The problem is, the plugin mgr on the carwings lite skin does not find the myextension.dll. So what I do wrong, what am i missing to get RR to recognize the plugin?
    My first question is if you did that regasm stuff to reg the DLL (since .NET doesn't register with regsvr32).. other than that, I'd say we need some insight from one of the .NET guys.. hehe
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  5. #15
    Maximum Bitrate ws6vert's Avatar
    Join Date
    Sep 2008
    Location
    Baton Rouge
    Posts
    351
    Bumping. Im doing another reinstall this time on Win7 machine. Let me know where I'm going wrong, I tried regsvr32 and regasm if I remember right.

  6. #16
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,266
    Quote Originally Posted by ws6vert View Post
    Bumping. Im doing another reinstall this time on Win7 machine. Let me know where I'm going wrong, I tried regsvr32 and regasm if I remember right.
    that seems out of context, "reinstall" of what?
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  7. #17
    Maximum Bitrate ws6vert's Avatar
    Join Date
    Sep 2008
    Location
    Baton Rouge
    Posts
    351
    Im reinstalling VS2008 because I was having issues with it on another machine. The problem is, I am taking the C# example plugin, changing GUIDs, compiling, attempting to register, and it is not showing up under the Carwings Lite skin plugin manager. Just trying to figure out, what step im missing or messing up at.

  8. #18
    FLAC
    Join Date
    Jan 2008
    Location
    Dartmouth, MA
    Posts
    914
    Are you on a 64 bit machine? You could be compiling the dll in 64 bit when RR is only 32.
    My Nearly Complete Car:
    http://www.mp3car.com/vbulletin/show...ed-car-pc.html

    Micro Control Center... Control Your Car Across the Internet
    http://www.mp3car.com/fusion-brain/1...-internet.html

    Website: (It's a work in progress, really. All my projects have taken me from ever really developing it.)
    http://paulfurtado.com/

  9. #19
    Maximum Bitrate ws6vert's Avatar
    Join Date
    Sep 2008
    Location
    Baton Rouge
    Posts
    351
    No the machines are 32 bit.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •