Page 45 of 58 FirstFirst ... 353637383940414243444546474849505152535455 ... LastLast
Results 441 to 450 of 575

Thread: Integrated voice control in RR...

  1. #441
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,173
    Blog Entries
    53
    sorry to bring this up again but voice is possessed. i reinstalled the .dll (tried test version, errors... so i went to 5-02 version). at first it worked with my ini settings:

    usekeyword=false
    usehotkey=true

    F10 is my hotkey. Started rr.. "voice is ready" press f10, said audio.. it worked. SWEET! Then without pressing the hotkey.. seemingly for no reason at all it said "BLANK BLANK disabled" (didnt hear it all) Since then, f10 no longer works, voice speaks randomly even with no music playin and quiet environment, and it commands itsself to reset my playlist every minute or so.

    i checked the ini file and my settings are the same. What gives?
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  2. #442
    Constant Bitrate
    Join Date
    Nov 2005
    Posts
    215
    Quote Originally Posted by Sonicxtacy02 View Post
    sorry to bring this up again but voice is possessed. i reinstalled the .dll (tried test version, errors... so i went to 5-02 version). at first it worked with my ini settings:

    usekeyword=false
    usehotkey=true

    F10 is my hotkey. Started rr.. "voice is ready" press f10, said audio.. it worked. SWEET! Then without pressing the hotkey.. seemingly for no reason at all it said "BLANK BLANK disabled" (didnt hear it all) Since then, f10 no longer works, voice speaks randomly even with no music playin and quiet environment, and it commands itsself to reset my playlist every minute or so.

    i checked the ini file and my settings are the same. What gives?
    Did you try it with both set to true?

  3. #443
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,173
    Blog Entries
    53
    set both to true with the same results. I even muted the mic and the problem was still there.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  4. #444
    Variable Bitrate
    Join Date
    Mar 2005
    Location
    Sweden/Vaxjo
    Posts
    418
    Quote Originally Posted by Sonicxtacy02 View Post
    its already embedded into road runner now? did you have somethin else that needed to be added?
    hmm... if this is really integrated into RR now... how do I turn it on and configure it...
    Swedish site for CarPC's
    http://www.bilpc.info

  5. #445
    Constant Bitrate
    Join Date
    Nov 2005
    Posts
    215
    Quote Originally Posted by Sonicxtacy02 View Post
    set both to true with the same results. I even muted the mic and the problem was still there.
    Can you PM me your ini file and I will try it here?

  6. #446
    Constant Bitrate
    Join Date
    Nov 2005
    Posts
    215
    Quote Originally Posted by Naesstrom View Post
    hmm... if this is really integrated into RR now... how do I turn it on and configure it...
    1. You will need SAPI installed, there is a link on the first post if it is not.

    2. Run thru the microphone and training wizards in Control Panel -> Speech

    3. Extract the files from the first post (use the 5-02 version) and add a UseVoiceControl=True line to the RR.ini

    4. There should not me any configurations you will need to do but you can customize commands if needed by editing the commands.xml and recompiling (let me know if you need help with this, may not be obvious)

    Let me know if this gets you going

  7. #447
    Variable Bitrate
    Join Date
    Mar 2005
    Location
    Sweden/Vaxjo
    Posts
    418
    Quote Originally Posted by whodwho View Post
    1. You will need SAPI installed, there is a link on the first post if it is not.

    2. Run thru the microphone and training wizards in Control Panel -> Speech

    3. Extract the files from the first post (use the 5-02 version) and add a UseVoiceControl=True line to the RR.ini

    4. There should not me any configurations you will need to do but you can customize commands if needed by editing the commands.xml and recompiling (let me know if you need help with this, may not be obvious)

    Let me know if this gets you going
    Thanks... I got it working last night and took it for a ride today, I have some problems to get it to undestand my commands though, I was trying to pause the music a couple of times and it took it for close an shut down RR while I was shouting "NOOOO!" at it...

    I have a few more questions:
    1. Is it possible to use another enginge then the MS SAPI, I think I might have Dragon Dictate around somewhere, I did the first set of exercise with it, the 10 minute one but it feels like it still doesnt understand me (Might be that I'm a swede and it just cant understand my dialect in english or something...)

    2. How many commands can I give in a row without havin to say boris between them, I was mostly thinking about the volume setting... I changed the command but it's still:
    -(me)Boris
    -(Boris)Speak
    -(Me)Volume up
    -(Boris)Volume up
    -(me)Volume up
    -(me)VOLUME UP
    -(me) For gods sake, VOLUME UP
    -(me)Boris (with a tired voice)
    -(Boris)speak (happy as ever)
    and so on...
    Swedish site for CarPC's
    http://www.bilpc.info

  8. #448
    Variable Bitrate
    Join Date
    Mar 2005
    Location
    Sweden/Vaxjo
    Posts
    418
    Today I noticed one more thing.. I have done all the training lessons available and have noticed one strange thing...

    Most of the time whe Boris don't get me he just says "now playing playlist" and jumps to song 21... is there any way to turn this off?
    Swedish site for CarPC's
    http://www.bilpc.info

  9. #449
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,173
    Blog Entries
    53
    that is the MOST annoying thing! All the other mishaps are ok, but i'd say 75% of the time there's an error interpreting commands it jumps somewhere in the playlist.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  10. #450
    Constant Bitrate
    Join Date
    Nov 2005
    Posts
    215
    Quote Originally Posted by Naesstrom View Post
    Thanks... I got it working last night and took it for a ride today, I have some problems to get it to undestand my commands though, I was trying to pause the music a couple of times and it took it for close an shut down RR while I was shouting "NOOOO!" at it...

    I have a few more questions:
    1. Is it possible to use another enginge then the MS SAPI, I think I might have Dragon Dictate around somewhere, I did the first set of exercise with it, the 10 minute one but it feels like it still doesnt understand me (Might be that I'm a swede and it just cant understand my dialect in english or something...)

    2. How many commands can I give in a row without havin to say boris between them, I was mostly thinking about the volume setting... I changed the command but it's still:
    -(me)Boris
    -(Boris)Speak
    -(Me)Volume up
    -(Boris)Volume up
    -(me)Volume up
    -(me)VOLUME UP
    -(me) For gods sake, VOLUME UP
    -(me)Boris (with a tired voice)
    -(Boris)speak (happy as ever)
    and so on...
    Glad you were able to get it going.

    1. The only engine currently supported is the MS one as that is all I have access too.

    I know how frustrating it is when it won't respond correctly, I use my headset for the mic only and I had the headphone jack plugged into the mic jack so it was using the earpieces for a mic - needless to say there was alot of shouting with words it was not meant to understand!

    2. There is a setting in Voice.ini KeywordTimeout= you can increase this to have more listening for command time. The timer is reset on each recognized command so it is probably aggravated by the difficulties with recognition.

    Some suggestions to try, in the control panel for speech for your profile there is a setting to 'automatically adapt to the speakers voice', I would not use this setting as it may be adapting your commands with background noise of the vehicle. I know it is not fun to go thru but maybe create another profile without this setting and see if helps. "The papaya tastes perfect"

    With helping with this particular scenario instead of using "volume up" multiple times use "volume sixty percent"

    Let me know if any of this helps

Similar Threads

  1. Recommendations : Voice Control
    By wolfebaine in forum Input Devices
    Replies: 49
    Last Post: 01-03-2006, 06:05 PM
  2. SpeakEasy Voice Recognition - Release 0.9.2
    By ruairi in forum Software & Software Development
    Replies: 10
    Last Post: 11-22-2005, 04:29 PM
  3. Voice control
    By Cheekz185 in forum Centrafuse
    Replies: 0
    Last Post: 06-23-2005, 11:35 PM
  4. request: voice control for videos
    By ryguy in forum Centrafuse
    Replies: 5
    Last Post: 06-09-2005, 02:04 AM
  5. Replies: 22
    Last Post: 08-13-2001, 02:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •