View Poll Results: Should the radioSHARK support be native in RR?

Voters
73. You may not vote on this poll
  • Yes

    70 95.89%
  • No

    3 4.11%
Page 12 of 20 FirstFirst ... 234567891011121314151617181920 LastLast
Results 111 to 120 of 193

Thread: radioSHARK Plugin for RoadRunner

  1. #111
    Variable Bitrate Evolution VIII's Avatar
    Join Date
    Dec 2005
    Location
    Miami-Florida-USA
    Posts
    342
    Quote Originally Posted by xs10x
    any new updates on this?
    I tested radioSHARK plugin and its working fine. The problem is in the radioSHARK plugin skin you using.

    Please try this skin and please let me know if it is working for you: http://www.bestmiamibeachproperties....osharkskin.zip

  2. #112
    Variable Bitrate xs10x's Avatar
    Join Date
    Jul 2005
    Location
    Bronx, NY
    Posts
    263
    Testing it...
    ````` _____||.\__
    .:.:.:.:.:.:;!_(o)______(o)'i
    TruckputerX - Vortech SuperCharger Vid
    TruckputerX Progress Bar [|||||||||-] 90% Complete [It's never 100% done]

  3. #113
    Variable Bitrate Evolution VIII's Avatar
    Join Date
    Dec 2005
    Location
    Miami-Florida-USA
    Posts
    342
    Quote Originally Posted by xs10x
    Testing it...
    Is it working?

  4. #114
    Variable Bitrate Evolution VIII's Avatar
    Join Date
    Dec 2005
    Location
    Miami-Florida-USA
    Posts
    342
    WORKING SKIN: (this version will not work with the skin included in the zip file)

    http://www.bestmiamibeachproperties....osharkskin.zip

    * If you still want to use your old skin and the plugin is not working (error: No valid skin found.) you must do the following:

    1. Ither remove referense to the slider from your skin
    S01,277,493,247,25,277,493,247,25,H,01,"",0,"MASTE R",""

    OR

    1. Make sure that the reference to slider and slider file path are present in the skin
    Y01,"SLIDER_VOLUME\slider_*.gif"
    S01,277,493,247,25,277,493,247,25,H,01,"",0,"MASTE R",""

    2. Make sure that the slider file path (folder) and slider images are exists in your skin folder.

  5. #115
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,691
    Blog Entries
    1

    Radio Shark

    First Off, Thanks for a great plugin, and FM sollution for RR. I started researching an FM sollution for my Car PCa couple days ago. Most supported tuners are PCI cards, and not an option for my mini CarPC. Radio Shark seemed like the way to go, and I love the time shifting capabilities built in.

    I started reading this thread this morning, and went to Best Buy and just bought a Radio Shark for $49. (Had them price Match Comp USA, as Best buy wanted $69 for it, and Comp USA is on the other side of town, BB is right on the corner )

    Now a couple of things I have learned learned from this thread, as well as trial and error that may help others:

    First, Evolution VIII, can you edit the first post in this thread to fix the "N N" issue, that is confusing a lot of people, including me when I couldn't get it to work, till I saw the write up a couple pages into this thread.
    Here is the line under item 6 a tthe top of this thread:
    "RADIOSHARK","PLUGIN;RRRadioSharkPlugin;C:\RoadRun ner\radioSharkPlugin\radioSharkPlugin.exe"
    Second, if you have installed the new version, as Evolution stated, make sure you edit the RadioShark.ini to have the correct paths to your volume sliders, and pointer. ALSO, not mentioned, is to do the same for the Phoco Signal and battery sliders. I do not use Phoco, so I just removed the last couple lines in the RadioShark.ini, started it up, and I didn't get the "76 path not found" error. Works great now!

    Third: The software that comes with the radio Shark on the CD is outdated. (Even though when you install it, it asks if it should look for updates, you say yes, it reports that no updates are available.) This will not allow you to patch the Radio Shark.exe to work with the plugin. Go to Their Website and get the latest version.

    Now that it's working, I am off to design a skin to match mine

    Also: You must be local to me, as I recognise all the radio stations in the .ini file, and did not have to alter it too much
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  6. #116
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,691
    Blog Entries
    1
    Sorry... I hate to double post.....

    I have Radio shark working pretty well in RR, vollume works, as well as the volume slider, it record ect ect...

    However in the RadioShark.skin, I see no reference to a list box whatsoever for the station presets. HOWEVER, there is a VERY small list box above the "Band" button on the skin with a couple stations showing in it. (Actually the size of the "Band" button itself). I moved a couple buttons in the skin, Restarted RR, to verify that yes, indeed, it is the skin that it is calling.

    Also, The presets in the .ini are not coorisponding to the ones in the skin. I set all the stations up in the .ini and in the skin it is just random stations. I changed the "tunestep=1" to "tunestep=5", again, as just a test, and sure enough the tuning in RR was changed, so I know that is definately the .ini file it is reading from. I have no idea where it is getting the "phantom" presets.

    Is there anything in the plugin.exe that hardcodes the path to "C:\Road Runner" for some things? Most of us have Road Runner installed in the c:\program files\Road Runner\" directory. Could this be a problem?
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  7. #117
    Variable Bitrate Evolution VIII's Avatar
    Join Date
    Dec 2005
    Location
    Miami-Florida-USA
    Posts
    342
    Quote Originally Posted by JohnWPB View Post
    First Off, Thanks for a great plugin, and FM sollution for RR. I started researching an FM sollution for my Car PCa couple days ago. Most supported tuners are PCI cards, and not an option for my mini CarPC. Radio Shark seemed like the way to go, and I love the time shifting capabilities built in.

    I started reading this thread this morning, and went to Best Buy and just bought a Radio Shark for $49. (Had them price Match Comp USA, as Best buy wanted $69 for it, and Comp USA is on the other side of town, BB is right on the corner )

    Now a couple of things I have learned learned from this thread, as well as trial and error that may help others:

    First, Evolution VIII, can you edit the first post in this thread to fix the "N N" issue, that is confusing a lot of people, including me when I couldn't get it to work, till I saw the write up a couple pages into this thread.
    Here is the line under item 6 a tthe top of this thread:


    Second, if you have installed the new version, as Evolution stated, make sure you edit the RadioShark.ini to have the correct paths to your volume sliders, and pointer. ALSO, not mentioned, is to do the same for the Phoco Signal and battery sliders. I do not use Phoco, so I just removed the last couple lines in the RadioShark.ini, started it up, and I didn't get the "76 path not found" error. Works great now!

    Third: The software that comes with the radio Shark on the CD is outdated. (Even though when you install it, it asks if it should look for updates, you say yes, it reports that no updates are available.) This will not allow you to patch the Radio Shark.exe to work with the plugin. Go to Their Website and get the latest version.

    Now that it's working, I am off to design a skin to match mine

    Also: You must be local to me, as I recognise all the radio stations in the .ini file, and did not have to alter it too much
    Unfortunately "N N" problem appears to be the functionality of this forum. I did try to fix it multiple times. No mater what I do it still inserting a space between those two N's.

    Thanks for your feedback.

  8. #118
    Variable Bitrate Evolution VIII's Avatar
    Join Date
    Dec 2005
    Location
    Miami-Florida-USA
    Posts
    342
    Quote Originally Posted by JohnWPB View Post
    Sorry... I hate to double post.....

    I have Radio shark working pretty well in RR, vollume works, as well as the volume slider, it record ect ect...

    However in the RadioShark.skin, I see no reference to a list box whatsoever for the station presets. HOWEVER, there is a VERY small list box above the "Band" button on the skin with a couple stations showing in it. (Actually the size of the "Band" button itself). I moved a couple buttons in the skin, Restarted RR, to verify that yes, indeed, it is the skin that it is calling.

    Also, The presets in the .ini are not coorisponding to the ones in the skin. I set all the stations up in the .ini and in the skin it is just random stations. I changed the "tunestep=1" to "tunestep=5", again, as just a test, and sure enough the tuning in RR was changed, so I know that is definately the .ini file it is reading from. I have no idea where it is getting the "phantom" presets.

    Is there anything in the plugin.exe that hardcodes the path to "C:\Road Runner" for some things? Most of us have Road Runner installed in the c:\program files\Road Runner\" directory. Could this be a problem?
    Have you tried the last version with new skin?

  9. #119
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,691
    Blog Entries
    1
    Yes, I have the new skin now, and the list box is appearing correctly. I am still having a problem with the station presets though. I have NO clue where it is getting the stations that are in the presets.

    One other strange note, When I first launch the radio, the list box is empty, and I have to scroll down or up to make the list actually appear.

    In the radioshark.ini file I have the following:
    FM radio presets
    fm_preset_1=94.3;Talk Radio
    fm_preset_2=96.5;Power 96
    fm_preset_3=97.3;Coast FM
    fm_preset_4=97.9;WRMF
    fm_preset_5=96.5;Power 96
    fm_preset_6=99.1;99 Jams
    fm_preset_7=100.7;Y-100
    fm_preset_8=104.3;Sunny

    If you look at this Screen cap:<BR>


    You will see when I click on "Power 96" It comes up with a station that is not in the presets whatsoever. Again, I change the tuning steps in the .ini to ensure that this is the correct location of the ini and it is indeed reading the one I am altering.

    All of these questions and problem... I am sorry! I know all to well what it is like to release something, and think that all will be well, and you are done with it, then it turns into more and more time involved answering questions and altering the code! I really do appreceiate your time and work on this project. It is the sole reason I went out and purchased a RadioShark in the first place yesterday morning!

    EDIT I also noticed that I have a total of 8 stations in the .ini file. When I scroll down the list, clicking on the first one shows the header at the top of the list as "Presets 1", the 2nd on the list shows as "Presets 2" When it gets to the 6th on in the list, it shows "Preset 6" for the rest of the items in the list...

    I don't know if that will help debug where the problem is or not. I have carefully checked my stations presets in the ini, and I am using a raw text editor, so I know there are no hidden characters/binary in the ini.

    Everything else on the skin is working perfectly, both volumes, recording, seek, tuning ect ect...) except for the presets.
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  10. #120
    Variable Bitrate Evolution VIII's Avatar
    Join Date
    Dec 2005
    Location
    Miami-Florida-USA
    Posts
    342

    Exclamation

    Yesterday I switch from radioSHARK to HQCT. Who want's the plugin ownership ?

Similar Threads

  1. Garo's Extra POI Plugin 1.0 beta 1
    By garo in forum Map Monkey
    Replies: 63
    Last Post: 01-18-2007, 12:32 PM
  2. radioShark am/fm usb adapter with timeshifting
    By kickerks80 in forum Car Audio
    Replies: 13
    Last Post: 10-04-2004, 04:08 PM
  3. Help with winXP/hibernate/LCD plugin
    By dave123456 in forum Software & Software Development
    Replies: 0
    Last Post: 10-17-2002, 08:17 PM
  4. Winamp LCD display plugin / IRMan plugin - together?
    By Jarrod in forum Software & Software Development
    Replies: 9
    Last Post: 06-03-2002, 05:39 AM
  5. Resumer Winamp plugin..works with MPC, too
    By Tony S in forum Software & Software Development
    Replies: 7
    Last Post: 03-30-2002, 05:10 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •