View Poll Results: Should the radioSHARK support be native in RR?

Voters
73. You may not vote on this poll
  • Yes

    70 95.89%
  • No

    3 4.11%
Page 13 of 20 FirstFirst ... 34567891011121314151617181920 LastLast
Results 121 to 130 of 193

Thread: radioSHARK Plugin for RoadRunner

  1. #121
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,700
    Blog Entries
    1
    Well I hope one of the programmers on here takes the plugin and completes it. Many of us do not have PCI slots in out Carputers, and this is one of the few sollutions available.

    Now, does anyone else have the presets working with the plugin? As mentioned above, I have been banging my head against the wall trying to figgure it out! If I could just get the presets to work correctly, I can live with this plugin in it's current state. Without presets though, it is just not functional.

    I even reverted back to the old skin with the preset buttons, and they do the exact same as the list, just choose random stations that are nowhere to be found in the .ini. I then twent back to ver 1 of the plugin, and still no dice....

    EDIT Ok, to make it even stranger, the AM radio presets work! I just filled them in from preset 1 to 6 with stations 610,620,630,640 ect in the .ini for testing purposes, and they work fine! This tells me that there is some communication problem from the RR skin, making a call to the incorrect place in the plugin exe.

    Evolution VIII, if you could just fix this hook for the FM presets, from RR to the plugin before you abandon the project, it would be GREATLY appreceiated, and would leave us with a functional plugin.
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  2. #122
    Variable Bitrate Evolution VIII's Avatar
    Join Date
    Dec 2005
    Location
    Miami-Florida-USA
    Posts
    342
    Quote Originally Posted by JohnWPB View Post
    Well I hope one of the programmers on here takes the plugin and completes it. Many of us do not have PCI slots in out Carputers, and this is one of the few sollutions available.

    Now, does anyone else have the presets working with the plugin? As mentioned above, I have been banging my head against the wall trying to figgure it out! If I could just get the presets to work correctly, I can live with this plugin in it's current state. Without presets though, it is just not functional.

    I even reverted back to the old skin with the preset buttons, and they do the exact same as the list, just choose random stations that are nowhere to be found in the .ini. I then twent back to ver 1 of the plugin, and still no dice....

    EDIT Ok, to make it even stranger, the AM radio presets work! I just filled them in from preset 1 to 6 with stations 610,620,630,640 ect in the .ini for testing purposes, and they work fine! This tells me that there is some communication problem from the RR skin, making a call to the incorrect place in the plugin exe.

    Evolution VIII, if you could just fix this hook for the FM presets, from RR to the plugin before you abandon the project, it would be GREATLY appreceiated, and would leave us with a functional plugin.

    Very strange, I don't see this behavior on my system at all. May be something changed in the radiSHARK executable, Iím may be using the older version or radioSHARK. No point going to old version/skin. Preset functionality hasnít changed. Iíll post the version number Iím using.

  3. #123
    Variable Bitrate Evolution VIII's Avatar
    Join Date
    Dec 2005
    Location
    Miami-Florida-USA
    Posts
    342
    I'm using radioSHARK v 1.1.7, and it works perfectly with the plug-in.

  4. #124
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,700
    Blog Entries
    1
    Im Using 1.1.7 FWO (not sure what the FWO on the end is.

    Strange part is the presets work perfectly on AM, but do not work on FM.

    The stations I get when pressing a preset button for FM are no where in my ini file. It just does not make sence to me!
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  5. #125
    Variable Bitrate Evolution VIII's Avatar
    Join Date
    Dec 2005
    Location
    Miami-Florida-USA
    Posts
    342
    Quote Originally Posted by JohnWPB View Post
    Im Using 1.1.7 FWO (not sure what the FWO on the end is.

    Strange part is the presets work perfectly on AM, but do not work on FM.

    The stations I get when pressing a preset button for FM are no where in my ini file. It just does not make sence to me!
    Send me you plugin ini file I'll find the problem.

  6. #126
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,700
    Blog Entries
    1

    Radio Shark

    As the .ini is short, I will just post it here, in case anyone else has the same problem, and you can comment on what you see. I have went through the ini with a fine tooth comb, and can't find anything out of the ordinary. I am editing it in a text editor, so there are no hidden binary characters, tabs, ect ect..

    This is the ini file it is using, as I changed the last line to Tunestep=10 and when tuning through the skin, it does indeed skip "10 steps".
    Also, it's worth mentioning again that the AM presets work perfectly.....

    Here it is:
    (I tried surrounding the text below with php tags to display it cleaner, but it altered the text)
    ---------------------------------------------------------------------------

    # path of the radioShark executable
    radioSharkPath=C:\Program Files\Griffin Technology\radioSHARK\radioSHARK.exe

    # To allow radioSHARK plugin work as stand-alone app set standalone=true
    standalone=false

    # FM radio presets
    fm_preset_1=94.3;Talk Radio
    fm_preset_2=96.5;Power 96
    fm_preset_3=97.3;Coast FM
    fm_preset_4=97.9;WRMF
    fm_preset_5=96.5;Power 96

    # AM radio presets
    am_preset_1=610;Public radio 610
    am_preset_2=620;Test
    am_preset_3=630;Test
    am_preset_4=640;Test
    am_preset_5=650;Test
    am_preset_6=660;Test

    # radioShark Volume control steps
    volumestep=1

    # radioShark Volume control symbol
    volumesymbol=|
    # volumesymbol=*
    # volumesymbol=numeric


    # radioShark tune control step
    tunestep=1

    -----------------------------------------------------------------------------------

    And here is the line from my Extbl,ini file:


    "RADIOSHARK","PLUGIN;RRRadioSharkPlugin;C:\Pro gram Files\Road Runner\radioSharkPlugin\radioSharkPlugin.exe"



    And here is a screen capture, showing that I am pressing the preset [1] button, which should bring up "94.3", and it is going to "100.7" instead.


    N OT E : * * * The Station name "Talk Radio" is showing up correctly when I press preset 1. I just noticed that this evening! So it is reading the correct line in the ini, just not changing the station to what is in the ini...





    As a note that alone is strange, as Y-100 in Miami is one of the stations you had originally had as one of your presets. Seems too much to be just a coincedence.
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  7. #127
    Variable Bitrate Evolution VIII's Avatar
    Join Date
    Dec 2005
    Location
    Miami-Florida-USA
    Posts
    342
    Quote Originally Posted by JohnWPB View Post
    N OT E : * * * The Station name "Talk Radio" is showing up correctly when I press preset 1. I just noticed that this evening! So it is reading the correct line in the ini, just not changing the station to what is in the ini... I just noticed that this evening! So it is reading the correct line in the ini, just not changing the station to what is in the ini...
    This is good info. I'll look into it Monday morning.

    PS:
    You forgot to install included font.

  8. #128
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,700
    Blog Entries
    1
    I appreceiate the help on this, if I can get the stations to work correctly, then I will be happy the way it is, as I really do not listen to the radio in the car that often, as I have 17,000 MP3's on 924 full albums... commercial free It is nice to catch a morning talk show or traffic report now and then though.


    Is there an undocumented "Pause" button in your plugin? I noticed you have record, was just wondering....

    As for the font, I didn't "Forget" to install it, I just didn't do it, as when I can get this to work correctly, I am going to use a skin that I am currently working on.

    EDIT: Here is the skin I am working on... it is not done, as I am still moving things around, cleaning it up, and I dont like the volume control the way it is with the text and all... but it's a start....
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  9. #129
    Variable Bitrate Evolution VIII's Avatar
    Join Date
    Dec 2005
    Location
    Miami-Florida-USA
    Posts
    342

    New and improved version released!

    New and improved version released! View beginning of the thread for information and links

  10. #130
    Newbie
    Join Date
    Aug 2006
    Posts
    14
    RadioShark is on sale @ BestBuy for anyone who hasn't gotten one yet. $29.

Similar Threads

  1. Garo's Extra POI Plugin 1.0 beta 1
    By garo in forum Map Monkey
    Replies: 63
    Last Post: 01-18-2007, 12:32 PM
  2. radioShark am/fm usb adapter with timeshifting
    By kickerks80 in forum Car Audio
    Replies: 13
    Last Post: 10-04-2004, 04:08 PM
  3. Help with winXP/hibernate/LCD plugin
    By dave123456 in forum Software & Software Development
    Replies: 0
    Last Post: 10-17-2002, 08:17 PM
  4. Winamp LCD display plugin / IRMan plugin - together?
    By Jarrod in forum Software & Software Development
    Replies: 9
    Last Post: 06-03-2002, 05:39 AM
  5. Resumer Winamp plugin..works with MPC, too
    By Tony S in forum Software & Software Development
    Replies: 7
    Last Post: 03-30-2002, 05:10 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •