View Poll Results: Should the radioSHARK support be native in RR?

Voters
73. You may not vote on this poll
  • Yes

    70 95.89%
  • No

    3 4.11%
Page 19 of 20 FirstFirst ... 91011121314151617181920 LastLast
Results 181 to 190 of 193

Thread: radioSHARK Plugin for RoadRunner

  1. #181
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,691
    Blog Entries
    1

    Radio Shark NOT working with Official releases of Road Runner

    I spent 2 hours trying to figure why I couldn't get Radio Shark working without the plugin, and natively in Road Runner. I was going in circles, read this entire thread, and still no luck. On a whim, I installed the Road Runner version you posted at http://www.track-a-car.com/RadioSharkPlugin/rr.zip and it worked! I tried the Official 10/30 & latest 11/12 versions of Road Runner, and it does not work with either one.

    I have the standard Road Runner.exe as well as the one I downloaded above, and named RR-RS.exe. When I run the standard RR the Radio Shark does not work. If I close RR and open the RR-RS.exe, Radio Shark workd flawlessly without ANY modifications being made between running the two versions. As mentioned, I also tried the 10/30 RR version, with no luck there either.

    Hasn't anyone else noticed this?
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  2. #182
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    on release versions of RR the radioshark should be setup in RRConfig (along with the path setting in there), is that how you're doing it ? I ask cause I clearly rememeber Evo saying that the path setting used to be something else in the test versions.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #183
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,691
    Blog Entries
    1

    No Plugin here....

    Yes, thats how I did it. I have to say I was supprised to open the RR config, and have Radio Shark as one of the options.

    This is a completely fresh install of everything on a brand new computer, and have never set up the plugin on this computer, I just installed the latest Radio Shark software, and patched the RadioShark.exe as is needed. There is no plugin directory or radioshark.ini as the old version required. That was the intent with this new computer, to not use a plugin at all, as it is now native.

    So to sum it up, the plugin has NEVER been on this computer, and the version posted above works with the standard Radio screen in the BMV2 skin, close it, open either the 10/30 or the latest 11/14 and it does not work, close em, fire up the one linked above, and again it does work.

    I do not know the version on the one above, as it does not have it on the splash screen.

    Here are the lines that the RRconfig utility put in the RR.ini. They look exactly as they are supposed to look according to the thread as using it natively.
    Code:
    radiomode=6
    RadioSharkPath=C:\Program Files\Griffin Technology\radioSHARK\radioSHARK.exe
    And yes, the path is 100% correct on my system, as I copied and pasted it into Start Menu/Run and it loaded RS fine.



    .
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  4. #184
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    if you rename it to the right name (either RR.EXE or RoadRunner.exe) it should have the right version displayed. I have not changed anything with the code for this radio, so either it's a merging issue or some other bug introduced, best thing would be to ask Evo to take a look (I don't have a card to test it with).
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  5. #185
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    see, I'm pretty sure that the latest versions use RADIATORPATH for that setting (not RadioSharkPath).. so you may just have an outdated config.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  6. #186
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,691
    Blog Entries
    1

    Radio Shark Issues

    Ok some further testing:

    The Version of RR that works, is the one posted by Evolution from 9/25. It works with the following in the rr.ini:
    radiomode=6
    RadioSharkPath=C:\Program Files\Griffin Technology\radioSHARK\radioSHARK.exe

    When I try either the 10/30 or 11/12 RR version, it does not work with the above in the ini, nor does it work with:
    radiomode=6
    RADIATORPATH =C:\Program Files\Griffin Technology\radioSHARK\radioSHARK.exe

    None of the three versions work with the Radioatorpath setting.

    I just do not want to lose all the functionality built into Road Runner since the 9/25 version (Write to file, native IGEmbedding, iGAuto switching ect ect)

    Actually the hardware is not needed to debug the program not launching, even with the Radio Shark unpluged from the USB port, when I use the 9/25 version, the Radio Shark icon loads in the system tray when the radio button is pressed. It never launches with the 2 newer versions. If you do want to test it, you can download the software at this DIRECT LINK.

    Here is the Debug log from when the RADIO button on the main menu skin is pressed if this can be of any help:

    Radio Shark Launched with Newer RR versions that RS does not work with:

    11/17/2006 5:44:03 AM: Enter Exec: False, menu.skin, , False
    11/17/2006 5:44:03 AM: Que Exec: True, menu.skin, "ONSONGSTART", False
    11/17/2006 5:44:03 AM: Executing: ONSONGSTART
    11/17/2006 5:44:03 AM: Que Exec: True, menu.skin, ONLINE, False
    11/17/2006 5:44:03 AM: Executing: NLIN
    11/17/2006 5:44:03 AM: Leave Exec: False, menu.skin, NLIN, False
    11/17/2006 5:44:05 AM: Enter Exec: False, menu.skin, "RADIO", False
    11/17/2006 5:44:05 AM: Que Exec: True, menu.skin, "RADIO", False
    11/17/2006 5:44:05 AM: Executing: RADIO
    11/17/2006 5:44:06 AM: Leave Exec: False, menu.skin, load;radio_player.skin;radio, False
    11/17/2006 5:44:06 AM: Enter Exec: False, radio_player.skin, , False

    11/17/2006 5:44:06 AM: Que Exec: True, radio_player.skin, "ONSONGSTART", False
    11/17/2006 5:44:06 AM: Executing: ONSONGSTART
    11/17/2006 5:44:06 AM: Leave Exec: False, radio_player.skin, ONSONGSTART, False

    Radio Shark launched with the 9/25 version:


    11/17/2006 5:45:23 AM: Enter Exec: False, menu.skin, , False
    11/17/2006 5:45:23 AM: Que Exec: True, menu.skin, "ONSONGSTART", False
    11/17/2006 5:45:23 AM: Executing: ONSONGSTART
    11/17/2006 5:45:23 AM: Que Exec: True, menu.skin, ONLINE, False
    11/17/2006 5:45:23 AM: Executing: NLIN
    11/17/2006 5:45:23 AM: Leave Exec: False, menu.skin, NLIN, False
    11/17/2006 5:45:27 AM: Enter Exec: False, menu.skin, "RADIO", False
    11/17/2006 5:45:27 AM: Que Exec: True, menu.skin, "RADIO", False
    11/17/2006 5:45:27 AM: Executing: RADIO
    11/17/2006 5:45:28 AM: Que Exec: True, radio_player.skin, "ONSONGSTART", False
    11/17/2006 5:45:28 AM: Executing: ONSONGSTART
    11/17/2006 5:45:28 AM: Leave Exec: False, radio_player.skin, ONSONGSTART, False
    The only thing I can see are two extra Leave/Enter Exec lines (In RED above) in the log for the RR version that is not working with the Radio Shark. I know nothing about RR code, but thought this MAY be of some significance.


    EDIT: Ok I just tried installing the Radio Shark software on my desktop PC running XP Pro (Car is running XP Home), and the same exact thing is happening, works with the 9/25 version, and not the 2 later versions of RR.



    .
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  7. #187
    Newbie
    Join Date
    Nov 2006
    Location
    Monterey Park CA
    Posts
    5
    I have been having exactly the same problem. I tried a dozen different things and searched the forums for hours over the course of 4 days, and out of desperation, I tried the plugin, which works, albeit without the newer features of course. It's mind-boggling that this bug has been there since October 8th, and absolutely no one has said a word in over 2 months, other than JohnWPB. It would be excellent to have native RadioShark support.
    ________________________________
    3 GHz P4 1GB RAM; Mini-ITX
    250 GB HDD
    Holux GPS; iGuidance 3.0
    Turtle Beach AA Roadie USB (5.1 config)
    Lilliput 629GL-70NP 7" Display

  8. #188
    Constant Bitrate deus ex machina's Avatar
    Join Date
    Mar 2006
    Posts
    136
    I played with native Radioshark support for about ten minutes before giving up and using the plugin. I was going to wait until LS releases the new version of his skin before I go messing with everything.

  9. #189
    Variable Bitrate Evolution VIII's Avatar
    Join Date
    Dec 2005
    Location
    Miami-Florida-USA
    Posts
    342
    Quote Originally Posted by JohnWPB View Post
    Ok some further testing:

    The Version of RR that works, is the one posted by Evolution from 9/25. It works with the following in the rr.ini:
    radiomode=6
    RadioSharkPath=C:\Program Files\Griffin Technology\radioSHARK\radioSHARK.exe

    When I try either the 10/30 or 11/12 RR version, it does not work with the above in the ini, nor does it work with:
    radiomode=6
    RADIATORPATH =C:\Program Files\Griffin Technology\radioSHARK\radioSHARK.exe

    None of the three versions work with the Radioatorpath setting.

    I just do not want to lose all the functionality built into Road Runner since the 9/25 version (Write to file, native IGEmbedding, iGAuto switching ect ect)

    Actually the hardware is not needed to debug the program not launching, even with the Radio Shark unpluged from the USB port, when I use the 9/25 version, the Radio Shark icon loads in the system tray when the radio button is pressed. It never launches with the 2 newer versions. If you do want to test it, you can download the software at this DIRECT LINK.

    Here is the Debug log from when the RADIO button on the main menu skin is pressed if this can be of any help:
    The only thing I can see are two extra Leave/Enter Exec lines (In RED above) in the log for the RR version that is not working with the Radio Shark. I know nothing about RR code, but thought this MAY be of some significance.


    EDIT: Ok I just tried installing the Radio Shark software on my desktop PC running XP Pro (Car is running XP Home), and the same exact thing is happening, works with the 9/25 version, and not the 2 later versions of RR.



    .

    Sorry guys for the long delay.

    Had a few minutes to test RadioShark native support problems and did not found any. I have downloaded the latest (RoadRunner Nov 12th 2006 Source Code) roadrunner source code from http://www.kompassist.co.uk/

    Here are my settings from rr.ini and these settings will work.
    Code:
    radiomode=6
    radiatorpath=C:\Program Files\Griffin Technology\radioSHARK\
    Please also check that your radioSHARK executable name is “radioSHARK.exe”

    JohnWPB
    Your problem is that you have full path to the radioSHARK.exe but you only need directory path.
    Code:
    RadioSharkPath=C:\Program Files\Griffin Technology\radioSHARK\radioSHARK.exe
    I also noticed that RRConfig.exe does not have a radioSHARK option in the dropdown box. I remember sending Guino code changes for it.

    Thanks.

  10. #190
    Newbie
    Join Date
    Jan 2007
    Posts
    9
    There is a new model of the RadioSHARK (2.0). Will this model work as well, or do I need the original?

Similar Threads

  1. Garo's Extra POI Plugin 1.0 beta 1
    By garo in forum Map Monkey
    Replies: 63
    Last Post: 01-18-2007, 12:32 PM
  2. radioShark am/fm usb adapter with timeshifting
    By kickerks80 in forum Car Audio
    Replies: 13
    Last Post: 10-04-2004, 04:08 PM
  3. Help with winXP/hibernate/LCD plugin
    By dave123456 in forum Software & Software Development
    Replies: 0
    Last Post: 10-17-2002, 08:17 PM
  4. Winamp LCD display plugin / IRMan plugin - together?
    By Jarrod in forum Software & Software Development
    Replies: 9
    Last Post: 06-03-2002, 05:39 AM
  5. Resumer Winamp plugin..works with MPC, too
    By Tony S in forum Software & Software Development
    Replies: 7
    Last Post: 03-30-2002, 05:10 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •