Page 22 of 91 FirstFirst ... 12131415161718192021222324252627282930313272 ... LastLast
Results 211 to 220 of 910

Thread: RRMedia Plugin by Blue ZX3 [v1.3.0 Released]

  1. #211
    FLAC
    Join Date
    Jun 2002
    Location
    Virginia
    Posts
    1,789
    Quote Originally Posted by tundra2000 View Post

    anyway, question for ya. after i hit the search button, type sometihng in, and hit enter, i get a bunch of results in some random order. the sort button usually works, but it is not working for me for search results. and keep in mind im using DFX 4.0. thanks if you can help me!
    The search results are not a playlist and can't be sorted. What you can do once you have your search results is hit manage playlist and then load the playlist that says [search results]. Then your search results will be in a playlist just like any other playlist and can easily be sorted. Note that you can control how the search results appear by hitting "sort by" before doing the search. This will tell it how to display the results, sorted by album, artist, etc. Again, though, you can't sort the search results once they exist unless you load them as a playlist.

  2. #212
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,170
    Blog Entries
    52
    Quote Originally Posted by MGD View Post

    EDIT Also, I did find the Date Format change does not work.
    Thanks
    Manny
    BTW. Donation is made. Thanks
    noticed this too.

    Something else that is super unimportant but the perfectionist you are might care about is the fact that when i have a disk playing then shut down RR the list label goes back to -- instead of continuing with the same disk number at start. As i said this is completely unimportant as the correct playlist resumes play and the VPL number resumes.. but disk number resets none the less.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  3. #213
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Quote Originally Posted by MGD
    Blue, nice work on the plugin. Boy, do I have a ball with it......but
    is there a way to inplement a way of error checking whe you add a song to a disk?
    I have everything working fine but when I add the same SONG by the same ARTIST it will just add it. So,
    if you try to add a song to a disk, have your plugin check for the artist and song.
    If the song by the same artist already exist on the same disk, have a screen pop up that says "That song by that artist already exists! Then OK to cancel.
    If the same song by a differnet artist is NOT on that disk, have a pop up come up that says,
    "This song by ARTIST already exists, would you like to add this song by "The other Artist" to the disk?
    Because as of right now, I can add the same song by the same artist to the same disk as many times I want to.
    Please have a look at this.
    This is a good idea and will add to the low priority todo list.

    Quote Originally Posted by MGD
    EDIT Also, I did find the Date Format change does not work.
    Thanks
    Manny
    BTW. Donation is made. Thanks
    I'll check this out, might be a typo in the skin cmds or in the code.

    Quote Originally Posted by tundra2000 View Post
    problem still not addressed yet. i dont mean to be a nuisance, but i just hadnt heard from you yet on this. again i have to repeat, excellent work, this plugin seriously pushes RR to the best FE without a doubt. great work, im implementing this into my new skin!
    Always like reading such great comments, sorry about getting back to you. I still have a lot on the plate right now and take one thing a time. See my reply to kbreeden reply

    Quote Originally Posted by Ramanator View Post
    Blue, Dont know what changed, but I just ran a rescan & my whole (50k) music library loaded. It loaded in just over 6 mins. according to the db screen, So now you can stop over my bug. Props to you for this powerful, feature rich, media plug-in. Also thanks for the "one-on-one" tring to squash this bug.
    No problem! Just glad it stared to work for you.

    Quote Originally Posted by kbreeden View Post
    The search results are not a playlist and can't be sorted. What you can do once you have your search results is hit manage playlist and then load the playlist that says [search results]. Then your search results will be in a playlist just like any other playlist and can easily be sorted. Note that you can control how the search results appear by hitting "sort by" before doing the search. This will tell it how to display the results, sorted by album, artist, etc. Again, though, you can't sort the search results once they exist unless you load them as a playlist.
    This is actually a bug... I do know that at one time it was working, so appearenty its now broken and will make the to fix list...

    Quote Originally Posted by Sonicxtacy02 View Post
    noticed this too.

    Something else that is super unimportant but the perfectionist you are might care about is the fact that when i have a disk playing then shut down RR the list label goes back to -- instead of continuing with the same disk number at start. As i said this is completely unimportant as the correct playlist resumes play and the VPL number resumes.. but disk number resets none the less.
    Again, this was fixed and working but i'll take a look and see if I broke this too..


    Still working on builder changes. Have only done a little work on it the last two days due body demanding some sleep time, not easy to code when in a zombie state...lol
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  4. #214
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    I have added a todo list in the first post.

    For anyone that has made a donation,thanks and If you could PM mer with you real name as that way I can add you to the donators list because I don't know you other than your forum name...Thanks.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  5. #215
    Maximum Bitrate tundra2000's Avatar
    Join Date
    Mar 2006
    Location
    Houston, TX
    Posts
    551
    Quote Originally Posted by kbreeden View Post
    Note that you can control how the search results appear by hitting "sort by" before doing the search. This will tell it how to display the results, sorted by album, artist, etc.

    that part doesnt work. however, Blue says taht not being able to sort the results is a bug? i hope it is, because thats really the only thing i can find wrong with this plugin.


    >>oo now that i tihnk of it, i have been having trouble with the "RM_!Select" command. it works fine on its own, but if i string it together with a bunch of commands, the command isnt activated for another 5 or 6 seconds... really weird. on its own tho, it works almost instantly. same deal for RM_Select too.

  6. #216
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    There is only one reason that I could see it slightly hanging, but that shouldn't matter what other cmds are stringed together...

    An example cmd string that you are trying to execute would be help full.

    I would really like to see examples when you guys are having issues like this, just tell me that your doing this and are having some issue doesn't help me at all...
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  7. #217
    Maximum Bitrate tundra2000's Avatar
    Join Date
    Mar 2006
    Location
    Houston, TX
    Posts
    551
    Quote Originally Posted by Blue ZX3 View Post
    There is only one reason that I could see it slightly hanging, but that shouldn't matter what other cmds are stringed together...

    An example cmd string that you are trying to execute would be help full.

    I would really like to see examples when you guys are having issues like this, just tell me that your doing this and are having some issue doesn't help me at all...
    sorry, i know i shoulda posted code...

    Code:
    "SETVAR;LibraryORBurner;0||SAVETOSKIN;LoB;0||SaveWhileGo||RM_!SELECT||menu;audio_player2.skin"
    ^^SaveWhileGo is a bunch of SETVARs.


    ----running that code will execute everything and pop up my audio_player2.skin, but it will not execute the RM_!SELECT command until like 4 seconds later. however, if i replace that whole line of code with just RM_!SELECT, it takes action instantly.

  8. #218
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    RRMedia cmd & notes typo's

    Song date formate cmds

    "RM_SetSongDateUSA"
    "RM_SetSongDateDefault"
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  9. #219
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Quote Originally Posted by tundra2000 View Post
    sorry, i know i shoulda posted code...

    ^^SaveWhileGo is a bunch of SETVARs.

    ----running that code will execute everything and pop up my audio_player2.skin, but it will not execute the RM_!SELECT command until like 4 seconds later. however, if i replace that whole line of code with just RM_!SELECT, it takes action instantly.
    Bunch of setvar's...like about how many we talking here, not that I would really think or see why it would be problem.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  10. #220
    Maximum Bitrate tundra2000's Avatar
    Join Date
    Mar 2006
    Location
    Houston, TX
    Posts
    551
    Quote Originally Posted by Blue ZX3 View Post
    Bunch of setvar's...like about how many we talking here, not that I would really think or see why it would be problem.
    like 5.... i really dont get it. shouldnt be a prob. ill try takin out commands until it works, then ill post again.


    UPDATE: this code below works, but i took off the MENU command.

    Code:
    "SETVAR;LibraryORBurner;0||SAVETOSKIN;LoB;0||SaveWhileGo||RM_!SELECT"
    ---so i can play whatever's selected in the list, but after it starts playing, i want to pop up a new screen. thats where im having the trouble. Am i the only one who cannot string RM_!Select and a MENU (pop up screen) command together?

Similar Threads

  1. Is there an Alpine blue for RR?
    By turbosx in forum RR Skins
    Replies: 10
    Last Post: 06-01-2008, 03:35 AM
  2. problems with navigation in streetdeck
    By customaudioman in forum StreetDeck
    Replies: 3
    Last Post: 01-25-2008, 12:46 PM
  3. RR 04-08-05 .. BETA Base Plugin ...
    By guino in forum Road Runner
    Replies: 37
    Last Post: 04-10-2005, 11:39 PM
  4. Does Any Winamp Plugin Work With Media Car ?
    By ccsnet in forum MediaCar
    Replies: 4
    Last Post: 11-23-2003, 01:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •