Page 23 of 91 FirstFirst ... 13141516171819202122232425262728293031323373 ... LastLast
Results 221 to 230 of 910

Thread: RRMedia Plugin by Blue ZX3 [v1.3.0 Released]

  1. #221
    Newbie
    Join Date
    Feb 2008
    Posts
    37
    Blue, I tried an experiment using an external drive as my media source. Everything imports fine. No issue there nor with playing a particular album that has been selected. But I am receiving this error upon selecting an album to play.
    .

    I verified all the files within the album are indeed in MP3 format. I also verified Winamp associated with the external drive. I assumed this was an issue of using an external drive location so I reverted back to using the internal drive changing the setting in rrconfig. Same issue. I cleared all virtual disks. Rescan..same prob. Manually located and removed the rrmediadb and the restoredisk file. Rescan...no help.

    Any ideas?

  2. #222
    Newbie
    Join Date
    Feb 2008
    Posts
    37
    Update...Removed winamp and reinstalled no help. Reinstalled Digitalfx 4.0 and the issue was fixed. I repeated the steps of moving to the external drive and again back to square one getting the error message. I do see the rrmediadb file moves itself to the new location (in this case the external drive) upon rescan. Is there a file that needs manually moved/removed when moving to a different music folder location?

  3. #223
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    That would be a script that John wrote to make the BBA work. That isn't associated with my plugin at all...

    The database is built at whatever your musicpath is set at in RR. It didn't move your db, it created a new because you pointed to a location that didn't have a RRMediadb.db file.

    Every path in the db is relative to your music path. This was done so that if you mirror your music collection from the house to the car(as most do), you could actually build the db in the house and just sync over the db file. Only the path after your music path is stored in the db.

    Example has a mirrored music collection between the house and car:

    House musicpath might be like C:\Doc & Settings\user\My Documents\My Music\

    Car music path might be like D:\Music\

    Even though those are to totally different paths, you could still use the same db file becuause the db path is the remaining portion of the path to the file.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  4. #224
    x10
    x10 is offline
    Constant Bitrate x10's Avatar
    Join Date
    Mar 2004
    Location
    Pittsburgh, PA
    Posts
    152
    Blue, just thought I would let you know....I found the file that was causing the DB Scan to fail...it is a single MP3 and it actually plays in winamp fine...

    I can send you the file so that you can check it out, if that will help at all....

  5. #225
    Constant Bitrate slvrsol's Avatar
    Join Date
    Mar 2007
    Posts
    148
    hey blue.. great job on the plugin.

    I am currently trying to import the song ratings from the popularmeter frame used by windows so I don't have to rate songs again. Looks like I have to do more than just create the rate.in_ file. How can I send a message to update the database? thanks!

  6. #226
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    While i'm still updating the builder, it probably be the best time to see why that file was giving you problems. But watch...it will just be my luck that it won't have any issue with that file on my comp...lol

    Go on ahead and send it to my addy (yahoo, just add @yahoo.com)in my profile..
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  7. #227
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Quote Originally Posted by slvrsol View Post
    hey blue.. great job on the plugin.

    I am currently trying to import the song ratings from the popularmeter frame used by windows so I don't have to rate songs again. Looks like I have to do more than just create the rate.in_ file. How can I send a message to update the database? thanks!
    Thanks, the rate.in_ file is simply a backup of ratings, just in case one goes and deletes the db file, upon next scan it will use that file to re-add the ratings back into the db. So right now there isn't a really easy way to do this but sometime down the road, I am planning on making a small ratings import wizard that will handle a few different ways that files have been rated and transfer them over to the db.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  8. #228
    x10
    x10 is offline
    Constant Bitrate x10's Avatar
    Join Date
    Mar 2004
    Location
    Pittsburgh, PA
    Posts
    152
    Quote Originally Posted by Blue ZX3 View Post
    While i'm still updating the builder, it probably be the best time to see why that file was giving you problems. But watch...it will just be my luck that it won't have any issue with that file on my comp...lol

    Go on ahead and send it to my addy (yahoo, just add @yahoo.com)in my profile..
    email sent out....with the file...let me know if you dont receive it...

  9. #229
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Boy...did I ever receive it!! I think that there might be some gremlins living in that file. I put it as the first file in the scan and WHAM! They started to attach....

    Thanks BTW...
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  10. #230
    Newbie ccwild's Avatar
    Join Date
    Apr 2008
    Location
    Middle GA
    Posts
    52
    To anybody having issues with the db failing during scanning or not adding files after scan here is is what worked for me.

    First I had two seperate files in my library that were causing the builder to stop running, i.e. freeze. these files, I found, had no data in the tag fields at all... after using a tag editor and renamer on 10,000+ files, these two slipped by and would stop the databuild everytime.

    If you have such a file and don't have a tageditor, just use windows...left click properties> details., and add anything into any field, i.e. artist, album, year, etc...

    The second issue was that my build would complete but if a certain file or group of files were included in that certain scan, the build would post completed but the songs (all of the included) would not be added.

    The causes were either duplicates in the selected files for scanning, excessively long file names (not sure of the character count), or special characters in the file name. I'm not sure as to what characters, I justed removed any $, @, :, <, > and such from the filenames.

    I still haven't found the reason for a COM error that I'm receiving. This error allows for the build to continue, just at a snail's pace from the rest of the scan.

    So if you are having problems with the browser not working after scan, try scanning a smaller portion of your library and checking the RRmediaDb.db file and making sure that it is getting larger with every scan. If not, check that certain group of files for the issues stated above.

    Hope that helps.....

Similar Threads

  1. Is there an Alpine blue for RR?
    By turbosx in forum RR Skins
    Replies: 10
    Last Post: 06-01-2008, 03:35 AM
  2. problems with navigation in streetdeck
    By customaudioman in forum StreetDeck
    Replies: 3
    Last Post: 01-25-2008, 12:46 PM
  3. RR 04-08-05 .. BETA Base Plugin ...
    By guino in forum Road Runner
    Replies: 37
    Last Post: 04-10-2005, 11:39 PM
  4. Does Any Winamp Plugin Work With Media Car ?
    By ccsnet in forum MediaCar
    Replies: 4
    Last Post: 11-23-2003, 01:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •