Page 25 of 91 FirstFirst ... 15161718192021222324252627282930313233343575 ... LastLast
Results 241 to 250 of 910

Thread: RRMedia Plugin by Blue ZX3 [v1.3.0 Released]

  1. #241
    Newbie
    Join Date
    Feb 2008
    Posts
    37
    Blue, I changed directories again to show the 2 rrmediadb that are created. Here's a pic


  2. #242
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,078
    Yes, it is working 100% correctly, there only need to be one place for the db and that is at your musicpath location. You change your music path, you change where there should be a db file.

    I am confused as to why your trying to point this out to me?
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  3. #243
    Newbie
    Join Date
    Feb 2008
    Posts
    37
    Ah, perhaps I misunderstand, when rebuilding the db is it not supposed to remove the old database or at least move it to the new location? Until I delete the old file manually, I get the CheckforMP3.exe error. Again, I must be misunderstanding how the rescan works.

  4. #244
    Newbie
    Join Date
    Feb 2008
    Posts
    37
    If the rescan only builds a new db in the appropriate folder and leaves the original alone full intact then I have another issue to examine on my end-why is it looking at both or looking at the original database instaed of the new. humn...think I'll go play with that idea a bit.

  5. #245
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,078
    "CheckforMP3.exe" is NOT part of my plugin. Rescanning does a combination of three things: remove missing media records from db, check for updated/changed files (ie upated tags in a file), and new files that have not been imported yet all on the original db file from the origanal scan, unless you change your musicpath, then ya its going make another db file as one doesn't yet exists at the path.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  6. #246
    Newbie
    Join Date
    Feb 2008
    Posts
    37
    Blue, it appears the CheckForMP3.exe located in the 'scripts' folder was/became corrupted. I replaced the .exe with a known working.

    Thanks for your help.

  7. #247
    FLAC Sal R.'s Avatar
    Join Date
    Aug 2006
    Location
    Sun Diego
    Posts
    1,448
    I don't know if this was intended or not, but RM_ADD1 does not "unload" a "loaded" disc like the other commands. Granted, it appends the playlist, but the "DISC" playing does not match the playlist.

    Also, when using "RM_Sel2Disk" at a file/song level in RM_MEDIA.skin, it doesn't update the the "DISC" song count label as seen in RM_ADD2DISK.skin.
    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

  8. #248
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,078
    Quote Originally Posted by Sal R.
    I don't know if this was intended or not, but RM_ADD1 does not "unload" a "loaded" disc like the other commands. Granted, it appends the playlist, but the "DISC" playing does not match the playlist.
    The RM_ADD has the logic that if you have a disk loaded it will add that selection to both the current PL and to the disk, otherwise just to the current PL.

    Quote Originally Posted by Sal R.
    Also, when using "RM_Sel2Disk" at a file/song level in RM_MEDIA.skin, it doesn't update the the "DISC" song count label as seen in RM_ADD2DISK.skin or add the song to an empty "DISC."
    This one I'm not sure about but will check on...
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  9. #249
    Constant Bitrate Stealth915's Avatar
    Join Date
    Apr 2004
    Location
    Bay Area, CA
    Posts
    137
    I figure I should post this here instead of the DFX thread. An update on my problem - I'm unable to get the database built. Originally I was getting this error while building the database:



    More recently I've tried building the DB with only 1 MP3 in my music directory, but still no luck. I did notice that my ID3v1 tag and ID3v2 tag was different on the same MP3 file. When I clear one of the two, the popup box during DB building goes away. However, I'm still not getting any entries in my database after building.

    After poking around the DB I got to this when going to Browse Mode > Recently Added. I still don't get anything when Browsing by Artist/Album/Genre and the DB file is blank.


    The 1 file I have in my Music dir is:

    RR Music Path: D:\Music\
    Filename: Akon.mp3
    ID3 tag (tried on both v1 and v2):
    - Title: Ghetto
    - Artist: Akon
    - Album: Konvicted
    - Year: 1998
    - Genre: Other
    - Comment: [left blank]

    Does this plugin scan both ID3v1 and ID3v2 tags? Is there a preference for any tag? Any help would be appreciated. I've spent a better part of this weekend trying to figure this out.

    I don't know if this matters, but I have "Prefer ID3v2 Tags", Show ID3 Playlist, Show ID3 Browse, and Lazy ID3 Load checked in my RRConfig.
    2004 Mazda3 Carputer Worklog - Update 5/17/11: Carputer 2.0 Hardware Selection

  10. #250
    FLAC Sal R.'s Avatar
    Join Date
    Aug 2006
    Location
    Sun Diego
    Posts
    1,448
    Quote Originally Posted by Blue ZX3 View Post
    The RM_ADD has the logic that if you have a disk loaded it will add that selection to both the current PL and to the disk, otherwise just to the current PL.
    Yeah, RM_ADD1 is not updating the loaded disc playlist nor it is updating the song count.

    In addition, RMA_ADD1 is not adding songs at a file/song level.

    I am using the beta you sent me.
    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

Similar Threads

  1. Is there an Alpine blue for RR?
    By turbosx in forum RR Skins
    Replies: 10
    Last Post: 06-01-2008, 03:35 AM
  2. problems with navigation in streetdeck
    By customaudioman in forum StreetDeck
    Replies: 3
    Last Post: 01-25-2008, 12:46 PM
  3. RR 04-08-05 .. BETA Base Plugin ...
    By guino in forum Road Runner
    Replies: 37
    Last Post: 04-10-2005, 11:39 PM
  4. Does Any Winamp Plugin Work With Media Car ?
    By ccsnet in forum MediaCar
    Replies: 4
    Last Post: 11-23-2003, 01:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •