Page 41 of 91 FirstFirst ... 313233343536373839404142434445464748495051 ... LastLast
Results 401 to 410 of 910

Thread: RRMedia Plugin by Blue ZX3 [v1.3.0 Released]

  1. #401
    Maximum Bitrate nasa's Avatar
    Join Date
    Aug 2006
    Location
    PA
    Posts
    696
    Hey Stealth,

    My system is setup similarly.... And I got the same error messages you did after blowing away my database. After reading your post, I should have noted earlier that my folder structure is like yours --

    e:\music
    e:\music\abcde
    e:\music\fghij
    e:\music\klmno
    .....

    There are no audio files in e:\music or the next level of folders. Are there audio files in your top level folder (I am guessing not)?

  2. #402
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Sorry bout not getting back to ya...

    I will also add to the next update, when the builder says invalid path, to put what it "thinks" or what it is trying to use as the music path. The path it is trying to use may be infact correct and maybe a bug further down the line but I don't think that check is right at the beginning..

    See first post for a amended 1.1.0.1 builder (RMBuilder v1.1.0.1.zip)
    *Before running newer builder, add these two lines to the "\RMDatabase\Support Filesbuilder.ini" file in your RR folder.

    [Debug]
    Status=True

    If you still have same problem, post what the path its trying to use from the builder_debug.txt.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  3. #403
    Maximum Bitrate nasa's Avatar
    Join Date
    Aug 2006
    Location
    PA
    Posts
    696
    Blue,

    I tried out the new .exe file -- same problem. However, it's not the path. Looking at the debug log -- the path is correct. The problem, it turns out, is what I started to suggest in my last post. If there's not a audio file (tested with only a mp3) in the root directory the program will crash with a path error.... Placing a mp3 file in the root directory allowed the database to be created without issue.

  4. #404
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Noted, Will check that issue here as well...
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  5. #405
    FLAC Sal R.'s Avatar
    Join Date
    Aug 2006
    Location
    Sun Diego
    Posts
    1,448
    Having a bit of trouble w/ the VPL's.

    Using the "RM_SvdLST+/-" command loads the playlist, but the pathname to the music files points to: "C:\Program Files\Road Runner\RMDatabase\Support Files\" then the artist & filename, not the musicpath folder.

    Did I miss a setting or something?
    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

  6. #406
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Hehe

    No, I did notice this issue some time ago, but for the life of me couldn't figure out where it was getting that fake musicpath at and only saw it happen here or there so I was really lost as to where to even begin to look code wise.

    The good news is that I do now know where/why its happening. This will also be looked at and another RMediaDb.exe patch will be posted in the first post when i have chance to check both of these last two recent problems.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  7. #407
    FLAC Sal R.'s Avatar
    Join Date
    Aug 2006
    Location
    Sun Diego
    Posts
    1,448
    Awesome. I'm not insane afterall...mostly...
    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

  8. #408
    FLAC Sal R.'s Avatar
    Join Date
    Aug 2006
    Location
    Sun Diego
    Posts
    1,448
    Here's some more bugs I found:
    - RM_ADD1 not working for "Albums"
    - rm_cleardisk$DiskControl$ a currently loaded disk will not update the indicator status for that disk (stays "on" even after the disk is cleared).
    - > Cured this by adding the following command BYIND;RM_DiskLoaded$DiskControl$;<<RM_UnloadDisk to rm_cleardisk$DiskControl$||ESC

    - Using RM_Sel2Disk w/ Browse by "SONG" mode will add the song to the disk, but not update the song count for that disk under diskchanger.skin.
    - RM_PL2DiskAdd||RM_PLAYLIST2DISK using a playlist will add the songs to the disk, but not update the song count under diskchanger.skin.
    - RM_DiskRemoveSong is not removing a song from the current playing disk. Removes it from the playlist, but doesn't update the corresponding loaded disk.
    - When you have multiple albums of the same name (i.e. Greatest Hits in Album view mode) it creates multiple entries each w/ their corresponding album cover (which is correct). However, browsing into any one of them will pull up all the songs under "Greatest Hits."

    More to come as I try and break your plugin...



    If I haven't said it yet, man this is an awesome plugin...
    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

  9. #409
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    K, just for that Sal... that patch now looks to be pushed to a further date...

    I can't work on my 'GPS Events' plugin with these errors keep pop'n up.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  10. #410
    Constant Bitrate Stealth915's Avatar
    Join Date
    Apr 2004
    Location
    Bay Area, CA
    Posts
    137
    Quote Originally Posted by nasa View Post
    Blue,

    I tried out the new .exe file -- same problem. However, it's not the path. Looking at the debug log -- the path is correct. The problem, it turns out, is what I started to suggest in my last post. If there's not a audio file (tested with only a mp3) in the root directory the program will crash with a path error.... Placing a mp3 file in the root directory allowed the database to be created without issue.
    I don't think the audio file is the only source of this bug. My music is organized

    D:\Music
    D:\Music\new <-- random misc mp3 files and folders
    D:\Music\Sorted\[Artist]\[Album]\[Title] (with no music files in the "Sorted" folder)

    the DB would build if I set the path to D:\Music\Sorted but wouldn't if I set it to D:\Music. I haven't tried the new builder yet, but I'll see if I can get a chance to use it later today.
    2004 Mazda3 Carputer Worklog - Update 5/17/11: Carputer 2.0 Hardware Selection

Similar Threads

  1. Is there an Alpine blue for RR?
    By turbosx in forum RR Skins
    Replies: 10
    Last Post: 06-01-2008, 03:35 AM
  2. problems with navigation in streetdeck
    By customaudioman in forum StreetDeck
    Replies: 3
    Last Post: 01-25-2008, 12:46 PM
  3. RR 04-08-05 .. BETA Base Plugin ...
    By guino in forum Road Runner
    Replies: 37
    Last Post: 04-10-2005, 11:39 PM
  4. Does Any Winamp Plugin Work With Media Car ?
    By ccsnet in forum MediaCar
    Replies: 4
    Last Post: 11-23-2003, 01:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •