Page 8 of 48 FirstFirst 123456789101112131415161718 ... LastLast
Results 71 to 80 of 478

Thread: RRFusion- My Fusion Brain plugin for RR

  1. #71
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    The last modified date on roadrunner.exe is December, 13 2007. That seems a bit old to me now that I look at it. It was installed with the installer in early May iirc.

    Edit: Just noticed there was an update in late May of 2008. I'm going to load up that and see if things start working.

  2. #72
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    Updated Roadrunner didn't change anything, still the same behavior.

    I thought I should point out that it's not consistent. For example, if I resume from hibernate and go into the music library browser it toggles, it does not toggle when I go back to the main screen and after that first time it wont toggle when I go back into the music library. Similar behavior occurs for other screens with the exception being the GPS, after a couple directions are spoken it consistently toggles.

    It's been raining today so I was unable to test the 2nd computer, hopefully the weather is nicer tomorrow. I should also mention that running a instance of Fusion Control Centre with both outputs set to on produces no problems as I switch through RR screens.

  3. #73
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,170
    Blog Entries
    52
    FCC wouldnt cause any problems with RR because its not actively communicating with RR. I'm anxious to see if you have similar problems on a second PC.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  4. #74
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    Just got done testing things out on a laptop. I'm not sure whether it's good or bad news but the problem didn't exist on the alternate computer, granted it didn't have iguidance or any peripherals connected.

    This seems to point the finger towards my carputer hardware which I will now list. I've played with all kinds of settings though, re-registered the .dll, moved the x,rrfusion call to the top of menu.skin, same goes for the definitions in skin.ini.

    On another note, I tried adding the save/resume commands as mentioned earlier in the thread. It didn't seem to want to work. Without the commands the brain fires up on resume from hibernate as it was before hibernation, with the commands in place it always starts up with all outputs off no matter what I do.

    I'm not sure what my next course of action should be now, I guess reinstalling RR would be the next logical step but that's only assuming the problem doesn't lie somewhere within the skin. I also tried turning off ilists just for fun, made no difference.

    If this was consistent I think it would be easier to figure out, it's the randomness that kills me. After I did one of the little changes (moved skin.ini commands to the top) it appeared to be working for a while, I successfully switched between gps, video, first level of audio browser, and to other main screens without problems, then I tried the cover browser and it toggled off and on, it then proceeded to do it again when I tried to go back into the GPS.

    System specs:
    Motherboard: JetWay J7F2WE1G5D-OC-LF
    Memory: CORSAIR ValueSelect 1GB PC2 4200
    Sound: SoundBlaster Audigy 2 w/ KX Drivers
    HDD: Toshiba 120gb 2.5" 5200rpm
    Screen: 7" Lilliput Touchscreen
    GPS: Globalsat BU-353
    Wifi: EDIMAX EW-7318USG
    DVD: Pioneer DVR-K06 Slot-Load External
    Keyboard: MadCatz PS2 USB Key
    PSU: M2-ATX

    I really appreciate all you've been doing to try and help Sonic, just one of the many reasons why I love coming to these boards.

  5. #75
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,170
    Blog Entries
    52
    Quote Originally Posted by mezz64 View Post
    Just got done testing things out on a laptop. I'm not sure whether it's good or bad news but the problem didn't exist on the alternate computer, granted it didn't have iguidance or any peripherals connected.

    This seems to point the finger towards my carputer hardware which I will now list. I've played with all kinds of settings though, re-registered the .dll, moved the x,rrfusion call to the top of menu.skin, same goes for the definitions in skin.ini.

    On another note, I tried adding the save/resume commands as mentioned earlier in the thread. It didn't seem to want to work. Without the commands the brain fires up on resume from hibernate as it was before hibernation, with the commands in place it always starts up with all outputs off no matter what I do.

    I'm not sure what my next course of action should be now, I guess reinstalling RR would be the next logical step but that's only assuming the problem doesn't lie somewhere within the skin. I also tried turning off ilists just for fun, made no difference.

    If this was consistent I think it would be easier to figure out, it's the randomness that kills me. After I did one of the little changes (moved skin.ini commands to the top) it appeared to be working for a while, I successfully switched between gps, video, first level of audio browser, and to other main screens without problems, then I tried the cover browser and it toggled off and on, it then proceeded to do it again when I tried to go back into the GPS.

    System specs:
    Motherboard: JetWay J7F2WE1G5D-OC-LF
    Memory: CORSAIR ValueSelect 1GB PC2 4200
    Sound: SoundBlaster Audigy 2 w/ KX Drivers
    HDD: Toshiba 120gb 2.5" 5200rpm
    Screen: 7" Lilliput Touchscreen
    GPS: Globalsat BU-353
    Wifi: EDIMAX EW-7318USG
    DVD: Pioneer DVR-K06 Slot-Load External
    Keyboard: MadCatz PS2 USB Key
    PSU: M2-ATX

    I really appreciate all you've been doing to try and help Sonic, just one of the many reasons why I love coming to these boards.
    when did you purchase your FB.. perhaps a different firmware? i was mistaken in the fact that the FB with default outputs to off at resume. If you have the FB on a constant power source it will keep the settings thru hibernation/resume. It will only kill the settings upon the next close/restart of RR. Thats where the SAVE/RESUME commands would come in handy for you. I probably know the reason for the commands not working because they stopped working for me awhile til i figured out the .txt file the output data is written to is set to read-only. Open your Roadrunner folder and look for the file rrfusion.txt. If you dont see it then you have to enable the ability to show hidden files (tools on toolbar, folder options, view tab, click show hidden files and folders). Right-click on rrfusion.txt and click properties. If the read-only attribute is checked either uncheck it or just delete the file. That will solve the problem. FBSAVE wasnt able to save any data to file, so FBRESUME just resumed with all outputs off.

    as for the random issue i'd like to have you check one more thing ( and i dont know why i didnt think of this before). Enable the debug log for road runner (rr.ini DEBUG=TRUE), then run RR until the problem occurs again. Then check debug.txt to see if one of the RRFUSION output toggle commands is run right when the problem starts(look for DIGITALOUT0TOGGLE). If so, then its something in my plugin, if not then it could be driver issues, firmware issues, driver incompatibility, or something beyond my control.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  6. #76
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    I've got a first batch FB, it doesn't have the latest firmware.

    The read-only thing makes sense for the same/resume commands, the FB is not on a constant power source though, it turns on/off with the computer.

    I'll try to do the RR debug on my lunch break today and report back with results.

  7. #77
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    Did the debug, I see no rrfusion events occurring after I change screens so it seems as if everything is great on your end and something is conflicting on mine.

    Here is the log from the point when I load rrfusion.skin on. Are the outputs being turned on correctly, seems like there are a lot of false commands.
    Code:
    7/2/2008 12:09:26 PM: Executing: LOAD;rrfusion.skin
    7/2/2008 12:09:27 PM: Leave Exec: False, menu.skin, LOAD;rrfusion.skin, False
    7/2/2008 12:09:29 PM: Enter Exec: False, rrfusion.skin, "DIGITALOUT0TOGGLE", False
    7/2/2008 12:09:29 PM: Que Exec: True, rrfusion.skin, "DIGITALOUT0TOGGLE", False
    7/2/2008 12:09:29 PM: Leave Exec: False, rrfusion.skin, DIGITALOUT0TOGGLE, False
    7/2/2008 12:09:30 PM: Enter Exec: False, rrfusion.skin, "DIGITALOUT2TOGGLE", False
    7/2/2008 12:09:30 PM: Que Exec: True, rrfusion.skin, "DIGITALOUT2TOGGLE", False
    7/2/2008 12:09:30 PM: Leave Exec: False, rrfusion.skin, DIGITALOUT2TOGGLE, False
    7/2/2008 12:09:33 PM: Enter Exec: False, rrfusion.skin, "EXIT", False
    7/2/2008 12:09:33 PM: Que Exec: True, rrfusion.skin, "EXIT", False
    7/2/2008 12:09:34 PM: Executing: EXIT
    7/2/2008 12:09:34 PM: Leave Exec: False, rrfusion.skin, load;menu.skin, False
    7/2/2008 12:09:37 PM: Enter Exec: False, menu.skin, "LOAD;alt_menu_cont.skin", False
    7/2/2008 12:09:37 PM: Que Exec: True, menu.skin, "LOAD;alt_menu_cont.skin", False
    7/2/2008 12:09:37 PM: Executing: LOAD;alt_menu_cont.skin
    7/2/2008 12:09:39 PM: Leave Exec: False, menu.skin, LOAD;alt_menu_cont.skin, False
    7/2/2008 12:09:41 PM: Enter Exec: False, alt_menu_cont.skin, "MAIN", False
    7/2/2008 12:09:41 PM: Que Exec: True, alt_menu_cont.skin, "MAIN", False
    7/2/2008 12:09:41 PM: Executing: MAIN
    7/2/2008 12:09:41 PM: Leave Exec: False, alt_menu_cont.skin, load;menu.skin, False
    7/2/2008 12:09:42 PM: Enter Exec: False, menu.skin, "MAINBT3", False
    7/2/2008 12:09:42 PM: Que Exec: True, menu.skin, "MAINBT3", False
    7/2/2008 12:09:42 PM: Executing: BYVAR;MAINBUTTON3;AP01<<AP02<<AP03<<AP04<<AP05<<AP06<<AP07<<AP08<<AP09<<AP10<<AP11<<AP12<<AP13<<AP14<<AP15<<AP16<<AP17<<AP18<<AP19<<AP20<<AP21<<AP22<<AP23<<AP24<<AP25<<AP26<<AP27<<AP28<<AP29<<AP30<<AP31<<AP32<<AP33<<AP34<<AP35<<AP36<<AP37<<AP38<<AP39<<AP40<<AP41<<AP42<<AP43<<AP44<<AP45<<AP46<<AP47<<AP48<<AP49<<AP50<<AP51<<AP52<<AP53<<AP54<<AP55<<AP56<<AP57<<AP58<<AP59<<AP60<<AP61<<AP62<<AP63<<AP64<<AP65<<AP66<<AP67<<AP68<<AP69<<AP70<<AP71
    7/2/2008 12:09:42 PM: Que Exec: True, menu.skin, "AP03", False
    7/2/2008 12:09:42 PM: Executing:  
    7/2/2008 12:09:42 PM: Que Exec: True, menu.skin, "GPS3||FSDEF_LOAD", False
    7/2/2008 12:09:42 PM: Executing: GPS
    7/2/2008 12:09:43 PM: Enter Exec: True, external_gps.skin, , False
    7/2/2008 12:09:44 PM: Shell: "C:\Program Files\iNav\iGuidance\iGuidanceUMPC.exe" nowarning
    7/2/2008 12:09:44 PM: Que Exec: True, external_gps.skin, "RUNQ;LSTOOLS\SB2.9_IG3\iGuidance\IGCONTROL2\IGCONTROL2.exe||SETVAR;isigopen;1||SAVETOSKIN;isigopen;1", False
    7/2/2008 12:09:44 PM: Executing: RUNQ;LSTOOLS\SB2.9_IG3\iGuidance\IGCONTROL2\IGCONTROL2.exe
    7/2/2008 12:09:44 PM: Shell: "LSTOOLS\SB2.9_IG3\iGuidance\IGCONTROL2\IGCONTROL2.exe"
    7/2/2008 12:09:44 PM: Que Exec: True, external_gps.skin, "SETVAR;isigopen;1||SAVETOSKIN;isigopen;1", False
    7/2/2008 12:09:45 PM: Executing: SETVAR;isigopen;1
    7/2/2008 12:09:45 PM: Que Exec: True, external_gps.skin, "SAVETOSKIN;isigopen;1", False
    7/2/2008 12:09:45 PM: Executing: SAVETOSKIN;isigopen;1
    7/2/2008 12:09:45 PM: Que Exec: True, external_gps.skin, "FSDEF_LOAD", False
    7/2/2008 12:09:45 PM: Executing:  
    7/2/2008 12:09:45 PM: Que Exec: True, external_gps.skin, "BYVAR;FS;<<LOADFS", False
    7/2/2008 12:09:45 PM: Executing: BYVAR;FS;<<LOADFS
    7/2/2008 12:09:45 PM: Que Exec: True, external_gps.skin, "", False
    7/2/2008 12:09:45 PM: Executing: 
    7/2/2008 12:09:45 PM: Leave Exec: False, external_gps.skin, , False
    7/2/2008 12:09:49 PM: Enter Exec: False, external_gps.skin, "EXIT2", False
    7/2/2008 12:09:49 PM: Que Exec: True, external_gps.skin, "EXIT2", False
    7/2/2008 12:09:49 PM: Executing: RUNQ;LSTOOLS\SB2.9_IG3\iGuidance\kill.exe
    7/2/2008 12:09:49 PM: Shell: "LSTOOLS\SB2.9_IG3\iGuidance\kill.exe"
    7/2/2008 12:09:50 PM: Que Exec: True, external_gps.skin, "EXIT", False
    7/2/2008 12:09:50 PM: Executing: EXIT
    7/2/2008 12:09:50 PM: Leave Exec: False, external_gps.skin, load;menu.skin, False
    7/2/2008 12:09:52 PM: Enter Exec: False, menu.skin, "LOAD;alt_menu_cont.skin", False
    7/2/2008 12:09:52 PM: Que Exec: True, menu.skin, "LOAD;alt_menu_cont.skin", False
    7/2/2008 12:09:52 PM: Executing: LOAD;alt_menu_cont.skin
    7/2/2008 12:09:52 PM: Leave Exec: False, menu.skin, LOAD;alt_menu_cont.skin, False
    7/2/2008 12:09:53 PM: Enter Exec: False, alt_menu_cont.skin, "MAIN", False
    7/2/2008 12:09:53 PM: Que Exec: True, alt_menu_cont.skin, "MAIN", False
    7/2/2008 12:09:53 PM: Executing: MAIN
    7/2/2008 12:09:54 PM: Leave Exec: False, alt_menu_cont.skin, load;menu.skin, False
    7/2/2008 12:09:54 PM: Enter Exec: False, menu.skin, "MAINBT1", False
    7/2/2008 12:09:54 PM: Que Exec: True, menu.skin, "MAINBT1", False
    7/2/2008 12:09:54 PM: Executing: BYVAR;MAINBUTTON1;AP01<<AP02<<AP03<<AP04<<AP05<<AP06<<AP07<<AP08<<AP09<<AP10<<AP11<<AP12<<AP13<<AP14<<AP15<<AP16<<AP17<<AP18<<AP19<<AP20<<AP21<<AP22<<AP23<<AP24<<AP25<<AP26<<AP27<<AP28<<AP29<<AP30<<AP31<<AP32<<AP33<<AP34<<AP35<<AP36<<AP37<<AP38<<AP39<<AP40<<AP41<<AP42<<AP43<<AP44<<AP45<<AP46<<AP47<<AP48<<AP49<<AP50<<AP51<<AP52<<AP53<<AP54<<AP55<<AP56<<AP57<<AP58<<AP59<<AP60<<AP61<<AP62<<AP63<<AP64<<AP65<<AP66<<AP67<<AP68<<AP69<<AP70<<AP71
    7/2/2008 12:09:54 PM: Que Exec: True, menu.skin, "AP01", False
    7/2/2008 12:09:54 PM: Executing: AUDIO
    7/2/2008 12:09:56 PM: Enter Exec: True, audio_player.skin, , False
    7/2/2008 12:09:56 PM: Que Exec: True, audio_player.skin, "SELPL", False
    7/2/2008 12:09:56 PM: Executing: SELPL
    7/2/2008 12:09:56 PM: Leave Exec: False, audio_player.skin, SELPL, False
    7/2/2008 12:09:59 PM: Enter Exec: False, audio_player.skin, "ESC", False
    7/2/2008 12:09:59 PM: Que Exec: True, audio_player.skin, "ESC", False
    7/2/2008 12:09:59 PM: Executing: ESC
    7/2/2008 12:09:59 PM: Leave Exec: False, audio_player.skin, load;menu.skin, False
    7/2/2008 12:10:00 PM: Enter Exec: False, menu.skin, "MAINBT7", False
    7/2/2008 12:10:00 PM: Que Exec: True, menu.skin, "MAINBT7", False
    7/2/2008 12:10:00 PM: Executing: BYVAR;MAINBUTTON7;AP01<<AP02<<AP03<<AP04<<AP05<<AP06<<AP07<<AP08<<AP09<<AP10<<AP11<<AP12<<AP13<<AP14<<AP15<<AP16<<AP17<<AP18<<AP19<<AP20<<AP21<<AP22<<AP23<<AP24<<AP25<<AP26<<AP27<<AP28<<AP29<<AP30<<AP31<<AP32<<AP33<<AP34<<AP35<<AP36<<AP37<<AP38<<AP39<<AP40<<AP41<<AP42<<AP43<<AP44<<AP45<<AP46<<AP47<<AP48<<AP49<<AP50<<AP51<<AP52<<AP53<<AP54<<AP55<<AP56<<AP57<<AP58<<AP59<<AP60<<AP61<<AP62<<AP63<<AP64<<AP65<<AP66<<AP67<<AP68<<AP69<<AP70<<AP71
    7/2/2008 12:10:00 PM: Que Exec: True, menu.skin, "AP07", False
    7/2/2008 12:10:00 PM: Executing: RUN;C:\Program Files\RoadRunner\Skins\LSX VOID 3.0\cleanup.exe
    7/2/2008 12:10:00 PM: Shell: "C:\Program Files\RoadRunner\Skins\LSX VOID 3.0\cleanup.exe"
    7/2/2008 12:10:00 PM: Que Exec: True, menu.skin, "VIZOFF||QUIT", False
    7/2/2008 12:10:00 PM: Executing: SETVAR;VIZSTAT;0
    7/2/2008 12:10:00 PM: Que Exec: True, menu.skin, "SAVETOSKIN;VIZSTAT;0", False
    7/2/2008 12:10:00 PM: Executing: SAVETOSKIN;VIZSTAT;0
    7/2/2008 12:10:00 PM: Que Exec: True, menu.skin, "QUIT", False
    7/2/2008 12:10:00 PM: Executing: QUIT
    7/2/2008 12:10:00 PM: Enter Exec: True, menu.skin, "ONEXIT", False
    7/2/2008 12:10:00 PM: Queued: "ONEXIT"
    7/2/2008 12:10:01 PM: Shutdown

  8. #78
    Variable Bitrate
    Auto Apps:loading...
    mezz64's Avatar
    Join Date
    Nov 2004
    Location
    PA
    Posts
    379
    Blog Entries
    1
    Just had an idea, since you've adapted the communication code written by mx270a I'm going to enable outputs with his program then run RR and switch some screens and see what happens.

    This should tell me whether or not it's a hardware conflict or an RR interfacing issue.

  9. #79
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,170
    Blog Entries
    52
    good idea.. that debug log looks normal. When you ran the debug log did you encounter the problems you described? if so it doesnt appear to be rrfusion related.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  10. #80
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,053
    The first batch did have the timer off when no USB communication happens. So if it is going off when switching screens that means during that time, no USB communication, so it shuts off perhaps. When you made the plugin, what did you set the timer bits to?
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

Similar Threads

  1. *NEW* USB Input/Output Board -- Fusion Brain
    By 2k1Toaster in forum Fusion Brain
    Replies: 1123
    Last Post: 02-22-2010, 02:33 AM
  2. Replies: 15
    Last Post: 09-22-2008, 08:02 AM
  3. Noob has some biginner questions about the Fusion Brain
    By phreaknes in forum Fusion Brain
    Replies: 14
    Last Post: 04-29-2008, 02:57 AM
  4. pc reboot on sd startup
    By duanes7 in forum StreetDeck
    Replies: 3
    Last Post: 12-14-2007, 08:55 AM
  5. Replies: 5
    Last Post: 10-22-2007, 08:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •