Page 3 of 16 FirstFirst 12345678910111213 ... LastLast
Results 21 to 30 of 151

Thread: RRUpd8 - Sync plugin for Road Runner Status : Updated 20/11/11

  1. #21
    FLAC Chuck's Avatar
    Join Date
    Sep 2003
    Location
    Ellicott City, MD
    Posts
    1,671
    Thanks Enforcer

    This is a very nice plugin and it would be nice to have a couple of other things.

    1: Have the rrupd8_automatic indicator work as a button also like rrupd8_popup does so you can do things like.

    To stop auto sync if on when you push stop
    “rrupd8_stop||BYIND;rrupd8_automatic;<<SETVAR;AUTO SET;1||BYIND;rrupd8_automatic;<<rrupd8_automatic”

    to start auto sync if it was on when you push start
    "rrupd8_start||BYVAR;AUTOSET;<<rrupd8_automatic||S ETVAR;AUTOSET;0"


    2: Have an option to have auto pop-up when copying only and not reading.

    3:Have it so when not in auto sync and you hit start it will only sync the highlighted line in the list or something like this.
    2001 S10 ZR2

    Chucks Skin - to old

  2. #22
    Confusion Master
    Auto Apps:loading...
    Enforcer's Avatar
    Join Date
    Sep 2003
    Location
    If you go down to the woods today, You're sure of
    Posts
    14,589
    I'll add to my todo list.

    However observations on first glance.

    1. will need to take longer to digest what you are saying here, so no observation.

    2. As the program doesn't make a list of the differences before copying, (it compares the files at the copy stage) this will only delay briefly the popup. But I will look into having an option that it will only trigger once it has found a file to copy.

    3. That shouldn't be a problem per se, but may need some core code rewrite.

  3. #23
    FLAC Chuck's Avatar
    Join Date
    Sep 2003
    Location
    Ellicott City, MD
    Posts
    1,671
    On the first one I simply mean make rrupd8_automatic work as a button command also – right now it will not work as a button just a indicator button.

    B09,98,180,70,70,"rrupd8_automatic",""
    2001 S10 ZR2

    Chucks Skin - to old

  4. #24
    Confusion Master
    Auto Apps:loading...
    Enforcer's Avatar
    Join Date
    Sep 2003
    Location
    If you go down to the woods today, You're sure of
    Posts
    14,589
    Quote Originally Posted by Bimmerstyle View Post
    Whouhou! I got it to do something! I tried one folder, and it copied the albumart to my test folder.

    Hmmmm... this opens perspectives! I have to play around with it a bit more just to see what the possibilities are but I'm pretty sure this could be useful add on to the skin.

    If the problems with the hidden and read only files could be solved that would be great.

    Could the reason for not getting the plugin version to work be that I'm still using the 04/11/07 version of RR. Don't really want to change that unless I really really have to. Call me old fashion but I'm sort of the "If it ain't broken don't try to fix it" type...

    EDIT: The problem with the Hadise folder was indeed that weird looking "i". I changed it to a normal "i" and now it reads the folder.

    Good.

    You'd be better off using the RRPlugin rather than the standalone one.

    Just tested it on the 04/11/07 RR version and it works fine, except for the indicators.


    What skin does and doesn't work, what skin are you using etc, etc.

  5. #25
    Variable Bitrate Bimmerstyle's Avatar
    Join Date
    Sep 2006
    Location
    Belgium
    Posts
    264
    I'll do some more testing on it and try to make the plugin work. I'll get back to you. (should however be doing some work on my skin also...)

    Thanks for the help so far. Looks promising!
    BMW 525tds -Biostar I94GM-I4 -Celeron M44O 1,86GHz, M2-ATX, 1Gb, 320GB -HQCT RDS tuner -Creative Extigy -iBus controller -Lilliput 7" touchscreen -DLS Ultimate A7 amplifier -Focal 130K, 130V, 27V2 speakers

    Bezel Worklog-My Install -iDrive F01 RR Skin

  6. #26

  7. #27
    Variable Bitrate Bimmerstyle's Avatar
    Join Date
    Sep 2006
    Location
    Belgium
    Posts
    264
    Hehe. I know.

    Well, been trying the plugin version. So far a no go.

    First I've changed my RR folder from "RoadRunner090907" to simply "RoadRunner". I've changed it to that back then when I've updated it to keep the original and never cared to changed it back. So now after some fiddling with my paths in shortcuts and ini files I got RR back to work.

    I tried the plugin this way and it won't show.

    Then I realized that I forgot to put the "x,rrupd8" in my menu skin. So I did that and still a no go. So I put it in my Utilities.skin also(from where I call upd8) and still no luck...

    I use my iDrive skin to call it and the Upd8 skin files are the BMV ones found here in the thirth post.

    What am I doing wrong here then..?
    BMW 525tds -Biostar I94GM-I4 -Celeron M44O 1,86GHz, M2-ATX, 1Gb, 320GB -HQCT RDS tuner -Creative Extigy -iBus controller -Lilliput 7" touchscreen -DLS Ultimate A7 amplifier -Focal 130K, 130V, 27V2 speakers

    Bezel Worklog-My Install -iDrive F01 RR Skin

  8. #28
    Confusion Master
    Auto Apps:loading...
    Enforcer's Avatar
    Join Date
    Sep 2003
    Location
    If you go down to the woods today, You're sure of
    Posts
    14,589
    You only need to put x,rrupd8 in the menu.skin

    and then the command rrupd8 is used to call the plugin.

    You have run the register.bat provided with the plugin haven't you?

  9. #29
    Variable Bitrate Bimmerstyle's Avatar
    Join Date
    Sep 2006
    Location
    Belgium
    Posts
    264
    Yep, registered it and put the "x,rrupd8" in the menu.skin. Did those things...

    this is the bottom part of my Menu.skin:

    Code:
    L,240,478,450,42,150,150,150,24,"Arial Narrow","=Utilities","LEFT"
    L,18,566,56,29,80,50,40,18,"Arial:B","=Exit","LEFT"
     
    /, I, x, y, w, h, Code;INDICATORCODES
    I,40,270,111,129,"MASTERMUTE"
     
    x,rrupd8
    
    END
    This is the button in my utilities skin to call it:

    Code:
    B,91,141,709,63,"rrupd8",""
    The Upd8 files are located at: C:\Program Files\RoadRunner\Plugins\RRUpd8\

    Looks like I did it all the way it's supose to. Not?
    BMW 525tds -Biostar I94GM-I4 -Celeron M44O 1,86GHz, M2-ATX, 1Gb, 320GB -HQCT RDS tuner -Creative Extigy -iBus controller -Lilliput 7" touchscreen -DLS Ultimate A7 amplifier -Focal 130K, 130V, 27V2 speakers

    Bezel Worklog-My Install -iDrive F01 RR Skin

  10. #30
    Confusion Master
    Auto Apps:loading...
    Enforcer's Avatar
    Join Date
    Sep 2003
    Location
    If you go down to the woods today, You're sure of
    Posts
    14,589
    Moved posts relating to plugin to the plugin folder.

    That looks OK to me.

    add debugmode=true to rr.ini

    add debug=true to upd8.ini

    and then post the debug.txt files.

Similar Threads

  1. Filesystem Sync Plugin
    By smeesseman in forum CF Plugins
    Replies: 27
    Last Post: 02-03-2010, 11:11 AM
  2. List of available plugins and features
    By JohnWPB in forum RR Plugins
    Replies: 5
    Last Post: 10-25-2008, 06:16 PM
  3. pc reboot on sd startup
    By duanes7 in forum StreetDeck
    Replies: 3
    Last Post: 12-14-2007, 08:55 AM
  4. Replies: 0
    Last Post: 03-31-2007, 10:12 PM
  5. How do I use the Base plugin sources ?
    By guino in forum RR FAQ
    Replies: 1
    Last Post: 04-24-2006, 03:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •