Page 32 of 34 FirstFirst ... 22232425262728293031323334 LastLast
Results 311 to 320 of 340

Thread: RRExtended [ v1.20 Updated 01/21/12 ]

  1. #311
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    EricE, please check that you have your time zone set properly, aside from that, I have tried to change both a few RR settings and Win regional settings and can not reproduce your results for those coords. Anything else that you can tell me about your setup that might narrow down what is causing your odd times?
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  2. #312
    Variable Bitrate
    Join Date
    Feb 2006
    Posts
    393
    Time zone is set to US pacific. I tried changing time format on the computer to 24 hrs time and did same in RR but that didn't change anything as far as the sunrise/sunset times. Sorry, I don't know what else to look at. I do know that I have always had this problem. I have never been able to use the GPS to set time of the computer and I have never gotten the sunrise/sunset times working to spite having this car computer up and running for years (though I recently replaced computer and op sys to win 7). That seems to leave the common denominator as the GPS. RR reads speed from the GPS just fine and when I put those coordinates into google maps it takes me to the place I expect.

  3. #313
    Constant Bitrate mstaedt's Avatar
    Join Date
    Dec 2007
    Posts
    164
    EricE, I'm having the same problem. So are some others....
    http://www.mp3car.com/road-runner/14...ne-labels.html

    The labels work correctly on my laptop, which is running XP and does not have a GPS puck installed.
    They do not work on my truck, which is Win7. I've tried it with the GPS operational and not operational, same result. I tried RR 11-10, 3-11, and 4-11... same result.
    I also installed RR and RRextended on my Win7 desktop last night (no GPS), and it does not work there either.


    Last night in my truck the SunSetTime changed from 24:44 to 24:45 and this morning the SunRiseTime moved from 12:00 PM to 11:59 AM, so at least it is watching the clock and performing SOME sort of calculation.
    --------------------------------
    Project completed! (almost)

    My Truck as featured in Custom Classic Trucks magazine.

  4. #314
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Well, I would have said that win7 is the culprit but EricE said that he's been running the computer for years, and has never got it work, unless i'm misinterpreting his statement. And i don't see why it would change anything as its mostly just a ton of math equations. The only thing that comes to mind would be when it looks to see what time zone your OS is set to, and maybe win7 has to be retreived differently than XP? This is something that I will have to check on, that could certainly be something that would throw off the computed times...
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  5. #315
    Constant Bitrate mstaedt's Avatar
    Join Date
    Dec 2007
    Posts
    164
    I just did a quick RRextended install onto another XP laptop running RR 11-10 - works perfectly.

    Was EricE's installation that never worked previous to upgrading his OS to Win7 on XP? or Vista?
    --------------------------------
    Project completed! (almost)

    My Truck as featured in Custom Classic Trucks magazine.

  6. #316
    Variable Bitrate
    Join Date
    Feb 2006
    Posts
    393
    Quote Originally Posted by mstaedt View Post
    I just did a quick RRextended install onto another XP laptop running RR 11-10 - works perfectly.

    Was EricE's installation that never worked previous to upgrading his OS to Win7 on XP? or Vista?
    My previous install was XP.
    Over the weekend I wrote my own custom plugin that works for me. It writes to the skin.ini and sets the skin variables for DNE. Works fine and only uses date and Lat/Lon. I see no reason to release it as this plugin works for most people but perhaps you could try it and see if it will work for you. PM me if you want to try it.

  7. #317
    Constant Bitrate mstaedt's Avatar
    Join Date
    Dec 2007
    Posts
    164
    Blue ZX3,

    Have you gotten anywhere with this? EricE's plugin only works with DFX skin, which I don't use. I looked into the math involved for calculating sunrise and sunset, and it doesn't look all that tough. It could probably be done with just the EVAL command if there is an "arccos" (inverse cosine) function available.
    Thanks....
    Mark
    --------------------------------
    Project completed! (almost)

    My Truck as featured in Custom Classic Trucks magazine.

  8. #318
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Just a update bump post, check first post...
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  9. #319
    Newbie
    Join Date
    Oct 2005
    Location
    Albuquerque, NM
    Posts
    24
    Blue ZX3;

    I am having a problem with sequence of execution of the RndVar function. During evaluation of a calculation the RndVar function is executed last regardless of the sequence of the statement.
    I have the following commands in the ExecTBL.ini file;

    "KVHParseGPS","KVHGetCords||KVHRndCords||KVHSetGps Cmd"
    "KVHGetCords","SETVARBYCODE;KVHLAT;GPSLAT||SETVARB YCODE;KVHLON;GPSLON||EVAL;KVHLON;$KVHLON$ * -1"
    "KVHRndCords","RNDVAR;$KVHLAT$;0;KVHLAT||RNDVAR;$K VHLON$;0;KVHLON"
    "KVHSetGpsCmd","SETVAR;KVHGPSCMD;$KVHLAT$,N,$KVHLO N$,W"

    When calling KVHParseGPS, the sequence should be;
    1. Get the current GPS Coordinates.
    2. Round the coordinates to a whole number and turn the longitude to a positive number.
    3. Set a string to the format “GPS,##,N,###,W” to be executed by an external program.

    A debug of the execution shows;

    SETVARBYCODE;KVHLAT;GPSLAT
    SETVARBYCODE;KVHLON;GPSLON
    EVAL;KVHLON;-107.1234 * -1
    SETVAR;KVHGPSCMD;GPS,32.3456,N,107.1234,W
    SETVAR;KVHLAT;32
    SETVAR;KVHLON;107

    The last two statements are the RndVar function calls even though they were to be executed before the SETVAR;KVHGPSCMD

    Does RideRunner execute native functions before calling functions defined in a plugin?

    No sequence of intervening statments, wait functions, etc will force the proper sequence. The only way I have been able to make it work is to remove the KVHSetGpsCmd command entirely from the line and execute it with a totaly seperate button command.

    Any help would be appreciated.

  10. #320
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Fixed, re-download v1.1.9

    Your cmd syntax's are correct, was a plugin bug
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

Similar Threads

  1. Volume too low on AUX line in, coming out of laptop.
    By Silenkiller in forum Car Audio
    Replies: 4
    Last Post: 10-07-2008, 08:45 PM
  2. iPod Integration Coming
    By Lazyflip in forum Centrafuse
    Replies: 2
    Last Post: 03-20-2008, 01:14 AM
  3. USB Hub not working after coming out of hibernation
    By volum3rider in forum Input Devices
    Replies: 25
    Last Post: 09-11-2005, 01:07 PM
  4. NEW playstation II portable keyboard coming out soon
    By clean customs in forum Input Devices
    Replies: 3
    Last Post: 03-04-2005, 04:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •